
DIAdemTM

Basics Course Manual
Course Software Version 9.1
November 2004 Edition
Part Number 323027E-01
DIAdem Basics Course Manual
National Instruments Ireland Resources Limited

Copyright

© 2004 National Instruments Ireland Resources Limited. All rights reserved. 
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including 
photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent 
of National Instruments Corporation.

Trademarks
DIAdem™, National Instruments™, NI™, and ni.com™ are trademarks of National Instruments Corporation.
Product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents
For patents covering National Instruments products, refer to the appropriate location: Help»Patents in your software, 
the patents.txt file on your CD, or ni.com/legal/patents.



Worldwide Technical Support and Product Information
ni.com

National Instruments Corporate Headquarters
11500 North Mopac Expressway Austin, Texas 78759-3504 USA Tel: 512 683 0100

Worldwide Offices
Australia 03 9879 5166, Austria 0662 45 79 90 0, Belgium 02 757 00 20, Brazil 011 3262 3599, Canada (Calgary) 403 274 9391, 
Canada (Montreal) 514 288 5722, Canada (Ottawa) 613 233 5949, Canada (Québec) 514 694 8521, 
Canada (Toronto) 905 785 0085, China (Shanghai) 021 6555 7838, China (ShenZhen) 0755 3904939, 
Czech Republic 02 2423 5774, Denmark 45 76 26 00, Finland 09 725 725 11, France 01 48 14 24 24, Germany 089 741 31 30, 
Greece 30 1 42 96 427, Hong Kong 2645 3186, India 91 80 4190000, Israel 03 6393737, Italy 02 413091, Japan 03 5472 2970, 
Korea 02 3451 3400, Malaysia 603 9596711, Mexico 001 800 010 0793, Netherlands 0348 433466, New Zealand 09 914 0488, 
Norway 32 27 73 00, Poland 0 22 3390 150, Portugal 351 210 311 210, Russia 095 238 7139, Singapore 6 2265886, 
Slovenia 386 3 425 4200, South Africa 11 805 8197, Spain 91 640 0085, Sweden 08 587 895 00, Switzerland 056 200 51 51, 
Taiwan 02 2528 7227, United Kingdom 01635 523545



Contents
Student Guide
About This Manual ....................................................................................................viii
What You Need to Get Started .................................................................................. ix
Installing the Course Software ...................................................................................x
Course Goals ..............................................................................................................xi
Course Conventions ...................................................................................................xii

Lesson 1
Introduction to DIAdem

A. The Modular DIAdem Concept ............................................................................1-2
B. The Structure of DIAdem Panels..........................................................................1-3
C. The DIAdem Help ................................................................................................1-6
D. Configuring DIAdem............................................................................................1-7
Summary, Tips, and Tricks.........................................................................................1-12

Lesson 2
Generating Your First Report

A. Working with the Report Wizard..........................................................................2-2
Summary, Tips, and Tricks.........................................................................................2-6

Lesson 3
Managing Data

A. Loading, Managing, and Saving Data ..................................................................3-2
B. Navigating External Data with DIAdem NAVIGATOR......................................3-4
C. Managing Data in the Data Portal.........................................................................3-13
D. Working with the Data Properties ........................................................................3-19
E. Working with DAT Files ......................................................................................3-28
F. Configuring DIAdem NAVIGATOR ...................................................................3-30
Summary, Tips, and Tricks.........................................................................................3-31
© National Instruments Ireland Resources Limited iii DIAdem Basics Course Manual



Contents
Lesson 4
Viewing Data

A. Viewing, Measuring, and Editing Data ................................................................4-2
B. Creating a Layout..................................................................................................4-4
C. Viewing Data as Curves .......................................................................................4-6
D. Describing an Evaluation in Textboxes ................................................................4-19
E. Editing Data in Channel Tables ............................................................................4-23
F. Configuring DIAdem VIEW ................................................................................4-33
Summary, Tips, and Tricks.........................................................................................4-35

Lesson 5
Creating Reports

A. Documenting Data ................................................................................................5-2
B. Creating a Report ..................................................................................................5-3
C. Printing a Report ...................................................................................................5-26
D. Saving the Layout .................................................................................................5-27
E. Format and Display Modes...................................................................................5-31
F. Configuring DIAdem REPORT............................................................................5-49
Summary, Tips, and Tricks.........................................................................................5-51

Lesson 6
Analyzing Data with Mathematics Functions

A. Analyzing and Evaluating Data ............................................................................6-2
B. Running Calculations............................................................................................6-4
C. Calculating with Invalid Values ...........................................................................6-38
Summary, Tips, and Tricks.........................................................................................6-40

Lesson 7
Automating Tasks

A. Automating Processes...........................................................................................7-2
B. DIAdem SCRIPT Toolbar ....................................................................................7-4
C. Script Structure and Syntax ..................................................................................7-5
D. Creating a Script ...................................................................................................7-7
E. Tools that Help You to Create Scripts ..................................................................7-9
F. Editing Scripts.......................................................................................................7-17
G. Configuring DIAdem SCRIPT .............................................................................7-32
Summary, Tips, and Tricks.........................................................................................7-33
DIAdem Basics Course Manual iv ni.com



Contents
Lesson 8
The DIAdem Calculator

A. Using the DIAdem Calculator ..............................................................................8-2
B. Working with the Calculator.................................................................................8-4
C. Operands, Operations, and Auxiliary Variables ...................................................8-8
D. Additional Notes ...................................................................................................8-15
Summary, Tips, and Tricks.........................................................................................8-27

Lesson 9
Additional Exercises

A. Example I ..............................................................................................................9-2
B. Example II.............................................................................................................9-13
C. Example III ...........................................................................................................9-42

Lesson 10
Loading External Data

A. DIAdem Data Organization ..................................................................................10-2
B. Loading External Data ..........................................................................................10-3
Summary, Tips, and Tricks.........................................................................................10-34

Lesson 11
3D Data Display

A. Organizing 3D Data ..............................................................................................11-2
B. Displaying 3D Data ..............................................................................................11-5
Summary, Tips, and Tricks.........................................................................................11-36

Appendix A
Evaluating Crash Data

A. Working with the Crash Analysis Functions ........................................................A-2
Summary, Tips, and Tricks.........................................................................................A-47
© National Instruments Ireland Resources Limited v DIAdem Basics Course Manual





Student Guide
Thank you for purchasing the DIAdem Basics course kit. This course 
manual and the accompanying software are used in the three-day, hands-on 
DIAdem Basics course.

You can apply the full purchase of this course kit toward the corresponding 
course registration fee if you register within 90 days of purchasing the kit. 
Visit ni.com/training to register for a course and to access course 
schedules, syllabi, and training center location information.
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Student Guide
A. About This Manual
This course manual teaches you how to use DIAdem to load and manage 
data, to run mathematical and visual analyses, to generate reports, and to 
automate work sequences. This course manual assumes that you are familiar 
with Microsoft Windows.

The course manual is divided into lessons, each covering a topic or a set of 
topics. Each lesson consists of the following:

• An introduction that describes the purpose of the lesson and what you 
will learn

• A description of the topics in the lesson

• A set of exercises to reinforce those topics

Some lessons include optional exercise sections or a set of additional 
exercises to complete if time permits.

• A summary that outlines important concepts and skills taught in the 
lesson
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Student Guide
B. What You Need to Get Started
Before you use this course manual, make sure you have the following items:

❑ Windows XP Pro Service Pack 1 or later, Windows 2000 Service Pack 
3 or later, or Windows NT 4 Service Pack 6 or later 

Caution! DIAdem does not run with these Windows systems if they do not have the  
Service Packs. DIAdem does not run with Windows 95/98/Me

❑ Internet Explorer, Version 5 or later

❑ DIAdem Professional Edition 9.1 including the Crash Analysis Toolset

❑ Microsoft Windows Script Debugger
which you can download from Microsoft Windows Script Downloads

❑ DIAdem Basics CD, which contains the following files:

Filename Description

Bin Folder with the files for the CD user interface

Exercises Folder with the files for all the exercises

Solutions Folder containing the solutions to all the 
course exercises
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Student Guide
C. Installing the Course Software
Complete the following steps to install the course software.

1. Insert the DIAdem Basics CD. 

2. Copy the contents of the Exercises folder to the top level of the 
C:\ folder.

3. Copy the contents of the Solutions folder  to the top level of the 
C:\ folder.
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D. Course Goals
This course presents the following topics:

• Importing and managing data

• Inspecting data, including graphically-interactive analysis

• Mathematical data analysis

• Creating presentation graphics and reports

• Automating work sequences with Visual Basic Script

This course does not describe any of the following:

• Programming with Visual Basic Script

• Creating DIAdem applications

These topics are covered by the DIAdem Advanced course. Refer to  
ni.com for information on DIAdem Advanced course.
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Student Guide
E. Course Conventions
The following conventions are used in this course manual:

<> Angle brackets indicate a key you press to perform a function, for example, 
<Ctrl> for the control key.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 
avoid injury, data loss, or a system crash.

bold Bold text denotes items that you must select or click in the software, such as 
menu items and dialog box options. Bold text also denotes menu names, 
functions, or buttons.

italic Italic text denotes emphasis, new terms, a cross reference, or an introduction 
to a key concept.

monospace Text in this font denotes text or characters that you enter from the keyboard, 
sections of code, programming examples, and syntax examples.
This font also is used for the proper names of disk drives, paths, folders, 
programs, subprograms, subroutines, functions, operations, commands, 
variables, controls, events, methods, filenames, and filename extensions.
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Lesson 1
Introduction to DIAdem
Introduction
This lesson introduces the basics of DIAdem.

Use the Getting Started with DIAdem manual to get started with DIAdem 
quickly. Use this manual to familiarize yourself with how DIAdem works 
and with the various functions and features in DIAdem. For more 
information about the DIAdem concepts, refer to the manual DIAdem: Data 
Analysis and Report Generation.

To view a PDF (Portable Document Format) version of the DIAdem 
manuals in the DIAdem Help, select Contents»DIAdem»Additional 
Information Sources, or refer to the DIAdem CD.

You Will Learn About: 

A. The Modular DIAdem Concept

B. The Structure of DIAdem Panels

C. The DIAdem Help

D. Configuring DIAdem
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Lesson 1 Introduction to DIAdem
A. The Modular DIAdem Concept
DIAdem is designed to help you manage, inspect, and analyze data and 
generate reports so you can transform test data to the results you need. 
DIAdem includes a separate panel for each function - managing data, 
viewing data, analyzing data, creating reports, and automating your analysis 
and reports. 

DIAdem includes the following panels:

Use DIAdem NAVIGATOR to navigate in various data types and data 
storages. You drag and drop your data into DIAdem.

Use DIAdem VIEW to view your data as curves or to edit single values in 
tables.

Use DIAdem ANALYSIS to mathematically evaluate your data using 
standard functions from the extensive mathematics libraries or using your 
own formulas.

Use DIAdem REPORT to generate reports of your test data and analysis 
results. 

Use DIAdem SCRIPT to automate recurring tasks, from loading data, to 
analysis, to report generation, using scripts.
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Lesson 1 Introduction to DIAdem
B. The Structure of DIAdem Panels
When you select a DIAdem panel, the group bars, function bars, and menus 
appear for quick access to the functions you want. Each DIAdem panel has 
its own group bar to the right of the panel bar. Click a function bar button in 
the group bar and select the function you want when the function bar opens. 
The workspace also changes with the DIAdem panel and displays a folder 
hierarchy or a worksheet. Each panel has its own toolbar and shortcut 
menus, which contain frequently used functions.

Figure 1-1 shows DIAdem VIEW as an example of the structure of a 
DIAdem panel.

Figure 1-1.   DIAdem VIEW as an Example of the DIAdem Window Structure

1 Panel bar
2 Group bar
3 Function bar with tables and axis systems
4 ToolTip for the selected function

5 DIAdem VIEW toolbar
6 Data Portal
7 DIAdem VIEW workspace
8 Status bar
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Lesson 1 Introduction to DIAdem
The DIAdem Panels
The DIAdem panels constitute the main level, where functions are grouped 
into related areas. The panels are arranged on the left side of the screen and 
are always visible, enabling you to switch from one panel to another. All the 
DIAdem modules read data into and out of the Data Portal.

The Functions
When you click a panel, the respective group bar appears next to the panel 
bar. This second level contains groups of related functions. Click an item in 
the group bar to open the associated function bar, and select the function you 
want. For example, you can select axis systems and tables in DIAdem 
REPORT or select mathematical functions in DIAdem ANALYSIS. 
DIAdem carries out actions in the panel workspace. 

Note You can purchase the DIAdem Base, Advanced, and Professional editions. If you 
install the Base edition, the function bar buttons and group bar buttons for the functions 
not included in the Base edition are dimmed.

You can modify all default settings at any time. Right-click the function bar 
button of the function you want to modify. Select Default setting in the 
shortcut menu. The dialog box for the function appears. Click Change to 
save the new settings.

The Workspace
Each DIAdem panel has a different workspace for displaying and editing 
functions. DIAdem VIEW has a predefined workspace, where you enable 
axis systems and tables for an overview of your data. The DIAdem REPORT 
workspace is an empty page where you can position and resize axis systems, 
tables, text, comments, and pictures.

You always edit objects in the workspace in the same way: click an object 
once to enable it. Double-click an object to set the object parameters in a 
dialog box. Right-click to open the shortcut menu.

The toolbar is above the workspace. The toolbar contains the functions that 
you require to work in the panel.

The status bar is below the workspace. The status bar displays messages, 
ToolTips, and notes about the functions of the selected objects and actions.

Shortcut menus are of key importance in DIAdem. The shortcut menu 
contains the functions you require to work with the object you click. Some 
functions are only located in shortcut menus, such as the browser settings in 
DIAdem NAVIGATOR and generating data in DIAdem VIEW channel 
tables. 
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Lesson 1 Introduction to DIAdem
The Dialog Boxes
DIAdem often needs additional information to execute a command or an 
action. Enter this additional information, called settings, into a feature-
specific dialog box.

Double-click a 2D axis system in the workspace in DIAdem REPORT. 
Figure 1-2 shows the dialog box for curve and axis definition.

Figure 1-2.  Dialog Box for 2D Curve and Axis Definition in DIAdem REPORT

The curve and axis definition demonstrates the hierarchy of the DIAdem 
dialog boxes. Basic settings such as channel pairs, which you often change, 
are in the main dialog box. Other settings, such as the axis scaling, are in 
subdialog boxes that you click a button to open.
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C. The DIAdem Help
DIAdem has four kinds of help: ToolTips for the user interface, the dialog 
box help for all the settings, and the help contents, with descriptions and 
examples.

ToolTips describe the button functions. When you idle the mouse over a 
button, a yellow field with the button name appears.

Click the Help button in a dialog box to access the description of the dialog 
box. The dialog box help describes the single settings in the open dialog box 
and refers you to other explanations. You also can press <F1> to access the 
help for the dialog box or panel.

Select Help»Examples to display demos. The user templates provide 
solutions for simple tasks, whereas the application examples demonstrate 
the range of DIAdem applications. 

You can start examples directly in the DIAdem help. Click Start example 
to display the example in DIAdem. Press <Esc> to abort the example. Click 
Copy example files to copy example files to your folder. 
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Lesson 1 Introduction to DIAdem
D. Configuring DIAdem
You can configure various program settings in DIAdem. The program 
settings can be general program behavior settings or specific panel settings. 
You can set memory management parameters in the data area, and configure 
the folder structure. Use the Settings menu to adapt the program settings to 
your requirements.

To save your settings in a configuration file, first select Window»Close all. 
Then click Save desktop. Click Load desktop to load a project-related 
configuration. Refer to the DIAdem Help for more information about 
configuration.

Note Each lesson that describes a new panel includes a description of the panel settings 
at the end.

The Folder Structure
DIAdem installs folders on three levels, as shown in Figure 1-3:

Figure 1-3.  DIAdem Folder Structure

1. The program level contains program files (.exe,.dll), control files, 
and the ReadMe file.
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Lesson 1 Introduction to DIAdem
2. The structure level divides the files:

3. The file level contains files from all DIAdem panels in different folders:

ADDINFO System files

DEMO Exercises from the manual

LIBR Examples, demos, and templates

SYMBOLS System files

USER User files

AUT Scripts (.vbs, .aut)
Compiled scripts (.vbc,. suc, .auc)
List files (.lst)
Variable definitions (.vas)
User dialog boxes (.sud)

DAT Header files (.tdm, .dat)
Data files (.tdx, .r64, .i16 and others)

GRA REPORT layouts (.tdr, .lpd)
Metafiles (.wmf,.bmp,.tif,.jpg and others)
VIEW layouts (.tdv)
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Lesson 1 Introduction to DIAdem
Exercise 1-1
Objective: Configuring the File Paths

In the following exercise you select the solutions folder path as the library 
path, and the exercise folder path as the user path, and DIAdem then 
displays all the course files in the file selection dialog boxes.

1. Select Window»Close all.

2. Select Settings»General.

3. Click Path selection.
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Lesson 1 Introduction to DIAdem
4. Click the Setting line next to the NAVIGATOR library path.

5. Click Path selection and navigate to the C:\Solutions\DIAdem 
Basics\ folder.

Click OK.

6. Click the Setting line next to the NAVIGATOR user path.

7. Click Path selection and open the C:\Exercises\DIAdem Basics\ 
folder.

Click OK.

8. Repeat steps 4 and 5 for all other library paths.

9. Repeat steps 6 and 7 for all other user paths.
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Lesson 1 Introduction to DIAdem
The path selection dialog box looks like this:

10. Click OK to close all the dialog boxes.

11. Click Save desktop in the toolbar.

Navigate to the C:\Programme\National Instruments\DIAdem 
9.1\ folder and overwrite the desktop file Desktop.ddd.

End of Exercise 1-1 
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Lesson 1 Introduction to DIAdem
Summary, Tips, and Tricks

• DIAdem is modular. Each DIAdem panel is designed for specific tasks 
and therefore contains specific functions. Switch between the DIAdem 
panels in the panel bar.

• Use DIAdem NAVIGATOR to navigate in various data types and data 
storages.

• Use DIAdem VIEW to view your data as curves or to edit single values 
in tables.

• Use DIAdem ANALYSIS to mathematically evaluate your data using 
standard functions from the extensive mathematics libraries or using 
your own formulas.

• Use DIAdem REPORT to generate reports of your test data and analysis 
results.

• Use DIAdem SCRIPT to automate recurring tasks, from loading data, to 
analysis, to report generation, using scripts.

• DIAdem has four kinds of help: ToolTips for the user interface, the 
dialog box help for all the parameters, and the help contents, with 
descriptions and examples. 
Press <F1> to open the help in each panel. Click the Help button in the 
respective dialog box for help with the individual functions.

• You can configure various program settings in DIAdem. To save your 
settings in a configuration file, first select Window»Close all. Then 
click Save desktop.
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Notes
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Lesson 2
Generating Your First Report
Introduction
This lesson describes the Report Wizard, which you use to create a report in 
three easy steps. 

You Will Learn About: 

A. Working with the Report Wizard
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Lesson 2 Generating Your First Report
A. Working with the Report Wizard
Use the DIAdem Report Wizard to generate a report. You can generate a 
report in three easy steps: 

1. Select the data,

2. Specify the curves, and

3. Specify the layout for the axis system. 

DIAdem uses your settings to generate the report, which you can add 
comments to and illustrate with graphics in DIAdem REPORT. If you select 
a VIEW layout in the last step of the Report Wizard, DIAdem creates a 
layout in DIAdem VIEW, where you can view your data as a curve.

By default, the Report Wizard opens when you launch DIAdem. To modify 
the default setting, select Settings»Desktop parameters»General. You can 
click the Report Wizard button in the toolbars of the DIAdem REPORT and 
DIAdem VIEW panels, or press <Ctrl-W> in all other panels to open the 
Report Wizard.
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Lesson 2 Generating Your First Report
Exercise 2-1 
Objective: Creating Your First Report with the Report Wizard

In the following exercise, you create a report with the Report Wizard, simply 
by selecting the data and the layout.

1. If the Report Wizard does not open when you launch DIAdem, press 
<Ctrl-W>.

If Report Wizard Step 1 of 3 does not appear, click Next or Back to open 
this page.

2. Select FILES: My DIAdem 9.1 as the data source.

3. Open the folder C:\Exercises\DIAdem Basics.

4. Select the file D3Display_1.tdm. 

The simplest type of data storage is a folder with data files. My 
Computer provides all the drives on your computer. Other available 
data storages include Citadel, SQL, and AOP databases, VI Logger files, 
and ATF files.

5. Click Next to open the Report Wizard - step 2 of 3 dialog box.

In the second step, the Report Wizard analyzes the loaded data channels. 
The Report Wizard interprets time and frequency channels as 
x-channels, and interprets the other channels as y-channels. The Report 
Wizard assigns an x-channel to each y-channel.
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Lesson 2 Generating Your First Report
To change the x/y-channel pairs that DIAdem displays, click in the table 
and select another x-channel at the bottom of the wizard page. Set Use 
as No for channels you do not want to display.

6. Click Next to open the Report Wizard - step 3 of 3 dialog box.

7. Click Y-axes to display all curves on one x-axis, in one axis system, 
with several y-scales.

8. Click the Finish button. 
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Lesson 2 Generating Your First Report
DIAdem displays the report.

Note You can switch back and forth among the three steps to change your settings. In 
each step you can click Finish to bypass the remaining steps and create the report. 
DIAdem uses standard settings for steps you leave out.

9. Click Save layout as.

Navigate to the C:\Exercises\DIAdem Basics\ folder and save the 
report file as MyFirstReport.tdr.

End of Exercise 2-1 
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Lesson 2 Generating Your First Report
Summary, Tips, and Tricks

• The DIAdem Report Wizard opens when you press <Ctrl-W>. You can 
use the Wizard to create your first report.

• Use the Report Wizard to generate a report in three steps:

– First select the data you want to display.

– Specify the x and y-channels for the curves.

– Select the curve display mode.

• The Wizard either creates a view in a new DIAdem VIEW worksheet, or 
DIAdem creates a report in the current DIAdem REPORT worksheet, 
according to your specifications. 
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Notes
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Lesson 3
Managing Data
Introduction
In this lesson you will learn how to load data and manage data in DIAdem.

You Will Learn About: 

A. Loading, Managing, and Saving Data

B. Navigating External Data with DIAdem NAVIGATOR

C. Managing Data in the Data Portal

D. Working with the Data Properties

E. Working with DAT Files

F. Configuring DIAdem NAVIGATOR
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Lesson 3 Managing Data
A. Loading, Managing, and Saving Data
You load, manage, and save your data in the DIAdem NAVIGATOR panel. 

In DIAdem NAVIGATOR, you navigate data files, file folders, and 
databases to find your external data. The properties window displays the 
properties of a selected data set. You load the data set into the Data Portal, 
which manages all internal data and makes the data accessible for all 
DIAdem panels.

The data in the Data Portal is organized in channels, and each channel is a 
separate series of data. You can group several channels into channel groups 
to sort and prepare your data for evaluations and presentations.

Figure 3-1 shows the DIAdem NAVIGATOR interface, with the properties 
window and the Data Portal.

Figure 3-1.   DIAdem NAVIGATOR with the Data Portal

1 Function bar for “File-based data storage”
2 Display all registered files
3 Select data set in DIAdem NAVIGATOR
4 Properties window with the properties of the selected 

external data set

5 Loaded data set is a new group in the 
Data Portal

6 Property window of the Data Portal 
displays the properties of the internal 
data
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Lesson 3 Managing Data
Use the function bars File-based data storage and Server-based data 
storage to reduce the external data storage display in DIAdem 
NAVIGATOR to the files and servers needed. 

The toolbar has functions for loading external data into the Data Portal and 
for saving and deleting the internal data storage in the Data Portal. You also 
can register and filter the data storage.

Shortcut menus are important for data management. Right-click in the 
DIAdem NAVIGATOR to open the browser settings. If you right-click a 
data set in DIAdem NAVIGATOR, DIAdem registers large data sets without 
loading the data. Right-click the Data Portal to create new channels and 
channel groups. 
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Lesson 3 Managing Data
B. Navigating External Data with DIAdem NAVIGATOR
The DIAdem NAVIGATOR displays your external data as a tree view, 
which is a hierarchical view. You can navigate data on your computer, on 
other network drives, and on all registered databases.

Use the function bar to select the type of data storage you navigate in. You 
can display file-based or server-based data storages. If you select file-based 
data storage, DIAdem displays the data files that are on your computer 
drives or on the network. If you select server-based data storage, DIAdem 
displays the data that are in the registered databases.

You can use the associated properties to configure the view of the data you 
want displayed in a way that enables you to find the data quickly, even in 
extensive data storages.

Use filter settings to limit the number of files listed in DIAdem 
NAVIGATOR. Select View»Filter settings to open the dialog box for filter 
settings. For example, to view all Test files from a certain date, enter the 
name Test.* and the storage date.

Select Settings»Desktop parameters»Panel specific in DIAdem 
NAVIGATOR to specify which data storage DIAdem automatically loads 
when it launches.

The properties window in DIAdem NAVIGATOR shows the properties of 
selected data storage, such as the name, the size, and the storage date of a 
file, or folder attributes. If the properties window is not open, click and drag 
up the bottom edge of the NAVIGATOR window.

Loading Data
To load DIAdem data, click DIAdem 9 files (*.tdm) in the function bar for 
file-based data storage. All the drives registered on your computer appear in 
DIAdem NAVIGATOR. Open the folder with the data you want. Drag and 
drop the data file into the Data Portal. DIAdem creates a new channel group, 
copies the contents of the file, and lists all the file channels in this group.

DIAdem automatically uses the associated loading procedure for the data 
type. If DIAdem cannot automatically load a file, you can specify the 
loading procedure. For example, if you want to load an earlier LabVIEW file 
in ASCII format, right-click the file and select Open with from the shortcut 
menu. In the dialog box that appears you specify the ASCII import loading 
procedure, to import LabVIEW data.

When you browse through a database, you can drag and drop channels and 
channel groups into the Data Portal. DIAdem displays selected channels, 
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channel groups or files that you can load into the Data Portal, with a blue 
background.

For example, select Selective opening in the shortcut menu to load single 
channels from a TDM file. Click the plus signs to view channels and channel 
groups in this data file. Select the channels you want and click Load. 
DIAdem loads the selected channels and adds the channels from the default 
group in the Data Portal.

You can work with large data sets in the Data Portal without actually loading 
the data. To do this, you register the data in DIAdem. To register a data file, 
select Register data in the shortcut menu. Double-click the data file to 
register individual channels. Select the channels and click Register in the 
dialog box that appears. 

You can display and calculate registered data, but you cannot modify 
registered data. To edit a registered channel, select Expand channel in the 
Data Portal shortcut menu. DIAdem then loads the associated data into the 
Data Portal.

Registering Data Storage
The data storage manager displays all the data storages available in 
DIAdem. You can configure, delete, and select the available data storage 
and load the data storage into DIAdem NAVIGATOR. You also can register 
new data storages in the data storage manager.

To register a new data storage, select File»Change data storage. The data 
storage manager appears with the registered data storage, in a hierarchical 
structure. For example, select the data storage type SQL for a database. 
Double-click New data storage to register the new SQL database. Enter a 
name and the settings.

The data storages available in the function bars have predefined names in the 
data storage manager, for example,  Default SQL for ODBC/SQLb data. 
Do not delete the predefined data storage. You can modify the configuration 
of the predefined data storage for quick access to frequently-used data. For 
example, if you want to change the registered SQL database for the 
ODBC/SQL data, right-click Default SQL in the data storage manager. 
Select Properties and switch databases.
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Supported Data Storage
DIAdem uses many file formats and databases. The data storage manager 
and the dialog box for loading procedures contain information about which 
data the current installation of DIAdem can load.

DIAdem Data
DIAdem uses the TDM format to save the properties and the numeric data 
in different files that have the same filenames. DIAdem saves the data 
properties in a text file with the filename extension .tdm, and the numeric 
data in a binary file with the filename extension .tdx.

Use the DIAdem 9 files (*.tdm) button in the File-based data storage 
function bar to load DIAdem data. DIAdem NAVIGATOR displays only 
data files with the filename extension .tdm. DIAdem reads the properties 
from the TDM file and loads the associated data from the TDX data file with 
the same name.

DAT Data
Click the DIAdem 8 files (*.dat) button in the File-based data storage 
function bar to load data from earlier DIAdem versions.

Before Version 8.1, the DAT format was the standard DIAdem format. In the 
DAT format, DIAdem saves the data properties as text in a header file with 
the extension .dat. DIAdem saves the numeric data in the binary format 
that uses the least amount of space for that data. One data set can include 
several binary files, for example, files with the file name extension .w16 or 
.r48.

Refer to the section on Working with DAT Files for more information.

LabVIEW Data
Use the LabVIEW files (*.lvm) button in the File-based data storage 
function bar to load LabVIEW data. DIAdem NAVIGATOR displays only 
data files with the filename extension .lvm. DIAdem reads the LVM file 
header and loads the data accordingly. LabVIEW saves descriptive 
information such as the delimiter used, the start value and the step width of 
the x-channel, and the actual values in a file.

Earlier VIEW data files have the filename extensions .lvd or .txt. These 
ASCII files only contain the actual values. Select Open with»ASCII 
Import in the DIAdem NAVIGATOR shortcut menu to load the files.

Use the LabVIEW DIAdem Connectivity VIs in LabVIEW to exchange 
data directly with DIAdem. These VIs can start DIAdem directly, to write 
acquired data straight into the Data Portal. The LabVIEW DIAdem 
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Connectivity VIs are on the DIAdem CD, and you can download them from 
the NI Web site.

Use the LabVIEW DSC module data button in the Server-based data 
storage function bar to open a database that the LabVIEW Datalogging and 
Supervisory Control (DSC) Module has generated. In addition to the 
measurement data, the LabVIEW DSC panel saves recorded data about the 
monitoring run, alarms that occur, and control tasks executed.

VI Logger Data
Use the VI Logger data button in the Server-based data storage function 
bar to load data from a VI Logger database. VI Logger saves measured data, 
including the record data, in the database. 

Lookout Data
Use the Lookout data button in the Server-based data storage function 
bar to load data from a Lookout database. Lookout saves data from various 
sources and saves recorded data with the measured data. You can accelerate 
access to a large database by specifying a time interval for which you load 
data into the Data Portal.

ASCII Data
Use the ASCII files (*.asc, *.txt, *.csv) button in the File-based data 
storage function bar to import ASCII data. A wizard helps you to analyze 
the data you want to import. For example, you specify whether a file 
contains text, or empty lines, and whether the values are in blocks or 
channels.

In the wizard preview, you check the settings, which you then save in a 
configuration file with the extension .stp. To import another ASCII file 
with the same structure, specify this configuration file in the wizard.

Excel Data
Use the Excel files (*.xls) button in the File-based data storage function 
bar to load Excel data from Excel 97 and later. As with ASCII files, a wizard 
helps you to analyze the data to be imported. You specify whether the file 
contains several table sheets and where text is located. In the wizard 
preview, you specify text as a channel name, comment, or unit.

You check the settings, which you can save in a configuration file with the 
extension .stp. To import another Excel file with the same structure, 
specify that configuration file in the wizard.
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ASAM Data
Use the ASAM-AOP data button in the Server-based data storage 
function bar to load data from ASAM-compliant databases using the 
ASAM-ODS Protocol (AOP). The Association for Standardization of 
Automation and Measurement Systems (ASAM) data model saves values 
and descriptive metadata in a hierarchical structure.

ODBC/SQL Data
Use the ODBC/SQL data button in the Server-based data storage 
function bar to load data from Access, Oracle, or ADO databases. Use SQL 
(Structured Query Language) commands to access an ODBC (Open 
Database Connectivity) database. DIAdem also can access data with OLE 
(Object Linking and Embedding) and with ADO (ActiveX Data Objects) in 
client-server architecture, and in Web-based applications.

Binary Data
Select File»DAT files»Import via header to import binary data. To import 
the data, you create a header file containing information about the data set 
and the data channels. Click Execute in the dialog box to load the channels 
into the default group in the Data Portal according to the header information. 
When you create a header, you can use an existing header file and adjust it 
to the binary data to be loaded.

Refer to the section on Working with DAT Files for more information.

Crash Test Data
DIAdem can load crash test data from the vehicle safety area in the EGV file 
format based on ISO DTR-13499, and in the MME format according to 
ISO-MME (TS 13499). To load EGV or MME data, select Settings»
Desktop parameters»GPI-DLL registration and register the appropriate 
GPI file filter. Load the function library egvload.dll for the EGV format 
and gfsmme.dll for the MME format, from the folder 
..\diadem\addinfo.
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Exercise 3-1
Objective: Expanding Data Storage

In the following exercise you add the folder with the exercises for this 
training course to the data source MyDIAdem 9.1.

1. Select DIAdem NAVIGATOR.

2. Open the DIAdem NAVIGATOR shortcut menu.

3. Select Properties in the shortcut menu. The following dialog box 
appears.

4. Open the folder C:\Exercises\DIAdem Basics.

5. Click Add elements. The DIAdem Basics folder appears in the top 
window. 

6. Double-click the icon of the new folder in the top window. 

An entry field for the Alias name appears.
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7. Enter MyTraining.

8. Click OK.

The MyTraining folder appears in DIAdem NAVIGATOR. 

9. Open the folder MyTraining.

End of Exercise 3-1 
DIAdem automatically saves the new folder in the MyDIAdem 9.1 data 
storage. The next time DIAdem launches, the MyTraining folder appears. 
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Exercise 3-2
Objective: Filtering Data Files

In the following exercise you display only the data from MyDIAdem 9.1 
that was saved after September 4, 2004.

1. Select DIAdem NAVIGATOR.

2. Click Filter settings in the toolbar.

3. Click Extend list in the middle of the dialog.

4. Set the filter criteria as shown in the following figure:

Click OK.

5. DIAdem NAVIGATOR now lists only the files saved after September 4, 
2004.
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6. Click Filter On/Off in the toolbar to display all the data files in the 
C:\Exercises\DIAdem Basics folder.

End of Exercise 3-2 
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C. Managing Data in the Data Portal
When DIAdem NAVIGATOR opens, the Data Portal appears to the right of 
the workspace. Click the Data Portal button in the toolbar to display and 
hide the Data Portal. Select Window»Data Portal floating to position the 
Data Portal anywhere in the window. 

The Data Portal in Figure 3-2 displays an overview of channels currently in 
the data area. The Data Portal makes the internal data accessible in all 
DIAdem panels. The Data Portal contains data channels, time channels, and 
text channels. The Data Portal organizes channels in groups and displays 
their properties. DIAdem only loads internal data from the Data Portal 
temporarily in the workspace. The changes you make to the internal data are 
not stored until you save the data in a file or a database. Registered data do 
not occupy memory space. DIAdem only creates a reference to the numeric 
data.

Figure 3-2.  The Structure View of the Data Portal with Channel Groups, Channels, 
and Properties

1 Example channel group
2 Channels in the Example channel group
3 Selected channel
4 Default group

5 Registered channels
6 Switch to the list view
7 Properties of the selected channel
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Working with Channels and Channel Groups
If you load a data set from the DIAdem NAVIGATOR to the Data Portal, 
DIAdem automatically generates a new channel group. This channel group 
contains all the channels of the data set, such as data channels with measured 
values from sensors, and a time channel with the associated time values. All 
DIAdem panels work with channels. In DIAdem ANALYSIS you can select 
two channels in the Data Portal for an FFT calculation, and in DIAdem 
REPORT you can select two channels for displaying a curve.

DIAdem identifies the last data set that you load in the Data Portal as the 
default group. If you load a selection of data set channels to the Data Portal, 
DIAdem stores these channels in the default group. You can move each 
channel in the Data Portal to another channel group.

Click a channel to select a single channel. To select a block of channels, 
click the first channel, and <Shift>-click the last channel you want. To select 
several non-consecutive channels, <Ctrl>-click the channels. Selected 
channels have a dark background.

Tip You also can select or delete several channels by clicking the symbol to the left of 
the channel names, as shown in Figure 3-3. If you use these symbols, you do not need to 
press <Shift> or <Ctrl>.

Figure 3-3.  Selecting Channels with the Selection Cursor

You can use the shortcut menu and the usual keys to delete, copy, and paste 
selected channels or channel groups.

Data, Time, and Text Channels
DIAdem works with three different channel types: data channels, time 
channels, and text channels.

A data channel contains acquired values such as the measurement values 
from a sensor, calculation results, input values, or values loaded from files. 
DIAdem can use any data channel for calculations and displays.

DIAdem generates a time channel from numerical date and time 
specifications. In the time format, DIAdem saves the seconds from the year 
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zero up to now. A time channel, for example, contains the time values that 
DIAdem acquires during a measurement. A time channel is often the x-
channel for calculations and displays of the respective measurement values 
in the y-channels.

A text channel contains text in the unicode format. Unicode characters 
include Chinese, Japanese, and Arabic characters. You can display text 
channels in tables in the DIAdem panels VIEW and REPORT. Use text 
channels to record observations during a measurement.

Generating New Channels
You can use the Data Portal shortcut menu to generate new channels and 
channel groups. Select New»Channel in the shortcut menu. In the dialog 
box that appears you specify whether the channel is a numeric channel, a 
time channel, or a text channel. You also specify the maximum length and 
the name.

After the channel is generated, you can either enter the channel values 
manually, or generate the values, in DIAdem VIEW. Open the Predefined 
screen partitioning function bar in DIAdem VIEW and select One 
channel table. Enter the data in the channel table or select Generate in the 
shortcut menu.

The List View in the Data Portal
Click the List tab to switch from the structure view to channel-oriented 
display. The list view lists all channels on one level, according to the 
property you select. The channel number is an important property in the list 
view. DIAdem uses the group index and the channel index to reference 
channels, and several Calculator functions still use the channel number.

Note You can sort the channels in the list in any way. The channel order in the List tab 
does not affect the channel order in the Structure tab. 

The Data Area
DIAdem adjusts the data area to the current data storage. A data set can have 
several channels with different lengths. Each data channel is an independent 
series of numbers. The channel length and the number of channels are 
practically unlimited, because DIAdem can manage up to 2 billion values. 

If you use more channels than the program configuration specifies, DIAdem 
enlarges the data area accordingly. DIAdem also extends the channel length 
dynamically to the actual number of values. First select Windows»Close all 
and then select Settings»Memory organization»Data area to change the 
length and the number of channels DIAdem starts with. This involves a total 
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memory reorganization and the changes do not come into effect until you 
save these settings and DIAdem automatically restarts.

Saving and Exporting Internal Data
The data in the Data Portal only exists while the program is running. 
DIAdem only registers changes temporarily. You must save data to make it 
accessible later.

You can save the entire data of the Data Portal in DIAdem format. Drag and 
drop your internal data to a folder in DIAdem NAVIGATOR, where 
DIAdem saves the data as a TDM file. When you drop data to a data file, 
DIAdem adopts the filename and overwrites the data file with the new data. 
To save all the data from the Data Portal, click Save TDM file as in the 
toolbar. DIAdem saves the data in the file in the same structure as in the Data 
Portal.

You also can save individual channels and channel groups in DIAdem 
format. Drag and drop the selected channels or channel groups to a DIAdem 
NAVIGATOR folder for storage. Enter a new filename in the Save as dialog 
box.

To save data in the DAT format, select the DAT format in the Save as dialog 
box. When you save data in DAT format, you provide your data to 
applications such as DIAdem CLIP, which only can read DAT files. 

To save data in the ASCII format, select File»DAT files»Storage 
parameters and change the DAT data type to ASCII. If you save files in the 
DAT format, DIAdem generates an ASCII file.

To save data in the Excel format, select the XLS format in the Save as dialog 
box. The Excel Export Wizard saves the data in the Data Portal as an Excel 
file.

If you want to save data in the ASAM data format, select File»ASAM Data 
service or use the script commands in DIAdem SCRIPT. You can use SQL 
commands in DIAdem SCRIPT to write data into SQL databases.
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Exercise 3-3
Objective: Loading a Data File to the Data Portal

In the following exercise you load the data set FrontCrash_1.tdm to the 
DIAdem Data Portal. The data are from a crash test and will be analyzed in 
the following exercises.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate in the MyTraining folder to the FrontCrash_1.tdm data 
file and click the file.

4. Drag and drop the FrontCrash_1.tdm data file into the Data Portal.
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The Data Portal looks like this:

End of Exercise 3-3 
You use these data in the subsequent exercises.
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D. Working with the Data Properties
DIAdem displays the properties of the internal data in the bottom section of 
the Data Portal. If the properties do not appear in the Data Portal, click the 
bottom edge of the Data Portal and drag open the properties window. Click 
the name of a channel group in the structure view to view the properties of 
the loaded data set. Click a channel to view the properties and characteristic 
values of the channel.

Properties you can edit appear in white fields. These properties include 
channel name, comment, physical unit, channel length, display format, and 
additional information. Click a property field to delete or to overwrite the 
contents. Double-click a properties field to edit the property. Channel 
properties that you cannot edit such as maximum length, NoValue 
occurrence, monotony behavior, minimum values, and maximum values 
appear in dark gray display fields.

1 Selected channel
2 Properties of the selected channel

3 Standard channel properties
4 Predefined custom properties
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You also can specify properties such as name, description, and author for the 
root element, which is above the channel groups. To enter the data set 
comments in the properties window, click the root name in the structure 
view. 

In the Data Portal structure view, DIAdem can display properties of the 
channels, the channel groups, or the root element. Select Select properties 
in the shortcut menu to select properties.

The following tables 3-1 to 3-3 list the properties of the root element, the 
channel groups, and the channels.

Table 3-1.  Properties of the Root Element

Property Meaning

Name Data set name

Description Data set description

Title Title

Author Author

RegisterTxt1
RegisterTxt2
RegisterTxt3

Additional descriptive information

DateString Date

TimeString Time

Table 3-2.  Channel Group Properties

Property Meaning

Name Channel group name

Description Channel group description

Index Channel group index
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Specifying Additional Custom Properties
You can specify custom properties for each structure element in the Data 
Portal, in addition to the standard properties and the predefined custom 
properties. To create a custom property for a channel group, open the 
shortcut menu for the channel group and select New»Custom property. 
You specify the data type and the property name in the dialog box that 
appears. You also can select several elements in the Data Portal and create a 
custom property for all the selected elements.

Table 3-3.  Channel Properties

Property Meaning

Name Channel name

Description Channel description

Unit_String Channel unit

Length Channel length

Minimum Minimum value in the channel

Maximum Maximum value in the channel

Monotony Channel monotony

NoValueKey Occurrence of NoValues in the 
channel

Status Channel status

LengthMax Maximum channel length

GroupIndex Channel group index

Number Channel number

DisplayType Channel display format

ValueType Channel data type

RegisterInt1
...
RegisterInt5

Descriptive integer channel 
information

RegisterVal1
...
RegisterVal6

Descriptive non-integer channel 
information

RegisterTxt1
RegisterTxt2

Descriptive channel information
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DIAdem saves your custom properties with the data set. If you export the 
data to the DAT format, you lose the custom properties and the channel 
group information. When DIAdem loads external data, DIAdem 
automatically converts non-TDM properties into custom properties.

Functions and Variables for Accessing Properties
You can use the following variables and commands in scripts and formulas 
to access root element properties, channel group properties, or channel 
properties.

Select Functions, Commands and Variables in the DIAdem help contents 
for more information about functions and variables that you can use to read 
and set data properties.

Root Element Properties

RootPropCount

Specifies the number of properties in a data set.

RootPropCreate(PropName,DataType)

Creates the PropName data set property, which is DataType.

RootPropDel(PropName)

Deletes the PropName data set property.

RootPropGet(PropName)

Determines the value of the PropName data set property.

RootPropInfoGet(PropName)

Determines information about the PropName data set property. 
DIAdem saves the results in the variables DataType, PropIsFixed, 
and PropIsReadOnly.

RootPropName(Index)

Specifies the name of the property of a data set specified by the Index.

RootPropNameChk(PropName)

Checks the name of a new data set property. If the name conventions are 
not met, DIAdem corrects the name and saves the name in the 
PropName variable.

RootPropSet(PropName,PropValue)

Sets the PropName data set property as PropValue.
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Channel Group Properties

GroupChnCount(Index)

Specifies the number of channels in the Index channel group.

GroupCount

Specifies the number of channel groups in the Data Portal.

GroupCreate(GroupCreateName [,TargetGroupIndex])

Creates a channel group called GroupCreateName at the position 
TargetGroupIndex in the Data Portal.

GroupDefaultGet

Specifies the index of the default group.

GroupDefaultSet(TargetGroupIndex)

Specifies the index channel group as the default group.

GroupDel(TargetGroupIndex)

Deletes the index channel group.

GroupIndexGet(GroupName)

Determines the position of the GroupName channel group in the Data 
Portal.

GroupName(Index)

Specifies the name of the property of the Index channel group.

GroupPropCount(Index)

Specifies the number of properties in the Index channel group.

GroupPropCreate(TargetGroupIndex,PropName,DataType)

Creates the Propname property, which has the DataType data type, for 
the channel group specified by the index.

GroupPropDel(TargetGroupIndex,PropName)

Deletes the PropName property from the channel group specified in the 
index.

GroupPropGet(SourceGroupIndex,PropName)

Determines the value of the PropName property from the channel group 
specified by the SourceGroupIndex.
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GroupPropInfoGet(TargetGroupIndex,PropName)

Determines information about the PropName property in the channel 
group specified by the index. DIAdem saves the results in the variables 
DataType, PropIsFixed, and PropIsReadOnly.

GroupPropNameGet(SourceGroupIndex,GroupPropIndex)

Determines the name of a group property specified by the index.

GroupPropSet(TargetGroupIndex,PropName,PropValue)

Sets the PropName property in the channel group specified by the index 
to PropValue.

Channel Properties

ChnPropCount(Index)

Specifies the number of properties of the specified channel.

ChnPropCreate(TargetGroupIndex,PropName,DataType)

Creates the PropName property of the data type DataType, for the 
specified channel.

ChnPropDel(TargetChn,PropName)

Deletes the PropName property of the specified channel.

ChnPropGet(ChannelNumber,PropName)

Determines the value of the PropName property of the channel specified 
by the channel number.

ChnPropInfoGet(TargetChn,PropName)

Determines the PropName property of the specified channel. DIAdem 
saves the results in the variables DataType, PropIsFixed, and 
PropIsReadOnly.

ChnPropNameGet(ChannelNumber,ChnPropIndex)

Determines the name of the channel property specified by the index, for 
the channel specified by the channel number.

ChnPropSet(TargetChn,PropName,PropValue)

Sets the PropName property as PropValue.
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Exercise 3-4
Objective: Editing the Data Set Properties and Saving the Data

In this exercise you give the data set comments that contain information 
about the measurement. You then save the data.

1. Select DIAdem NAVIGATOR.

2. In the Data Portal, open the shortcut menu for FrontCrash_1 and 
select Data set comments.

3. Enter the following information in the data set comments dialog box to 
describe the data set:

Click OK.

4. Select FrontCrash_1 in the Data Portal and drag and drop the selected 
data set to the tree for the MyTraining data storage. Enter the filename 
Training3.tdm and click Save. 

End of Exercise 3-4 
The FrontCrash_2.tdm data set, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 3-5
Objective: Creating a Custom Property for a Channel

In the following exercise you create a custom property and integrate the 
property into a report.

1. Select DIAdem NAVIGATOR.

2. In the Data Portal, open the shortcut menu for the p_Airbag channel, 
and select New»Custom property.

3. Enter Test setting as the Name and select String as the Type.

Click OK.

DIAdem creates the custom property in the properties window.

4. Double-click the Test setting field in the properties window and enter 
the following text:
Trigger after 10 ms

5. Select DIAdem REPORT.

6. Delete the current layout without saving the layout.

7. Drag and drop the Test setting custom property from the properties 
window in the Data Portal to the current worksheet.
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If you enlarge the text, the report looks like this:

End of Exercise 3-5 
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E. Working with DAT Files
Before Version 8.1, the DAT format was the standard DIAdem format. In 
DAT format, DIAdem stores the data itself in one file and the organizational 
information for data management in another file.

You can drag and drop DAT files from DIAdem NAVIGATOR to the Data 
Portal, and you can select File»DAT files to load and save DAT data 
selectively, to load binary data, and to export DAT data.

Selective Loading
Select File»DAT files»Paste from file to load sections from single channels 
of a DAT file to the Data Portal. Open the DAT file and select the channels 
you want to load. Then you can reduce the values to be loaded and edit the 
data set properties. DIAdem loads the selected channel values into the 
default group in the Data Portal.

Loading Binary Files
When you load a DAT format file, the header file controls access to the 
actual data. Before you actually load binary data, you must generate the data 
set properties from which DIAdem obtains the administrative data for 
accessing external files. The user must be familiar with the data 
organization. When the file with data set properties is generated, DIAdem 
can load the external file like a DAT file.

Select File»DAT files»Import via header to load, generate, save, edit, and 
delete the channel properties for importing binary data.

Load external data as follows:

1. Load an existing header file that describes a data structure similar to the 
data to be loaded. If necessary, delete the channel properties.

2. Open the Properties subdialog box to edit the properties of the data 
storage to be loaded.

3. Generate the channel properties associated with each channel of the 
external data that is to be read. Then edit the generated channel 
properties. 

4. Save the created data set and channel properties. 

5. Click Execute to load the external data into the default group in the Data 
Portal.

When the properties are saved, DIAdem can read the data with the 
normal loading function.
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Specifying Storage Parameters
When you save data in DAT format, you provide your data to applications 
that only can read DAT files. For example, to analyze data and videos in 
DIAdem CLIP, the data must be in DAT format.

Select File»DAT files»Storage parameters to specify the storage format 
for DAT files. You can set the following parameters for the DAT format:

Storage mode Specifies the storage format for the data files. 
DIAdem saves data in columns or tables.

Type of data Specifies the data type. DIAdem uses various 
binary formats and the ASCII format.

Real format Specifies the format of the real numbers for 
ASCII block storage. The letter d stands for 
numbers, and the letter e stands for the 
exponent. Use points or commas as decimal 
characters.

Integer length Specifies the minimum length of the ordinal 
numbers for ASCII block storage.

Separator Specifies the separator for ASCII block storage.

Check implicit data Checks implicit channels. DIAdem saves the 
generating instructions (start value, step width, 
number of values) for implicit channels, for 
example, time channels with equidistant 
partitioning. Therefore these channels must not 
be changed in the DIAdem VIEW channel table.

Check integer data Checks integer channels. Real data is therefore 
invalid for these channels.

Selective Storage
Select File»DAT files»Selective storage to save channels selected in the 
Data Portal as a DAT file, or to add these channels to an existing DAT file. 
When you enter the filename in the dialog box, you specify how DIAdem 
saves the data. If you enter a filename that does not exist in the selected 
folder, DIAdem saves the selected channels under the new filename. If you 
enter a filename that does exist in the selected folder, you can add the 
selected channels to the channels in the file, or overwrite the file.

Note When DIAdem saves data in DAT format, it ignores custom properties and group 
information. 

Refer to Lesson 8, The DIAdem Calculator and to the section on Loading 
External Data in Lesson 10, Loading External Data, for more DAT file 
information and examples.
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F. Configuring DIAdem NAVIGATOR
You can make settings for the specific panels and configure the DIAdem 
data area.

Making Panel-Specific Settings
In DIAdem NAVIGATOR, select Settings»Desktop parameters»Panel 
specific. The configuration dialog box has the following settings:

Library path Displays the current library folder with data files.

User path Displays the current user folder with data sets. 

Data storage Specifies the data storage that DIAdem loads 
when the NAVIGATOR panel opens.

Default file Specifies the data file that DIAdem loads when 
the Data Portal opens.

Configuring the Data Area
You do not have to have a default configuration for the data area. The data 
area adapts automatically to the loaded data, and only uses as much memory 
space as absolutely necessary.

If you do have to configure the data area, select Window»Close all to close 
all panels. Then select Settings»Memory management»Data area. 

If you modify the data area, DIAdem saves the current settings in a desktop 
file with the filename extension *.ddd. DIAdem automatically restarts with 
this desktop file and the new settings are effective. 
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Summary, Tips, and Tricks

• In DIAdem NAVIGATOR, you navigate data files, file folders, and 
databases to find your external data. You can display file-based or 
server-based data storages.

• You load the data set into the Data Portal, which manages all internal 
data and makes the data accessible for all DIAdem panels.

• The Data Portal contains data channels, time channels, and text 
channels. The Data Portal organizes channels in groups and displays 
their properties.

• You also can load several data files into the Data Portal at the same time. 
DIAdem generates a separate channel group for each loaded data file.

• You can display and calculate registered data, but you cannot modify 
registered data. Registered data do not occupy memory space. DIAdem 
only creates a reference to the numeric data.

• DIAdem identifies the last data set that you load in the Data Portal as the 
default group. If you load a selection of data set channels to the Data 
Portal, DIAdem stores these channels in the default group. 

• Use the shortcut menu in the Data Portal to modify the default group. 

• The data in the Data Portal only exists while the program is running. 
DIAdem only registers changes temporarily. You must save data to make 
it accessible later.

• Select Settings»Desktop parameters»Panel specific to specify a 
Default file, that is, you specify the data set that is loaded into the data 
area when the program starts.
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Notes
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Lesson 4
Viewing Data
Introduction
In this lesson you will learn how to view and edit your data, and use graphics 
to interactively analyze your data.

You Will Learn About: 

A. Viewing, Measuring, and Editing Data

B. Creating a Layout

C. Viewing Data as Curves

D. Describing an Evaluation in Textboxes

E. Editing Data in Channel Tables

F. Configuring DIAdem VIEW
© National Instruments Ireland Resources Limited 4-1 DIAdem Basics Course Manual



Lesson 4 Viewing Data
A. Viewing, Measuring, and Editing Data
You can use DIAdem VIEW to view, measure, and edit the data in the Data 
Portal.

You create curves in 2D axis systems to get an overall impression of your 
data. You examine the curves with a graphic cursor, zoom curve sections, 
and delete or replace incorrect curve points. You list data channels and text 
channels in channel tables to view and edit data and text in detail. If you 
modify curves or edit channels, the changes affect the channels in the Data 
Portal. You describe the evaluation in textboxes.

Figure 4-1 shows a worksheet with two axis systems, the coordinate 
window, a channel table, and a textbox.

Figure 4-1.  DIAdem VIEW with Coordinate Window

Select screen partitioning in the group bar to align the axis systems, channel 
tables, and textboxes in the worksheet. The function bars provide various 
partitioning combinations. 

A VIEW layout may contain several worksheets with different views of your 
data. Select Insert»Worksheet to create new worksheets.

1 Toolbar with the various graphics cursors and cursor 
types

2 Group bar with various kinds of partitioning
3 2D axis systems
4 Axis toolbar

5 Worksheet tabs
6 Textbox with test description
7 Curve symbol in the legend
8 Coordinate window
9 Channel table
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The toolbar contains various graphics cursors and cursor types for 
inspecting curves and accessing characteristic curve points. The toolbar also 
contains the buttons for enabling and disabling the coordinate window, for 
defining the curve display, and for loading and saving your own layouts. You 
can print a view or transfer the view to a report.

The toolbar has a button that opens the Calculator. You can use the 
Calculator to create and calculate channels. 

Each axis system also has its own toolbar. Use this toolbar to specify the 
scaling mode for the y-axis, to resize a selected section of the curve, and to 
set flags.
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B. Creating a Layout
You can include axis systems, channel tables, and textboxes in one 
worksheet, to see the data on the curve and the associated numeric values 
simultaneously, and to record your evaluation in a textbox. The screen 
partitioning function bars have templates for splitting the worksheet into 
varying numbers of sections that are in different positions.

For example, if you want to display your data as a curve in an axis system 
and list the numeric values in a channel table, divide the worksheet into two 
areas. Open the Predefined screen partitioning function bar and select 
Axis system/channel table horizontal. DIAdem generates an axis system 
in the top part of the worksheet and a channel table in the bottom part.

To generate a curve, select two data channels in the Data Portal. Click the 
channel you want to use as the x-channel. <Ctrl>-click the y-channel you 
want to use. Drag and drop this channel pair into the axis system. Then 
select the channels and drag and drop the channels into the channel table.

The worksheet partitions in the top four function bars are not predefined. To 
define one area of the split window, right-click the area and select Display 
type from the shortcut menu. You can select 2D axis system, Channel 
table, Textbox or Empty as the display type.

The partitions in the fifth function bar includes various combinations of axis 
systems, channel tables, and textboxes. If you select one of these 
preassigned partitions, DIAdem creates the view in a new worksheet. The 
channel table defined on the first button automatically displays all the Data 
Portal channels.

Move the frame to resize separate areas. You cannot move areas. To generate 
new areas, you can either use the shortcut menu to split an existing area, or 
you can load more areas in a partition you specify yourself. If you select 
non-preassigned worksheet partitioning with fewer areas than the current 
view, the definitions for the surplus areas are lost.

No matter how many areas you have, and what types they are, you only work 
in the area that DIAdem highlights with a dark frame. 

Loading and Saving a Layout
You can save the layout of your current view in a file with the filename 
extension .tdv. In this layout file, DIAdem stores for each worksheet the 
description of all axis systems and channel tables, with the names of the 
channels to be displayed, and all textboxes, including the text. You can use 
the layout again later for other evaluations. 
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You can load a prepared layout as a template for a view, and adapt the 
settings to your evaluation.

Using the Report Wizard
Press <Ctrl-W> to open the Report Wizard and generate a view.

Use the Report Wizard to generate a view with axis systems, in three steps:

1. First select the data you want to display.

2. Specify the x and y-channels for the curves.

3. Select the VIEW display style.

DIAdem creates a view in a new worksheet according to the parameters you 
set in the Report Wizard. You can use the display as a template and edit it.

Creating a Report
To document the current view of your data in a report, you can transfer the 
worksheet to DIAdem REPORT. Click Transfer to REPORT in the 
DIAdem VIEW toolbar. DIAdem REPORT generates a new worksheet with 
the axis systems, tables, and comments, in the same layout as in the DIAdem 
VIEW worksheet.
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C. Viewing Data as Curves
Use 2D axis systems for an overall view of your data. In 2D axis systems, 
DIAdem generates a curve from two data channels by creating data pairs for 
each curve point from the the x-channel and the y-channel values. If the two 
data channels are not the same length, the curve is as long as the shortest 
data channel.

To define another curve, select two data channels in the Data Portal and drag 
and drop the channel pair to the axis system. To display several curves, you 
also can select several channels and drag and drop them into an axis system. 
DIAdem uses the first channel you select, as the x-channel.

Double-click the axis system to open the Display dialog box, where you 
add, modify, or delete curves. Figure 4-2 shows the dialog box for curve 
definition.

Figure 4-2.  Dialog Box for Curve Definition

The list at the top of the dialog box contains the defined curves. Click the 
list entry to select a curve definition, and you can then change the settings 
in the bottom part of the dialog box, for example, you can assign another 
color.

Click New Entry to open the subdialog where you can select an x-channel 
and one or more y-channels. Click Curve markers to open the subdialog 
box where you specify the line that joins the curve points. You also can 
specify the curve markers.

DIAdem then displays the curve in the axis system. A curve symbol appears 
next to the axis system, as a checkbox the same color as the curve.
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The axis system has a graphic cursor for measuring and editing the curve. 
Use the mouse to move the cursor along the curve, and the coordinates 
appear in the coordinate window.

Axis Scaling
If you want to compare curves that have different value ranges in one axis 
system, you can use the axis system toolbar to select another scaling mode 
that improves the display. 

You can choose from the following scaling types:

• 1 system  [phys.]

Use 1 system [phys.] to display several curves with one scale, in one 
system. The y-axis displays physical values. The value range is the 
common value range for all curves. The cursor position is in relation to 
all the curves.

• 1 system  [%]

Use 1 system [%] to display all curves in one axis system. The y-axis 
display ranges from 0–100%. The y-cursor position is in relation to the 
main curve. DIAdem indicates the y-positions on the other curves with 
dashes.

• n systems [phys.]

Use n systems [phys.] to display each curve with a subaxis. The y-
scaling is physical. The range of values for each axis corresponds to the 
range of values of the curve. DIAdem displays a separate graphic cursor 
in each axis system. You only can move the cursor in the main axis 
system.

To scale the y-axis, DIAdem uses the lowest and the highest y-value of the 
displayed curves. If you set 1 system [phys.] scaling or n systems [phys.] 
scaling, you can scale the y-axis manually to inspect a specific curve 
section. You do this in the dialog box for curve definition, which is shown 
in Figure 4-2.

The Graphics Cursors
You use the various graphics cursors to move and measure one or more 
curves. You can choose a Crosshair cursor, a Band cursor, or a Frame 
cursor. You can click from one cursor type to another in the toolbar.

You can use the mouse or the cursor keys to move the graphic cursor in the 
enabled axis system. The graphics cursor runs parallel in the other axis 
systems if the range of values is the same.
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You can observe the coordinates of the graphics cursors in the coordinate 
display and in the legend.

A crosshair cursor consists of a vertical line and a horizontal line, each of 
which you can move separately. The x and y-cursor coordinates that 
DIAdem displays as x1 and y1 specify the point where the lines intersect.

If you idle the mouse on one of the cursor lines, the graphic cursor changes 
to a horizontal or to a vertical arrow. Click and drag to move the cursor line 
vertically or horizontally. DIAdem refreshes the coordinates in the 
coordinate window.

The band cursor consists of two parallel, vertical lines that define a curve 
section with a delta-x bandwidth. DIAdem uses the x-position of the line 
with a little square for the x1 coordinate, and the x-position of the other line 
for the x2 coordinate.

If you move the mouse cursor along one of the two lines, the cursor changes 
to a double arrow, indicating the extended mode. To change the bandwidth 
delta-x of the graphics cursor, click and drag to the right or left.

When the cursor is inside the band cursor, it appears as two crossed arrows. 
You can click and drag the entire band along the curve.

The frame cursor is a rectangular area framed by two horizontal and two 
vertical lines. A small square indicates the point of intersection, which is at 
the cursor coordinates x1 and y1. The diagonally opposite point of 
intersection is at the coordinate points x2 and y2. Delta-x and delta-y are the 
distances between the horizontal and the vertical lines, which means the 
frame height and the frame width.

The frame cursor works the same way as the band cursor. You also can move 
the frame cursor up and down.

The Global Coordinate Display
You can display the current graphic cursor coordinates in a separate window. 
Click the Coordinates button in the toolbar to open and close the 
coordinates window. You can move the coordinates window around. 

The small rectangle on the cursor indicates the data point for which DIAdem 
displays the coordinates in the coordinate window.

You also can use the coordinate window to position your cursor in the axis 
system. For the enabled graphics cursor, enter the point numbers, the x and 
y-values, or the distance between the cursor lines dx and dy, and press 
<Enter>. DIAdem changes or moves the cursor accordingly.
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The Cursor Position
Each axis system has a graphic cursor, which you drag along a curve. The 
default cursor is the free cursor, which you can move freely in the enabled 
axis system.

Use the curve cursor to move along the single curve points. You can display 
the coordinates of each point on the curve.

Use the maximum values cursor or the minimum values cursor to move 
the graphics cursor along the extreme values on the curve.

Defining Leading Curve
If an axis system contains several curves, you must specify which curve the 
graphics cursor relates to.

To specify the leading curve, click the associated curve symbol in the legend 
area.

If you have several axis systems in your worksheet, the graphic cursors 
move along the same value ranges in the other axis systems.

Curve Legend
If you move the cursor to the right edge of an axis system, a window divider 
appears. Click and move the edge of the resizable window to open the axis 
system legend.

The legend contains the y-channel name for each curve, and a checkbox that 
is the same color as the curve. You can add channel properties such as unit, 
extreme values, or cursor coordinates, and any text. Double-click the legend 
area to open the configuration for the legend in Figure 4-3.

Figure 4-3.  Dialog Box for Legend Configuration
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The properties that DIAdem can display in the legend are on the left of the 
dialog box. The overview on the right is a list of the properties that DIAdem 
currently displays in the legend.

To display another legend property, select the property in the list on the left 
of the dialog box and click > to add the property to the Properties to be 
displayed. The Format/expression specifies the display format for the 
numeric values, which are the x and y-numeric values or the time values.

Select the <freetext> property for display, specify in Format/expression 
the general text or the calculator expression that you want DIAdem to 
display in the legend window. You also can enter the heading for the display 
field in the Title column.

Note DIAdem only displays the properties CursorX and CursorY, which are the x and 
y-coordinates of the cursor, if one of the graphics cursors such as the curve, maximum 
value, or minimum value cursor, is enabled.

Zooming and Scrolling
Use the zoom function to enlarge and to inspect separate sections of the 
curve. You only can use the zoom function with a band cursor or a frame 
cursor. 

Move the band cursor or the frame cursor to a position where the curve 
section you want is inside the cursor lines. To move the cursor, click 
between the cursor lines and drag the mouse to the right or left. You define 
the width of the cursor by positioning the cursor lines.

Click Zoom, static in the axis system toolbar. The curve section that the 
cursor specifies covers the entire axis system. The narrower the cursor, the 
greater the enlargement.

You can repeatedly select and zoom, to examine smaller and smaller curve 
sections.

When you click Zoom off, DIAdem displays the original curve, regardless 
of how many times you zoomed the curve.

Whereas you use Zoom, static to zoom separate curve sections, you can use 
Zoom, dynamic to move the zoom along the entire curve. To move along 
the curve, click and drag the cursor horizontally.
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Editing Curves
You can view and resize curves in axis systems, and you also can use flag 
functions to edit the curves.

Use the graphic cursor to specify single points or curve sections. Then click 
Set flags in the axis system toolbar to select all the curve points in the 
section. If the axis system contains more than one curve, DIAdem selects 
only the leading curve. To select the specific area in all the curves, <Shift>-
click the Set flags function.

You also can select several separate areas. You move the graphics cursor and 
click Set flags in the axis toolbar. 

Then specify the flag function you want to use to edit the selected values. 
You can choose from:

• Flags: Delete data points
Deletes the curve sections specified by flags.
Select Settings»Flag parameters to specify whether DIAdem deletes 
curve points from the data channel or replaces them with NoValues.

• Flags: Copy data points
Copies the curve sections specified by flags into new data channels.

• Flags: Interpolate points
Interpolates the curve sections specified by flags.
Select Settings»Flag parameters to specify whether DIAdem 
interpolates the data points as a line or as a spline.

• Set data point and flag
Marks single points with the crosshair cursor.

If a section of the curve is incorrect, you can replace the data points. Set the 
edges of the band cursor to the right and left of the erroneous section. Click 
Set flags to mark all the curve points in the section, and then click Flags: 
Interpolate points. This section of the curve is now linear. DIAdem stores 
the calculated values in the y-data channel of the active curve.

You also can delete the flags without the flag functions. You can use the axis 
system toolbar to delete specific flags. You move the graphics cursor to the 
selected area and click Reset flags in the axis toolbar. If the axis system 
contains more than one curve, DIAdem only deletes the flags on the leading 
curve. To delete the flags from all the curves in the selected area, <Shift>-
click the Reset flags function.

You can use the DIAdem VIEW toolbar buttons to delete all the flags in all 
curves or all the flags from the data in the Data Portal. Click Global flag 
reset.
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Exercise 4-1
Objective: Viewing the Loaded Data

In the following exercise, you view the loaded data as curves in an axis 
system and define a legend. This gives you an overview of the channels in 
the Data Portal.

1. Select DIAdem VIEW.

2. Open the Predefined screen partitioning function bar and select One 
channel table with all channels.

The channel table contains the contents of all channels in the Data 
Portal. You can scroll the displayed extract.

3. Select Insert»Worksheet.

4. Select the channels shown in the following figure in the Data Portal:

5. Drag and drop the selected channels into the second worksheet.

6. Select the 2D axis system display type to display the selected channels 
as curves.

7. Click Coordinates in the toolbar to open the coordinate window.

DIAdem displays three curves in the axis system. You can position the 
graphic cursor anywhere in the axis system. DIAdem displays the exact 
cursor position in the coordinate window.

8. Click the edge of the resizable window at the right of the axis system and 
drag open the legend.

9. Double-click the legend area to open the dialog box where you set the 
legend parameters.
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10. Enter d.dd under Format/expression for the properties CursorX and 
CursorY. 

Click OK.

11. Click Curve cursor in the toolbar.

The graphic cursor attaches to a curve point. You can now only move the 
cursor along the curve point by point.

In this mode, the legend displays the coordinates of the current curve 
point. In the coordinate window, DIAdem displays the coordinates and 
the current point number.

12. Click a curve symbol in the legend area to specify a different leading 
curve. The graphic cursor attaches to the new curve.

13. Click Minimum values cursor and then Maximum values cursor in 
the toolbar. You move the graphics cursor from one local minimum 
value to the next, or from one local maximum value to the next.

14. Now click Curve cursor in the toolbar.

15. Click 1 system [%] in the axis toolbar. 

DIAdem displays all the curves in one axis system with one common y-
scale that displays the value range 0–100%.
© National Instruments Ireland Resources Limited 4-13 DIAdem Basics Course Manual



Lesson 4 Viewing Data
16. Click n systems [phys.] in the axis toolbar. 

DIAdem displays each curve in a separate axis system.

Use the 1 system [%] scaling and the n systems [phys.] scaling to 
compare curves with different value ranges. 

Use 1 system [phys.] scaling to display several curves with one absolute 
y-scale, in one axis system.

If you hide the Data Portal, the display with 1 system [phys.] scaling 
looks like this:

End of Exercise 4-1 
The FrontCrash_1.tdv layout, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 4-2
Objective: Zooming a Curve Section

In the following exercise you use the zoom and scroll functions in DIAdem 
VIEW to inspect and measure curves. Select screen partitioning with three 
areas. Display the original data in the top axis system and use the frame 
cursor to specify a curve section. Zoom this curve section in the middle axis 
system and scroll the curve in the bottom axis system.

1. Select DIAdem VIEW.

2. Click New layout in the toolbar without saving the current view.

3. Open the Regular screen partitioning function bar and select Three 
areas.

4. Select the Time1 and a_Head_hor channels in the Data Portal and drag 
and drop the selected channels into each of the three areas.

Select the 2D axis system display type.

5. Click Band cursor in the toolbar.

In all three axis systems, the band cursor consists of two parallel, vertical 
lines that define a curve section with a dx bandwidth. 

6. Click the top axis system and move the sides of the band cursor to 
specify a curve section.

If you idle the cursor over one of the lines, the cursor changes into a 
double arrow. Click and drag the mouse to the right or left to change the 
bandwidth of the graphics cursor. 

When the cursor is inside the band cursor, it turns into two crossed 
arrows. Click and drag to move the entire band along the curve.

7. If you have closed the coordinates window, click Coordinates in the 
toolbar. 

The x1-coordinate specifies the x-position of the band cursor line that is 
marked with a small square. The x2-coordinate specifies the x-position 
of the second line.

8. Click Zoom, static in the toolbar of the middle axis system.

DIAdem displays the range inside the band cursor in the middle axis 
system.

The smaller the band cursor section the more you zoom into that section. 
You can enlarge the zoom by specifying a new section in the zoomed 
display area.

9. Click Zoom, dynamic in the toolbar of the bottom axis system.
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The static zoom in the middle axis system enlarges the curve section, 
and you scroll the curve through the enlarged dynamic zoom view in the 
bottom axis system. To move the displayed area, click and drag the area 
to the right or left. 

If you hide the Data Portal, the view looks like this:

End of Exercise 4-2 
The FrontCrash_2.tdv layout, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
DIAdem Basics Course Manual 4-16 ni.com



Lesson 4 Viewing Data
Exercise 4-3
Objective: Editing Curves

In the following exercise you use the flag functions to edit curves.

1. Select DIAdem VIEW.

2. Click Coordinates in the toolbar to close the coordinate window. 

3. Open the Regular screen partitioning function bar and select One 
area.

DIAdem uses the curve from the top axis system.

4. Click Free cursor in the toolbar to move the cursor anywhere along the 
curve.

5. Click Band cursor in the toolbar and position the band cursor on any 
curve section.

6. Click Set flags in the axis toolbar to select the curve section.

7. Click Flags: Delete data points in the axis toolbar to delete the curve 
section.

This makes a gap in the curve, because DIAdem replaces the y-values of 
the selected curve points with NoValues. DIAdem does not change the 
x-values of the curve points and the length of the two channels when it 
deletes the points. 

Note In DIAdem you can define a numeric value as invalid. These numeric values are 
called NoValues. DIAdem does not include NoValues in DIAdem VIEW and REPORT 
displays, or in mathematical analysis.

8. Click Crosshair cursor in the toolbar.

9. Move the crosshair cursor to any position in the area you deleted. Click 
Set flags in the axis toolbar to include the current point in the curve.

10. Repeat step 9 twice to specify a total of three new curve points.

11. Click Band cursor in the toolbar.

12. Move and enlarge the band so it covers the gap in the curve.

13. Click Set flags in the axis toolbar to select the curve section.
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14. Select Settings»Flag parameters and set Spline interpolation 
for Interpolation as shown in the following figure:

Click OK.

15. Click Flags: Interpolate points in the axis toolbar to reconstruct the 
deleted section of the curve.

DIAdem uses the boundary points and the specified curve points to 
recalculate the section with a spline function.

16. Click Reset flags in the axis toolbar to undo the curve section selection.

The view could look like this:

End of Exercise 4-3 
The FrontCrash_3.tdv layout, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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D. Describing an Evaluation in Textboxes
Use the textboxes to comment your evaluation and to display variable 
contents, as shown in Figure 4-4.

If you want to define an area as a textbox, select Display type»Textbox in 
the shortcut menu. Double-click a textbox to edit texts or to insert new text.

Figure 4-4.  View with Textbox

To display channel properties, select the properties in the Data Portal and 
drag and drop the properties into the textbox. DIAdem automatically sets 
two @ in before and after the expression. 

Your text may include formula expressions, which return a single value. The 
formula expression must be set in @. You can use the Calculator operands 
and operations in formula calculations. DIAdem evaluates this expression 
and displays the result in the textbox. 

Select Refresh in the shortcut menu to refresh variable contents and to 
calculate formulas. The shortcut menu also includes the Textbox settings 
for font, font size, font color, and line alignment.
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Exercise 4-4
Objective: Commenting an Evaluation

In the following exercise you create a textbox and comment the evaluation.

1. Select DIAdem VIEW.

2. Open the Regular screen partitioning function bar and select Two 
areas.

DIAdem displays the axis system in the top area.

3. Right-click the bottom area and select Display type»Textbox in the 
shortcut menu.

4. Reduce the size of the textbox.

5. Double-click the textbox and enter the following text:

Crash data evaluation:

6. Press <Enter>.

7. Select the a_Head_hor data channel in the Data Portal. 

8. Select Name in the left column of the channel properties and drag and 
drop the property into the textbox.

9. Select Maximum in the left column of the channel properties and drag 
and drop this property into the textbox too.

10. Right-click the textbox and select Textbox settings in the shortcut 
menu.

11. Set the font size to 14 and set the font color to Blue as shown in the 
following figure:

Click OK.
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The view looks like this:

End of Exercise 4-4 
The FrontCrash_4.tdv layout, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Additional Exercise
If you have time, complete the following exercise.

1. Use the Transfer to REPORT function to transfer the current 
worksheet to DIAdem REPORT.

2. In DIAdem REPORT, add a frame and grid lines.

3. Set manual scaling for the x-axis and limit the value range from 10 to 80 
ms.

4. Save the report.

The report could look like this:
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E. Editing Data in Channel Tables
Use channel tables to view and edit the contents of data channels, time 
channels, and text channels.

To list channels in a channel table, select the channels in the Data Portal and 
drag and drop the channels into the channel table. DIAdem displays 
channels columnwise in the channel table, with headings that are channel 
properties such as, name, number, and channel length.

To edit the y-values of the curves specified in an axis system, select 
Displaytype»Channel table in the shortcut menu. 

Double-click the left edge of the channel table to open the Display dialog 
box shown in Figure 4-5. In this dialog box you can specify new columns, 
or move, modify, and delete existing columns. For each column, you can 
select another channel in the bottom part of the dialog box and enter a 
display format.

Figure 4-5.  Dialog Box for Defining Channel Tables

Click the column header in the channel table to select the column. You can 
move selected columns and press <Del> to delete selected columns from the 
channel table. To change the width of a column, move the right or left edge 
of the column header. The width of the other columns does not change. 

Click Table settings in the shortcut menu to specify the display for the table 
contents, such as the font size. 
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The Channel Contents: Editing Single Values
Depending on the window size and the length of the channels, DIAdem only 
displays an extract of the data in the channel table. You can scroll the extract 
horizontally or vertically.

You can edit one or more channels, data from one or more channels (data 
blocks), or one single datum. To delete or overwrite a datum, click the data 
field. To edit a datum, double-click the data field.

To select a data block, click the first data field and drag to the last data field. 
Figure 4-6 shows a selected data block. If the block you want to select is 
larger than the extract displayed, drag the cursor over the edge in the 
direction you want. 

Figure 4-6.  Selected Data Block in a Channel Table

Click the column heading to select a channel. Then right-click to open the 
shortcut menu, which contains the editing functions. The shortcut menu also 
includes functions such as Delete and Generate. 

Delete deletes selected channel values. Use the Generate function to insert 
equidistant values into a channel.

Note When you edit the data in channel tables you change the internal data. You cannot 
undo data changes you make. To restore the data, you must reload the original data set. 
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You can use the Calculator to edit and calculate your data in DIAdem 
VIEW. You can use the Calculator to create and calculate channels. You also 
can use the Calculator to calculate and display single values and to assign 
variables.

Refer to Lesson 8, The DIAdem Calculator for more information about the 
Calculator, which you also can use in the DIAdem panels ANALYSIS and 
SCRIPT.

Channel Properties: Viewing and Editing Characteristic Values
To display other properties than the name, numbers, and length of the 
channels, select the properties in the Data Portal and drag and drop the 
properties into the channel table.

To delete properties from the table header or to change the display format, 
select Select properties in the shortcut menu. The dialog box shown in 
Figure 4-7 appears. The properties and characteristic channel values that 
DIAdem can display in channel tables are displayed on the left. The 
properties include comments, physical unit, channel type, the display format 
for the channel contents, and additional information. The overview on the 
right is a list of the properties that DIAdem currently displays in the channel 
table.

Figure 4-7.  Dialog Box for Selecting the Channel Properties in Channel Tables

To display another property in the channel table heading, select the property 
from the list on the left of the dialog box, and click > to include the property 
in the Properties to be displayed. The Format specifies the display format 
for the numeric properties and characteristic values.

In the table heading, DIAdem dims channel properties that you cannot edit, 
such as maximum length, NoValues, monotony behavior, and minimum and 
maximum value. Property fields that you can edit have a white background 
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in the channel table. Click a property field to delete or to overwrite the 
contents. Double-click a property field to edit the contents.

Note You specify the channel properties in the Data Portal. In the custom properties, 
you can include special information for each channel, such as test conditions or 
characteristic statistical values. 
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Exercise 4-5
Objective: Generating a Data Channel

In the following exercise you load the data of a measurement that took 
approximately 250 ms. When you view the data, you see that the channels 
have different lengths of 324 and 1944 values, which means that the data 
were acquired at different sampling rates in this time interval. Therefore, 
you cannot assign all channels to the existing time channel. 

In the following exercise you generate a new time channel for the data 
measured at a lower sampling rate and enter associated channel properties.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the FrontCrash_2.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

4. In the Data Portal, open the shortcut menu for the channel group Car_1, 
and select New»Channel.

5. Enter Time2 as the name and click OK.

6. Move the Time2 channel to the fifth position in the Data Portal. The 
time basis is now at the top of each Data Portal group, followed by the 
data channels that relate to that time basis. 

This means that the channels a_Head_hor, a_Head_ver, and 
a_Head_lat are related to the time base Time1; and Speed and 
p_Airbag are related to the time base Time2.

7. Select DIAdem VIEW.

8. Open the Predefined screen partitioning function bar and select One 
channel table with all channels.

The channel table displays the contents of all the channels in the Data 
Portal. 
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9. Select the first channel value of the empty channel Time2.

10. Select Generate in the shortcut menu.
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11. Set the dialog box parameters as shown in the following figure:

If you enter CMax(1)/323, DIAdem reads the maximum value of the 
first channel, which is the exact time the measurement takes, and divides 
this value by the number of intervals. The number of intervals is lower 
than the number of values.

You can enter variables and mathematical expressions in dialog box 
entry fields. The Calculator calculates your entries. This allows you to 
also calculate and display single values in entry fields.

Note Refer to Lesson 8, The DIAdem Calculator for more information about the 
Calculator.

Click OK. DIAdem creates the channel values according to the 
generation rule.

12. Set the following channel properties for the Time2 channel in the 
appropriate property fields of the channel table:

Unit: ms
Description: Time for slower channels
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The view looks like this:

Note This function generates numeric values in equidistant steps in a channel. The 
Basic mathematics in DIAdem ANALYSIS includes more functions for generating 
channel data. Select the Generate time channels function to create channels with 
equidistant time values. Select Generate data to break down existing channels, and to 
generate new channels with equidistant or geometric step widths.

End of Exercise 4-5 
The FrontCrash_3.tdm data set, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 4-6
Objective: Calculating Channels

In the following exercise you use the Calculator to determine the resultant 
of the three head accelerations.

1. Select DIAdem VIEW.

2. Click the Calculator in the toolbar.

3. Use the following formula to calculate the resultant R from the head 
accelerations:

Use the sqrt function to calculate the square root. Use the sqr function 
to calculate the square. If you replace the variables x, y, and z with the 
appropriate data channels, the following formula results:
Ch('Resultant'):= 
sqrt(sqr('a_Head_hor')+sqr('a_Head_ver')+
sqr('a_Head_lat'))

Enter the formula in the Edit field.

Click Calculate.

In the Data Portal, DIAdem generates the new Resultant channel with 
the formula result.

4. Close the Calculator.

5. Enter the g as the unit property for the Resultant channel in the Data 
Portal.

R x2 y2 z2+ +=
© National Instruments Ireland Resources Limited 4-31 DIAdem Basics Course Manual



Lesson 4 Viewing Data
6. Position the Resultant channel above the Time2 channel in the Data 
Portal:

End of Exercise 4-6 
The FrontCrash_4.tdm data set, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
DIAdem Basics Course Manual 4-32 ni.com



Lesson 4 Viewing Data
F. Configuring DIAdem VIEW
The Desktop parameters are the program settings you can specify in 
DIAdem.

Making Panel-Specific Settings
In DIAdem VIEW, select Settings»Desktop parameters»Panel specific. 
The configuration dialog box has the following settings:

Library path Displays the current library folder with VIEW 
layouts.

User path Displays the current user folder with VIEW 
layouts. 

Default file Specifies the VIEW layout that DIAdem displays 
when the VIEW panel opens.

You load and save VIEW layouts in the REPORT folders. Therefore, you 
cannot modify the library and user path in the panel-specific DIAdem 
VIEW settings: you also can modify them in the DIAdem REPORT settings 
or by selecting Settings»Desktop parameters»General»Path selection.

You can save all the program settings in a desktop file. The desktop file has 
the filename extension .ddd. To save your settings in a desktop file, first 
select Window»Close all. Then click Save desktop.

Specifying Layout Parameters
Select Settings»Layout parameters to specify how DIAdem accesses 
channels. You can use the channel name or the channel number to assign 
channels. By default, DIAdem works with the channel names and the group 
index.
DIAdem saves the layout parameters with the layouts.

Note  The channel assignments in channel tables and 2D axis systems stay the same, 
regardless of which mode is set, even if you assign new channel numbers. If you save a 
layout in a name-oriented mode and then reload it, DIAdem uses the first channel with 
the specified name when the channels have the same name but different channel numbers. 
The channel assignments in channel tables and 2D axis systems remain unchanged even 
if you delete channels in the Data Portal, or if you load a layout with channels assigned 
that DIAdem cannot find in the Data Portal. 
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Configuring Flag Parameters
Select Settings»Flag parameters to specify how the flag functions in 
DIAdem VIEW work.

• Use the Delete parameter to specify whether DIAdem VIEW deletes the 
selected data or sets NoValues when you click Flags: Delete data 
points. 

• Use Interpolate to specify how DIAdem VIEW approximates the areas 
marked by the flags when you click Flags: Interpolate points.
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Summary, Tips, and Tricks

• You can include axis systems, channel tables, and textboxes in one 
worksheet, to see the data on the curve and the associated numeric 
values simultaneously, and to record your evaluation in a textbox.

• The screen partitioning function bars have templates for splitting the 
worksheet into varying numbers of sections that are in different 
positions. Previous graph entries are included in new screen partitioning 
as far as possible.

• To generate a curve, select two data channels in the Data Portal. Click 
the channel you want to use as the x-channel. <Ctrl>-click the y-channel 
you want to use. Drag and drop this channel pair into the axis system.

You list data in channel tables in the same way.

• To specify the leading curve, click the associated curve symbol in the 
legend area.

• Use the zoom function in the axis toolbar to enlarge and to inspect 
separate sections of the curve. You only can use the zoom function with 
a band cursor or a frame cursor. The zoom function always affects all the 
curves in an axis system.

• When you edit the data in channel tables you change the internal data. 
You cannot undo data changes you make. To restore the data, you must 
reload the original data set.

• You can use the Calculator to create and calculate channels. You also can 
use the Calculator to calculate and display single values and to assign 
variables. You also can use the Calculator functions in the dialog box 
textboxes.
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Notes
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Lesson 5
Creating Reports
Introduction
In this lesson you will learn how to document and present data in DIAdem.

You Will Learn About: 

A. Documenting Data

B. Creating a Report

C. Printing a Report

D. Saving the Layout

E. Format and Display Modes

F. Configuring DIAdem REPORT
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A. Documenting Data
You use DIAdem REPORT to generate reports that document your data. 
You can access all the data in the Data Portal and present it in a variety of 
ways. Figure 5-1 shows the DIAdem REPORT interface. 

Figure 5-1.  A Worksheet in DIAdem REPORT

The various graphical display objects are grouped into function bars: 2D and 
3D axis systems, 2D and 3D tables, polar axis systems, graphics, and 
decorations. The related function bars have different types of these objects.

A report may consist of several worksheets with different views of your 
data. When you lay out your worksheets, you can combine all the graphic 
objects, and position and scale them freely. Double-click an object to assign 
data to it and to set the object parameters.

You save the report worksheets and the links to the displayed data, in a file 
with the filename extension tdr. You can reuse layouts as templates for 
similar reports.

The toolbar contains functions for loading and saving layouts and for 
printing the report. The toolbar also has functions for aligning selected 
objects, and for refreshing the report.

1 Toolbar with alignment functions
2 Group bar with axis systems, tables, graphics, and 

decorations
3 2D axis systems

4 Worksheet tabs
5 2D table
6 Integrated graphic
7 Text
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B. Creating a Report
You can use any combination of axis systems, tables, text, and graphics in a 
report. DIAdem displays the data in curves or bar diagrams in axis systems, 
and lists numeric data in tables. You can label your report with text and 
comments and illustrate your report with graphics and lines.

In DIAdem REPORT you do almost everything with the mouse. You use the 
mouse to position the various objects in the worksheet and you drag and 
drop the data channels to be displayed, from the Data Portal to the axis 
system or table.

You can include existing layout files or blank worksheets in your report. To 
add a blank worksheet, click New in the tab bar shortcut menu. To add 
several blank worksheets, select Manage in the shortcut menu. In the dialog 
box that appears you can add, delete, and change the order of the 
worksheets. Select File»Append layout to add completed worksheets. 

Using the Report Wizard
Press <Ctrl-W> to open the Report Wizard, which you use to generate a 
report.

Use the Report Wizard to generate a report in three steps:

1. First select the data you want to display.

2. Specify the x and y-channels for the curves.

3. Select the curve display mode.

DIAdem creates a report in the current DIAdem REPORT worksheet 
according to the parameters you set in the Report Wizard. You can use the 
report as a template and edit it.

Template: Predefined Layout
You save and load layouts separately from the data. This allows you to reuse 
the layout for any data set.

You can load a report as a template for a prepared layout, and then adapt the 
layout to data you want to evaluate, or to the project, or to specific company 
standards.

When you open DIAdem REPORT, the worksheet contains the layout that 
you designate as the Default file in the dialog box that opens when you 
select Settings»Desktop parameters»Panel specific. If you want to always 
access a specific layout when you click New, specify this layout as the 
Template in this dialog box. You can insert objects that every report should 
have, such as the company logo.
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Figure 5-2 shows the standard DIAdem default layout. The layout has a 
frame. You can only move, scale, or rotate graphic objects inside this frame. 
Select Settings»Layout parameters to specify the frame.

Figure 5-2.  Default Layout that DIAdem Loads when It Launches

When you load a layout, DIAdem displays the report with the data channels 
specified in the layout. If no data appears in the axis systems or tables 
although the appropriate data is in the Data Portal, you saved the layout last 
time without assigning data. Drag and drop the data channels you want to 
display from the Data Portal to the axis system or the table. 

Page Format
To protect the object alignment, specify the page format before you create 
the report. You can specify a relative or a scaled page format. DIAdem saves 
the page format with the layout.

A relative page format specifies the paper format and page orientation. In 
the print dialog box you enter the width of the printout, corresponding to the 
selected paper format. If you change the paper format later, DIAdem can 
adapt the report to the new format because it specifies the distance from each 
object to the edge of the page as a percentage of the page width and the page 
height-.

For scaled page format, select Settings»Layout parameters and enter a 
fixed height and a fixed width for your worksheets. DIAdem always prints 
your report in the specified size, regardless of the selected paper format. If 
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you select scaled page layout, you can scale your axis system manually to 
ensure that DIAdem always prints the same number of units per centimeter, 
for example, 10°C/cm.   

Editing Objects
You can combine axis systems, tables, text, graphics, and decorations in a 
report, position them where you want, and resize them.

Selecting Objects
You use either the mouse or the <Tab> key to select objects. The latter is 
useful if the objects are underneath each other. 

You can select several objects at once by drawing a selection box. To do this, 
click anywhere in the worksheet and drag to enclose the objects you want to 
select. Alternatively, click the first object, press <Ctrl>, and click additional 
objects.

You also can click subobjects to enable them. The subobjects of an axis 
system include the axes, the axes labels, the axis scale, and the curves. The 
subobjects of a table include the table header and the single columns. You 
can select, move, and configure each subobject separately.

Go through the subobjects of a selected object with <Shift-Tab>. <Shift>-
click overlapping objects. The enabled object has a thick blue frame. When 
you release the <Shift> key, the object is selected and you can edit and 
configure the object.

Selected objects are framed with scaling marks on the corners and on the 
middle of the sides.

To undo a selection, click anywhere in the worksheet, or press <Esc>.

Manipulating Objects
You can move or resize selected objects.

When you idle the cursor over the scaling marks, the shape of the cursor 
changes. To resize the object, click and drag a scaling mark.

Click and drag the corner marks to resize the object maintaining the height 
to width ratio. If you use the marks at the sides, you can move the sides 
separately.

To disable proportional scaling, click the corner marks and press <Shift> at 
the same time. You only can do this with graphic objects that may distort. 
Text only can be scaled proportionally.
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The corner and side markers opposite the side you move, do not change 
position when you scale an object. However, if you press <Ctrl> at the same 
time, only the center of the object remains the same. This applies for all 
graphic DIAdem objects.

If you position the cursor on the enabled object, the moving cursor becomes 
visible. Press the left mouse button and move the object.

You can rotate one-line text freely. Click one of the corner markers again to 
enable the rotation mode.

Aligning Objects
The toolbar has several functions for aligning and scaling several objects.

You can align objects on one of the four edges, and DIAdem uses the object 
that protrudes the furthest as the reference point. You also can align objects 
horizontally, adjust the distance between objects to be equal, or make all 
selected objects the same size.

You can edit groups of selected objects in the same way as individual 
objects. This means you can move, resize, and configure the objects, but 
only if the edits apply for all the objects in the group. For example, if you 
cannot enlarge one of the objects, this applies to the entire group.

To enter common parameters like color, line width, line style, font, and font 
size for a group of selected objects, open the shortcut menu for the group 
and select Properties. In this dialog box, the settings that do not have the 
same default for all the selected objects are empty.

Undoing Object Edits
You can undo your edits in DIAdem REPORT. To undo actions such as 
positioning, rotating, and scaling, starting from the last action, select 
Edit»Undo.

Note DIAdem cannot undo object definitions you set in dialog boxes.

Axis Systems: Displaying Data as Curves
Axis systems display data channels in relation to each other. For example, 
you use a 2D axis system to display velocity over time, or 3D axis systems 
to display air pressure and a related temperature over time as isolines. You 
can display the sensitivity of a microphone in a polar axis system.
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2D Axis Systems
Use 2D axis systems to display data channels as curves or as bar diagrams.

The 2D axis system function bar contains templates for 2D axis systems, for 
example, with and without grid lines, with linear or logarithmic partitioning, 
and with one or more y-axes. Select Simple 2D axis system to insert an axis 
system into the worksheet. 

Click and drag open the 2D axis system anywhere in the worksheet. 
DIAdem inserts the axis system and displays it with a selection frame. Now 
you can move and scale the axis system.

To generate a curve, select two data channels in the Data Portal. Click the 
channel you want to use as the x-channel. <Ctrl>-click the y-channel you 
want to use. Drag and drop this channel pair into the axis system. 

Double-click the axis system to open the dialog box where you specify the 
layout for the axis system and for the curve. Figure 5-3 shows the dialog box 
for curve and axis definition.

Figure 5-3.  Dialog Box for 2D Curves and Axis Definition

Use the Axis definition subdialog box to set the global display parameters, 
which specify the appearance of the axis, of the frame, and of the grid lines.

Use the Curve param subdialog box to specify other curve parameters that 
apply for the selected display mode. For example, in the Line display mode, 
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you can specify that markers appear at every twentieth displayed data point, 
as shown in Figure 5-4.

Figure 5-4.  Curve with Markers

You can enter more than one curve in an axis system. If the y-channel value 
ranges differ very greatly, specify several y-axes.

The 2D axis system function bar has prepared axis systems that have several 
y-axes. You also can add subaxes to an existing 2D axis system. To modify 
existing subaxes and to specify additional y-axes, select the Subaxes 
subdialog in the dialog box for curve and axis definition.

In the main dialog box for the curve and axis definition, you specify several 
y-axes and you must assign a subaxis system to each channel pair as shown 
in Figure 5-5. First enable the channel pair in the overview and then enable 
the subaxis system in the selection list.
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Figure 5-5.  Each Curve Can Have a Separate Subaxis System

After you display the axis system, you can move the subaxes and reduce 
them, as in the top axis system in Figure 5-6. When you reduce the subaxes, 
the curves and the reference axis change.

Figure 5-6.  The Top Axis System Has Two Different Y-Axes
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When you display multiple curves in one axis system, as shown in Figure 5-
7, use a Legend to assign the curves to the data. Enable the legend display 
in the dialog box for curve and axis definitions. Set parameters for legend 
labels, headings, position, and size in the Legend subdialog. Double-click a 
legend to open the dialog box where you can modify the parameters.

Figure 5-7.  Each Axis System Can Display a Legend

3D Axis Systems
Use 3D axis systems for surface, waterfall, isoline, 2D matrix, and 3D curve 
display. For example, you can display the results of a rainflow matrix in a 
2D matrix where the size of the square reflects the frequency counted.

The 3D axis system function bar has various templates for 3D axis systems, 
for example, with and without grid lines. Select Simple 3D axis system to 
insert an axis system into the worksheet. 

Click and drag open the 3D axis system anywhere in the worksheet. 
DIAdem inserts the axis system and displays it with a selection frame. Now 
you can move and scale the axis system.

To generate a curve, select three data channels in the Data Portal. Click the 
channel you want to use as the x-channel. <Ctrl>-click the y-channel and the 
z-channel you want to use. Drag and drop this channel triple into the axis 
system. 
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Which display features you can use in the axis system depends on how your 
3D data is organized. Depending on the type of display, data must be stored 
as xyz-value triples or as an xyz-matrix. DIAdem requires matrix data for 
surface, waterfall, bar, 2D matrix, and 3D curve display, but DIAdem also 
can use value triples for spike and symbol display. Refer to Lesson 11, 
Organizing 3D Data for more information.

Double-click the axis system to open the dialog box where you specify the 
layout for the axis system and for the curve. To change the view of a 3D axis 
system, rotate the axis system by resetting the Axis definition dialog box. 
You can scale and label each display level separately, and add grid lines.

You also can position a display layer vertical to the two other display layers 
in the worksheet. To move a plane outwards, click the edge of the plane. The 
cursor changes to a triangle and you can click and drag the plane outwards.

Polar Axis Systems
Use polar axis systems to project the values of a channel onto a circle.

The Polar axis system function bar has various polar axis system 
definitions, including 360°, 180°, and 90° aperture angles. Click Polar axis 
system with 360-degree aperture angle to insert a polar axis system into 
the worksheet. 

Click and drag open the polar axis system anywhere in the worksheet. 
DIAdem inserts the polar axis system and displays it with a selection frame. 
Now you can move and scale the polar axis system.

To generate a curve, select two data channels in the Data Portal. Click the 
channel you want to use as the x-channel with the angle values. <Ctrl>-click 
the y-channel with the length values you want to use. Drag and drop this 
channel pair into the polar axis system. 

Double-click the axis system to open the dialog box where you specify the 
layout for the polar axis system and for the curve. Use the subdialogs 
Scaling, Numbers, Labeling and Display to set the parameters for your 
polar axis system.

Using Tables: Displaying Data Numerically
Tables list channels numerically. 2D tables also can display text channels, 
formula expressions, and variable contents. You can display tables 
horizontally or vertically.

2D Tables
Use 2D tables if you want to list data channels, time channels, and text 
channels in columns.
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The 2D table function bar has various templates, for example, for 2D tables 
with and without separators. To insert a simple table in the worksheet, select 
2D table with horizontal and vertical separators. 

Click and drag open the 2D table anywhere in the worksheet. DIAdem 
inserts the table and displays it with a selection frame. Now you can move 
and scale the table.

Select channels in the Data Portal and drag and drop the channels into the 
table. DIAdem transfers the channels in the order you select them in. You 
can resize the column width and the row height by shifting the 
corresponding separating lines.

Double-click the table to open the dialog box where you specify the display 
for the table and for the data. Figure 5-8 shows the dialog box for 2D table 
definition. The dialog box for the table definition gives you an overview of 
the channels to be displayed. You can modify the table display in the 
subdialog boxes Headers, Columns and Display.

Figure 5-8.  Dialog Box for 2D Table Definition

Tables can display not only the contents of a channel, but also variables or 
results of an expression, which means a combination of text and variables.

For the Variable data type, you enter only the variable name  in the dialog 
box, without a dimension or format instruction. If the variable is a scalar 
variable, the table only displays the variable content once. The table displays 
the contents of vector variables according to the variable type and the table 
length.
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With the Expression data type, you can format a variable and add any new 
text. If you use a variable in an expression, you must enclose the variable in 
@ characters. Vector variables also require a reference to the dimension.

Note To access table columns use the variable D2TabCol in an expression, and to 
access table rows use the variable D2TabRow in an expression.

Example [@CD(D2TabRow)@]

This expression enters the channel unit in the table in brackets. If you use 
the variable D2TabRow, the unit of the first channel appears in the first table 
row, the unit of the second channel appears in the second row, and so on.

The table in Figure 5-9 displays all the values and text from the selected 
channels. Display very long channels in sections so the numbers and text are 
more legible. If you want to display the trends in the single channels, only 
display every twentieth value, for example.

Select Automatic expand as the Table length in the Table definition 
dialog box for complete documentation of long channels. This defines a 
table that lists the channel contents on several pages. Use the functions 
Previous table contents and Next table contents in the DIAdem REPORT 
toolbar to scroll in the table. DIAdem automatically prints reports with 
multipage tables on several pages.

Figure 5-9.  Report with Two Axis Systems and a Table
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3D Tables
Use 3D tables if you want to numerically list data channels as a matrix. 

The 3D table function bar has two templates for 3D tables, with and without 
labels. Select 3D table without labels to insert a basic table into the 
worksheet. 

Click and drag open the 3D table anywhere in the worksheet. DIAdem 
inserts the table and displays it with a selection frame. Now you can move 
and scale the table.

To display an xyz-matrix, select three data channels in the Data Portal. Click 
the channel you want to use as the x-channel. <Ctrl>-click the y-channel you 
want to use and the first z-channel. Drag and drop this channel triple into the 
axis system. 3D tables assign each xy-value pair the associated z-value. 

Double-click the table to open the dialog box where you specify the display 
for the table and for the data. The 3D table can display the entire data matrix 
or a section. The 3D table can also skip values in long channels, and only 
display every twentieth value, for example. You enter display parameters 
like font and display mode separately for the x, y, and z-values, not 
columnwise.

Note To display data channels as triples, list the three data channels in a 2D table. Each 
row in the table then contains a value triple. Refer to Lesson 11, Organizing 3D Data for 
more information about 3D data.

Texts: Labels, Descriptions, Comments
Reports often include explanatory text. You can insert text anywhere in the 
worksheet.

You can integrate two kinds of text: free text and text objects. Use free text 
for short text like headings and expressions, and the text object for long texts 
with several lines that can contain more than one text format, such as a text 
field.

Free Text
Use free text to include short texts in your report or if you want to align and 
rotate text in relation to objects.

The Decorations function bar has free text, a text object, comments, 
rectangles, circles, lines, and arrows. Click Texts to enter text.

The cursor changes and appears as a vertical line with Abc attached. Use the 
text cursor to click the position where you want to insert the text in the 
worksheet. A blinking entry marker appears. 
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Click anywhere in the worksheet, a flashing text cursor appears, and you 
enter your text. Press <Return> to separate lines: DIAdem generates a free 
text for each line. Click another position in the worksheet to finish the text 
entry. 

Now you can move and resize the text. If you use the selection frame to 
zoom text in the worksheet, you enlarge the font size. 

Double-click the text to open the dialog box where you expand the text or 
modify the font attributes. You also can include formulas and variables in 
text. DIAdem only recognizes formulas and variables set in @ characters.

You can rotate free text. Click one of the squares at the corners of the 
selected text shown in Figure 5-10, and rotate the text to the right or to the 
left with the curved arrow.

Figure 5-10.  Rotating Free Text

Select Default setting in the shortcut menu for the button to change the font 
attributes for the free text. Any text you write after changing the attributes 
appears with the new attributes.
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Text Objects with Different Formats
Use text objects to generate several lines of block text with different formats.

The Decorations function bar has free text, a text object, comments, 
rectangles, circles, lines, and arrows. Select Text object to insert a text 
object into the worksheet. 

DIAdem inserts the text object into the worksheet as a white rectangle. 
Double-click the white field to open the text editor, which you use to enter 
text, to import existing files in ASCII, RTF, or HTML format, and to 
integrate DIAdem variables. Figure 5-11 shows the text editor, where you 
can set the following formats for single words, formulas, and sections: 

• The following standard functions are available for character formatting: 
font, font size, font color, font type, subscript and superscript. 

• For paragraph formatting the following options are available: alignment, 
bullets, numbering, and left and right tabs.

• Use the menu bar options to format the background and insert DIAdem 
expressions, tables, and graphics.

Figure 5-11.  All Kinds of Formats are Available for Text Objects

When you close the editor, you can move and resize text objects. If you 
resize the text object, you only change the line feed for multiline text, not 
the size of the actual letters. You cannot rotate text objects.
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Figure 5-12 displays the text object at the bottom right in the report:

Figure 5-12.  Report with Text Object

Note Text object font size definitions are different from single-line text and axis label 
definitions. You specify the font size for the text object in points, not in relation to the 
page width.

Graphics, Rectangles, and Lines
Use graphics to include a diagram of a test stand, or to insert a company logo 
into your graphic, for example. 

You can use the Graphics file function bar to load graphics in various 
formats, such as wmf, bmp, jpg, tif, and gif. The first four buttons in the 
function bar have predefined graphics. Select the fifth button, Load 
graphics, to load a graphic from the folder. 

When you select a graphic in the preview, DIAdem inserts the graphic in the 
top left of the worksheet. Now you can move and resize the graphic. 
Figure 5-13 displays a graphic at the bottom right in the report.

When you integrate graphics in your report, DIAdem only generates a link 
to the graphics file. DIAdem saves the link with the path in the layout. If you 
load a layout and DIAdem displays a gray frame instead of a graphic, 
DIAdem was not able to find the graphics file in the specified folder. 
Double-click the graphic and correct the path definition.
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Click Default setting in the shortcut menu to assign frequently used 
graphics to the four buttons in the Graphics function bar. You then click the 
appropriate button to integrate the logo into your report.

Figure 5-13.  Report with Graphic

Use rectangles to frame text fields or headings in reports.

The Decorations function bar has rectangles, circles, lines, and arrows. 
Select Rectangles to insert a rectangle into the worksheet. 

Click and drag open the rectangle anywhere in the worksheet. DIAdem 
inserts the rectangle and displays it with a selection frame. Now you can 
move and scale the rectangle. Double-click the rectangle to open the dialog 
box where you specify the frame and the background color. 

The Decorations function bar also includes comments. Use comments to 
link objects in a report to a comment text. Use circles and ellipses to 
highlight an area of your report. Use lines and arrows to display report 
objects or curve points. 
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Displaying the Report
You can superimpose axis systems, tables, text, and graphics in a worksheet. 
The superimposed objects are visible because the backgrounds are 
transparent. To highlight a text in an axis system, select White for the text 
background.

DIAdem displays objects in the same order you insert them. The new 
objects are in the foreground. You can change the order of the objects. For 
example, to position a graphic behind an axis system, select the graphic and 
click Move to background in the shortcut menu.

You can refresh the report display, which means that DIAdem then redraws 
the report, updates the variable contents, and displays the objects in the 
actual order.

To display reports with large graphics and extensive data channels faster, 
you can temporarily block the display of graphics and curves. Deselect 
View»Graphic layer to display a gray wildcard with the filename instead 
of the graphic. Deselect View»Data layer to delete all curves and table 
entries. Select Graphic layer to redisplay the graphics and select Data 
layer to redisplay the curves and table entries. 
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Exercise 5-1
Objective:  Creating a Report with Three Axis Systems

In the following three exercises you create a report for a crash test. In the 
first exercise you display the head acceleration, the resultant, the velocity, 
and the airbag pressure over time, in three axis systems.

1. Select DIAdem REPORT.

2. Click Load layout.

Navigate to the FrontCrash_1.tdr layout in the 
C:\Exercises\DIAdem Basics\ folder and open the layout.

3. Open the 2D axis system function bar and select a Simple 2D axis 
system. 

4. Click and drag open the 2D axis system where you want to have it in the 
worksheet. 

5. Click the Time1 channel in the Data Portal and select the channels 
shown in the following figure. 

6. Drag and drop these channels into the axis system. 
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7. Double-click the y-axis labeling to open the dialog box for y-axis 
labeling, and change the text as shown in the following figure: 

Click OK. 

8. Repeat steps 3 - 6 to specify two more 2D axis systems, as described in 
the following steps:

• Display the Time1,Resultant curve in the middle axis system

• Display the curves Time2,Speed and Time2,p_Airbag in the 
bottom axis system

9. Position the three axis systems underneath each other and adjust the 
size.
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The report looks like this:

End of Exercise 5-1 
The FrontCrash_2.tdr layout, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 5-2
Objective:  Multiple Y-Axis Scaling

In the following exercise you create a second y-axis in the bottom axis 
system to scale the airbag pressure separately, because the velocity and the 
airbag pressure have different units and value ranges.

1. Select DIAdem REPORT.

2. Double-click the bottom axis system to open the dialog box where you 
set the parameters. 

3. Click Subaxes to define another axis: 

4. Click New axis to generate another axis: 

Specify the Offset as %, which is the distance between the new axis and 
the first y-axis, as a percentage.

A negative entry moves the axis to the left in relation to the defined 
reference point (axis origin), and a positive entry moves it to the right.

Click OK.
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5. Click the curve pair Time2,p_Airbag in the list of curves and select 
the subaxis system 2 X-1/Y-2 (0.0,-8.0) in the dialog box.

Click OK.

6. Move the left edge of the bottom axis system to the right until both 
y-axes appear.
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The report looks like this:

End of Exercise 5-2 
The FrontCrash_3.tdr layout, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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C. Printing a Report
You can print the report on any printer that is installed in the system. Click 
the Print button in the toolbar.

If you select Settings»Layout parameters and set relative page format, you 
can specify the size of the printout in the print dialog box. 

Click Save graphic as in the toolbar to export your report as a graphic. 
DIAdem supports various graphics formats.

Click Copy graphic to Clipboard in the toolbar to copy the report to the 
Windows clipboard and from there into an open text document. The status 
bar shows you when the report is copied. In text processing you use the 
Paste function to copy your report from the clipboard as a Windows 
metafile. 
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D. Saving the Layout
You can save a completed report as a template and load the template at any 
time to display other data. The layout contains specifications for aligning the 
graphic objects and the channel names that DIAdem displays in the 
respective objects. You save the data set separately in DIAdem 
NAVIGATOR.

Before you save the layout, select Settings»Layout-Info to assign the name 
of the author, the project name, and brief comments on the layout.

You can use your report layout as a template for an analysis in DIAdem 
VIEW. To transfer the layout of the visible worksheet to DIAdem VIEW, 
click Transfer to VIEW in the toolbar. In DIAdem VIEW, 2D axis systems 
do not change, 2D tables become channel tables, and 3D axis systems, 3D 
tables, and polar axis systems generate empty spaces. Text disappears.
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Exercise 5-3
Objective:  Integrating Graphics and Text

In the following exercise you integrate a picture of the measurement object 
and a test description in the report.

1. Select DIAdem REPORT.

2. Open the Graphics file function bar and select Load graphics.

Navigate to the FrontCrash.wmf graphic in the 
C:\Exercises\DIAdem Basics\ folder and load the graphic.

3. Position the graphic in the top right of the worksheet and adjust the size. 

4. Open the Decorations function bar and select Texts to enter a free text. 

5. Click the text cursor in the worksheet where you want to insert the text. 
Enter the DIAdem variable @CurrDate@ to display the current date.

6. Press <Enter> twice to insert a blank line between the two lines of text. 
Enter a text in the bottom line, for example, the vehicle type Amalfi. 

Click another position in the worksheet to finish the text entry.

7. Double-click the text to open the dialog box with the text parameters. 
Set the Arial font, the font size 4, and blue as the font color. 

Click OK.

8. Position the text in the text field on the right of the report, as shown in 
the following figure.
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9. Click Save layout as.

Open the C:\Exercises\DIAdem Basics\ folder and save the 
report file as FrontCrash_2.tdr.

The report looks like this:

Note Update the report to display the final result after editing and before printing. This 
is especially important when you integrate graphics or modify the data in the Data Portal.

End of Exercise 5-3 
The FrontCrash_4.tdr layout, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
© National Instruments Ireland Resources Limited 5-29 DIAdem Basics Course Manual



Lesson 5 Creating Reports
Additional Exercise
If you have time, complete the following exercise.

1. Use the Copy graphic to clipboard function to copy the created report 
to the Windows clipboard. 

Paste the report into a word processor such as MS Word or WordPad to 
check the graphic export.

2. Use the Save graphic as function to export the report as a JPG file. 

Open the JPG file in the Explorer to check the export.

3. Select Insert»Graphics to paste the JPG file created in step 2 into the 
current worksheet in DIAdem REPORT.
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E. Format and Display Modes
DIAdem offers various formats for displaying numbers, time data, and text. 
This section also includes information about several display modes.

Format Options
You can specify a format wherever numeric data or time data are displayed. 
This includes labeling axis systems, displaying data as a table, and 
displaying numerical variables formatted in labels.

Formatting Numeric Data
Format specifications for numerical display are useful in the following 
cases:

• Only a particular number of places after the decimal point are relevant 
for the data.

• The report to be generated does not have enough space to display all the 
numbers.

• The range of measured values is so large or small that the E format is 
more informative than floating point display.

Format specifications for numeric labels may include the following 
characters:

d Identifier for decimal format (floating comma display)
dd.ddd displays numbers with two places before and three 
places after the decimal point, for example, 12.345. If 
numbers with more than two places before the decimal point 
occur, DIAdem automatically expands the display. 

e Identifier for numbers in E format
d.dde displays exponentials, for example, 1.23E+01.

h Identifier for powers of ten
d.ddh displays numbers as exponentials with a superscripted 
power of ten, for example, 1.23*10².

. or, Decimal character
A point or a comma separates the digits before and after the 
decimal separator. 

b Identifier for binary format
DIAdem displays numbers as single bits.
bbbb bbbb means eight bits and the value range 0...255. The 
number 43 then appears as 0010 1011. All bits are displayed.
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Time Data Format
DIAdem writes time data numerically. The time is a code calculated as the 
number of seconds from the year 0 up to now.

Note Time specifications are only useful in the internal DIAdem time code.

For DIAdem to recognize a format as a time format, you must enter a 
leading # character. A format specification can consist of any combination 
of the default time format:

mm/dd/yyyy  hh:nn:ss.ffff 
Month/Day/Year  Hour:Minute:Second.Fraction of a second

Format specifications for time data may include the following characters:

If you use uppercase letters instead of lowercase letters in the format 
specification, DIAdem replaces leading zeros with blanks.

Examples hh:nn:ss   =>   01:01:00

HH:NN:SS   =>    1: 1: 0

HH:nn:ss   =>    1:01:00

$ Identifier for hexadecimal format
$$$$ represents the value range 0...65,535. For example, the 
number 43 appears as $2B. The $ character appears before the 
numbers to indicate a hexadecimal number. DIAdem 
suppresses leading zeros.

! No text display for NoValues
DIAdem suppresses the text NoValue for NoValues.

abs Identifier for the absolute value
You can combine this identifier with the characters listed 
above, for example, abs d.dd.

m or M Wildcard for month

d or D Wildcard for day

y or Y Wildcard for year

k or K Wildcard for calendar week

h or H Wildcard for hour

n or N Wildcard for minute

s or S Wildcard for second

f Wildcard for fraction of a second
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The following codes are reserved for the display of months and week days 
as texts. The codes either provide the complete term or are limited to a 
particular number of letters:

Example www, DD. T, yyyy         =>   Mon, 28. July, 2003

If the time format goes over two lines, use a / slash to separate the top line 
from the bottom line. DIAdem repeats the top labels for each tick and 
displays the bottom labels centered in relation to the time unit.

For example, the format #ttt/yy displays the first three characters of the 
respective month at each tick. The last two numbers of the year are specified 
in a second line in the middle of the year specification.

Formatting Text
Any text that appears in the report can also contain variables with format 
instructions and special codes, in addition to normal characters and special 
characters.

You can use the DIAdem Calculator features to display text. Refer to 
Lesson 8, The DIAdem Calculator for more information about the 
Calculator.

Superscripting and Subscripting Free Text
You can subscript or superscript separate characters or character groups 
within text. Enter one of the following control characters in front of the text:

You also can nest the above forms inside each other. You can use up to ten 
levels. DIAdem reduces the subscripted or superscripted text by a factor that 
relates to the index level:

Example X^t(abs)^n = 100 mm^h2^n =>   X(abs) = 100 mm2

t, tt Months (1, 2, ... characters)

T Written months

w, ww Weekdays (1, 2, ... characters)

W Written weekdays

^t Subscripts the following text by one layer

^h Superscripts the following text by one layer

^n Resets the subscript or superscript by one layer
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Integrating Variable Contents
To integrate the contents of a variable in a report, enclose the variable name 
in @ characters. For example, if you use @CurrDate@ in any text for display, 
the current date appears at the respective position in the report:

Example Date: @CurrDate@   =>   Date: 12.10.2004

The Calculator evaluates the expression between the @ characters before 
display. This means that you can use the Calculator operands and 
operations, and that all the expressions interpreted as single expressions are 
valid entries.

DIAdem offers several special variables you can use with the Calculator or 
for report labeling. These variables contain information on channel 
properties or data set properties or show the current date or time. Table 5-1 
displays an overview of these variables:

Table 5-1.  Special Variables

Variable name Meaning

Ch(No) Channel data with the channel number No

ChD(Line,No) Value of the channel with the channel number No 
in the line Line

ChT(Line,No) Value of the text channel with the channel number 
No in the line Line

CN(No) Name of the channel with the channel number No

CC(No) Comments on the channel with the channel 
number No

CD(No) Unit of the channel number No

CL(No) Length of the channel with the channel number No

CMax(No) Maximum value of the channel with the channel 
number No

CMin(No) Minimum value of the channel with the channel 
number No

CurrDate Current date

CurrTime Current time

CurrDateTime Current date/time

CurrDateTimeReal Current date/time in seconds

DataSetName Data set name
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You can replace the parameter No used in the first list with Name. In this 
case, the variables refer to the channel called Name, not to the channel with 
the number No. Use Group name/Channel name to access a channel of 
a certain channel group.

For flexible object labeling, use CCN as the variable index. If you replace the 
No parameter with CCN, the respective variable always accesses the channel 
specified in the first line of the object dialog box instead of accessing a 
specific channel.

Formatting Variable Contents
You also can export variable contents with a specific format instruction. You 
use the str function, with the variable and the format definition as 
parameters. The expression must be enclosed between @ separators:
@str(variable name,'Format template')@

Examples Minimum value: @str(CMin(1),'dddd.dd')@ [mm]

The expression outputs the following text for a minimum value of 156.344 
in channel 1:

Minimum value: 156.34 [mm]

Examples Display time: @str(CurrTime,'RRRRR')@ Time

This expression outputs the following text for the computer time 16:37:
Time: 16:37

The format 'RRRRR' specifies that five characters are displayed flush right. 
Alternatively, you can enter 'R:5'. The format 'R:8' displays seconds as 
well. Without a format instruction, DIAdem automatically uses the 
following variable format.

Examples Date: @str(TTR(CurrDateTime),'#mm-dd-yyyy')@

This expression outputs the following text for the date 06/12/2004:
Date: 06-12-2004

DataSetAuthor Author of the data set

DataSetTitle Name of the current data set

DataSetComment(i) Comment line of the current data set (i=1..100)

DataSetDate Date the data set was last modified

DataSetTime Time the data set was last modified

Table 5-1.  Special Variables

Variable name Meaning
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Formatting with User Commands
Use user commands as format instructions if you want to display data in a 
format that DIAdem does not recognize. You define user commands in 
DIAdem SCRIPT. Refer to DIAdem help for more information about user 
commands.

Notes on the Display Modes
In axis systems, you can select various curve display modes. The following 
sections are about the display modes Differential, Constant and Line 
and symbol.

Differential
Use differential display to display the distance between two curves. Both 
curves use the same x-channel. This display mode displays a bar or a line 
between the curve points x/y and x/y1.

Constant
Use the constant display mode to display lines in a 2D axis system. DIAdem 
uses the function x=constant or y=constant to display a line in the 
selected axis system or subaxis system.

To define a constant, select the constant display mode in the dialog box 
for curve and axis definitions. You then enter the values of the x and/or y-
constant to be displayed. Specify the line parameters in the Curve 
parameters subdialog box.

Line and Symbol
Use the Line and symbol display mode to display a curve that has 
symbols at certain points. You can use all the fonts in DIAdem as symbol 
characters or symbol strings. You also can use text control characters and 
special characters in the symbol character string. To integrate variable 
contents in the symbol character string, enclose the variable name and any 
format instructions in @ characters. 

The codes listed below can be combined with free text and with each other:

n Repeating symbols
The n character followed by a number means 
that DIAdem only displays the symbol at every 
nth curve point.

x(),y(),p() Coordinates
DIAdem displays the x or y-value, or the 
number of the data point, at the curve point.
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%([/XPos]
  [/YPos])

Shift
DIAdem can position labels in relation to the x 
or y-axis of the coordinate system, regardless of 
the curve coordinates. You also can use the /X 
and /Y parameters.
The parameter /y with a numerical position 
entry, specifies the percentage of the height of 
the axis system, by which DIAdem shifts the 
label vertically in the y-direction, in relation to 
the x-axis. Positive settings position the label 
above the x-axis, negative settings position the 
label below the x-axis.

W([/B][/E]
  [/Long])

Repetition
Specifies the number of labels on a curve and 
displays the labels at equal intervals. You can 
display the symbol at the first (Begin) and /or at 
the last (End) point on the curve. You also can 
specify the number of labels in relation to the 
curve length, which you enter as a percentage of 
the diagram diagonals.

T(/Dfile
 [/Iindex 
channel])

Text file access
DIAdem uses the text labels from an ASCII file 
called file (with extension). The /I 
parameter with indexchannel specifies 
access to the text lines in the file. DIAdem reads 
the text lines either according to the running 
index of the curve display (index 
channel=0), or according to the contents of 
the index channel. 

K(/Kchannel 
number
 [/Iindex 
channel])

Access to channel contents
DIAdem uses the numeric values of the 
channel number channel for labeling. If you 
do not specify an index channel, DIAdem 
accesses the channel number channel with 
the running index in the curve display. If you do 
specify the index channel, DIAdem uses the 
index channel contents to access the channel 
indirectly.
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Name-Oriented Mode
By default, DIAdem uses the channel name and the group index to assign 
the data channels in the report. This works well if the channels in the data 
files to be evaluated always have the same channel name and are always in 
the same channel group. However, if the channels in the data files to be 
evaluated have different channel names, but are always at the same position 
in the data set, you can use number-oriented channel reference in DIAdem 
REPORT. If you set number-oriented channel reference, DIAdem displays 
the channel number in front of the channel name in the definitions of the axis 
systems and tables. The channel number appears in the list view of the Data 
Portal.

Select Settings»Layout parameters to enable the name-oriented mode or 
the number-oriented mode. If you specify the channels to be displayed in the 
name-oriented mode, and enable the Expansion mode, DIAdem displays all 
curves with the same channel name when you enter the curve definition, not 
only the first channel pair with the name. Select Settings»Layout 
parameters»Curve expansion to assign each curve its own set of display 
attributes. To enable DIAdem to find the channel names independently of 
the channel groups, select Settings»Desktop parameters»General and 
select Only channel name for the syntax.

After you define the channel assignment for an axis system or a table, 
DIAdem displays the assignment as follows:

1. DIAdem searches for a channel with the specified channel name. The 
search starts at the first channel.

2. If DIAdem finds an x-channel, the search for a related y-channel and, if 
required, y1-channel begins. 

3. In expanded mode, DIAdem continues with point 1. DIAdem keeps 
searching for other pairs until it reaches the end of the data. 

Example The following channels are in the Data Portal:
1     Time
2     Speed
3     Distance
4     Torque
5     Time
6     Speed
7     Time
8     Speed
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The 2D axis definition contains the following entries:

The non-expanding mode displays the following channel pairs:
X-channel       Y-channel
1 (Time)      2 (Speed)
3 (Distance)  4 (Torque)

The expanding mode displays the following channel pairs:
X-channel       Y-channel
1 (Time)      2 (Speed)
5 (Time)      6 (Speed)
7 (Time)      8 (Speed)
3 (Distance)  4 (Torque)

Row X-channel Y-channel

1 Time Speed

2 Distance Torque
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Exercise 5-4
Objective:  Displaying Time Data Graphically

For a representative display of data measured over a period of weeks, the 
measured values must be assigned to a time reference in the report.

In the following exercise you load the House_1.tdm data file and layout. 
You use the time format for the numeric display of the x-axis.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the House_1.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

4. Select DIAdem REPORT.

5. Click Load layout.

Navigate to the prepared House_1.tdr layout in the 
C:\Exercises\DIAdem Basics\ folder and open the layout.

6. Select the channels Date, Electricity, Water, and Gas in the Data 
Portal and drag and drop the channels into the top axis system.

7. Double-click the top axis system to open the dialog box for the curve 
definition.
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8. Assign the curves to the subaxis system as shown in the following 
figure: 

Click OK.

9. Double-click the numbers of the x-axis to open the dialog box for 
numeric display.

10. Check the time format for the x-axis: 

Click OK.
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The report looks like this:

End of Exercise 5-4 
The House_2.tdr layout, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 5-5
Objective: Data Overview in Tables

In the following exercise you insert a table in another worksheet in the report 
from the last exercise, to display selected data as numbers.

1. Select DIAdem REPORT.

2. Open the shortcut menu for the Sheet 1 tab and select Manage.

3. Click Rename and enter Graphic for the first worksheet. 

4. Click New entry and enter Table for the second worksheet. 

Click OK. DIAdem opens the second worksheet.

5. Open the 2D table function bar and select 2D-table with horizontal 
and vertical separators.

6. Drag open the table in the top left of the worksheet.

7. Select the channels Date, Electricity, and Water, in the Data Portal 
and drag and drop the channels into the table.
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8. Double-click the table to open table definition. Select Automatic 
minimum as the Table length.

9. Click Headers to specify the table labels:

The first line of the heading is @CN(CCN)@ for the channel name.

Enter @CD(CCN)@ for the physical unit in the second line. 

Click OK.

10. Click Columns to set the following format for the columns with the time 
entries: 
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11. Click OK in all the dialog boxes.

12. Drag the separator underneath the heading downwards to enlarge the 
table heading.

13. Click Save layout as. 

Navigate to the report file in the C:\Exercises\DIAdem Basics\ 
folder and save the report file as House_New.tdr.

The report looks like this:

End of Exercise 5-5 
The House_3.tdr layout, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 5-6
Objective: Using the Expansion Mode

In the following exercise you create a new report and use the expansion 
mode.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the Expand.tdm data file in the C:\Exercises\DIAdem 
Basics\ folder and drag and drop the file into the Data Portal.

4. Select Settings»Desktop parameters»General and set Only 
channel name as the Syntax.

Click OK.

5. Select DIAdem REPORT.

6. Delete the current layout without saving the layout.

7. Select Settings»Layout parameters and click Curve expansion. 

8. Select Expand curves and Use attribute list.

Click OK to close all the dialog boxes.

9. Open the 2D axis system function bar and select a Simple 2D axis 
system.

10. Drag open the axis system in the top left of the worksheet.
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11. Select the result channels TimeCopy and VibrationCopy in the first 
channel group and drag and drop the selected data channels into the axis 
system. 

DIAdem now displays all curve pairs called TimeCopy, 
VibrationCopy.

The report looks like this:
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End of Exercise 5-6 
The Expand.tdr layout, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
Select Settings»Desktop parameters»General and reset the default syntax 
[Group index]/Channel name. 
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F. Configuring DIAdem REPORT
The Desktop parameters are the program settings you can specify in 
DIAdem.

Setting Panel-Specific Parameters
In DIAdem REPORT, select Settings»Desktop parameters»Panel specific 
to access the panel-specific settings. The configuration dialog box has the 
following settings:

Library path Displays the current library folder with report 
layouts.

User path Displays the current user folder with report 
layouts. 

Default file Specifies the report layout that DIAdem displays 
when the REPORT panel opens.

Template Specifies the report layout that DIAdem 
REPORT loads when you select File»New.

Hardware text positioning
Specifies whether DIAdem or the printer routine 
calculates the text position for printing.

You can save all the program settings in a desktop file. The desktop file has 
the filename extension .ddd. To save your settings in a desktop file, first 
select Window»Close all. Then click Save desktop.

Setting Layout Parameters
To specify the global appearance of the report, select Settings»Layout 
parameters. In the dialog box, you specify the page format, the frame, 
autoscaling, the name-oriented mode, and the commands to be performed. 

You can specify the page format in relation to the paper format, or scaled. 
Relative page format adjusts to the selected paper format and the 
orientation. You specify the size of the report in relation to the selected paper 
format, later in the printer dialog box. You can print your report to take up 
whole pages, or less, regardless of the paper format.

Scaled display contains fixed dimensions for the height and width of your 
report. Specify the margins and distances for your objects in centimeters or 
in inches. DIAdem prints your report in the specified size, regardless of 
which paper format you select in the print dialog box.
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If you want a frame around your report, specify the color and line width.

Axis autoscaling can use the standard progression 1, 2, 5, 10, 20 and so on, 
or the sequence 2, 2.5, 5, 10 and so on. When DIAdem scales the axes 
according to standard progression, the range from 0 to 100 is scaled as 20, 
40, 60, 80 and 100, otherwise DIAdem scales the axis at 25, 50, 75 and 100.

If you use number-oriented channel reference, you use the channel 
number to assign channels in graphic objects, not the channel names.

Under Commands to be performed you enter the names of the VBS user 
commands that you have registered by selecting Settings»Desktop 
parameters»User commands, and that DIAdem performs when the report 
refreshes.

DIAdem saves the layout parameters with the layouts.

Color Palettes
Select Settings»Color palettes to specify the color palette properties, the 
number of colors and how the colors are assigned to the data value range. 
You also can modify the global line attributes of the display. 

Layout Information
Select Settings»Layout-Info to include a comment in your report. 
DIAdem saves the layout information with the layout.
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Summary, Tips, and Tricks

• You can use any combination of axis systems, tables, text, and graphics 
in a report. DIAdem displays the data in curves or bar diagrams in axis 
systems, and lists numeric data in tables. You can label your report with 
text and comments and illustrate your report with graphics and lines.

• You save and load layouts separately from the data. This allows you to 
reuse the layout for any data set. The layout contains all the data for 
arranging the graphics objects and the data channel assignments. Save 
the data set separately in DIAdem NAVIGATOR.

• When you open DIAdem REPORT, the worksheet contains the layout 
that you designate as the Default file in the dialog box that opens when 
you select Settings»Desktop parameters»Panel specific. If you want 
to always access a specific layout when you click New, specify this 
layout as the Template in this dialog box.

• Assign a button to graphics objects you use frequently in the respective 
function bar. Select Default setting in the shortcut menu.

• You also can include formulas and variables in text. DIAdem only 
recognizes formulas and variables set in @ characters.

• You can use the Graphics file function bar to load various formats, such 
as wmf, bmp, jpg, tif, and gif.

• You can export reports in all kinds of formats and use them in other 
applications.
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Notes
DIAdem Basics Course Manual 5-52 ni.com



Lesson 6
Analyzing Data with Mathematics Functions
Introduction
In this lesson you will learn how to use mathematical functions to evaluate 
the data in the Data Portal. 

With the standard mathematical functions you perform calculations without 
having to enter a formula. You select the input data and make the settings 
you want. 

Use the Calculator to define and calculate your own formulas.

You Will Learn About: 

A. Analyzing and Evaluating Data

B. Running Calculations

C. Calculating with Invalid Values
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A. Analyzing and Evaluating Data
With DIAdem ANALYSIS you analyze the data of the Data Portal 
mathematically to reveal correlations and to derive further information from 
the data. Figure 6-1 shows the DIAdem ANALYSIS interface.

Figure 6-1.  DIAdem ANALYSIS with the List of Calculations.

DIAdem ANALYSIS contains extensive libraries of mathematical standard 
functions that are located in various function bars. The functions include 
basic mathematics such as differentiation, signal analysis such as FFT, and 
3D analysis such as isoline calculations.

Note Which functions you can use depends on which options you have in your DIAdem 
license. The buttons for the functions that are not included in your license are dimmed in 
the function bar and the group bar.

To use a standard function, click the function button in the group bar and 
select the feature you want in the function bar that opens. A dialog box 
appears where you set the parameters for your calculation.

The DIAdem ANALYSIS workspace shows you which calculations you 
have run with which data channels.

1 Toolbar with the Calculator
2 Group bar with standard mathematical functions
3 Protocols of the calculations

4 Data Portal with the original data and 
the results
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DIAdem stores the calculation results in new data channels in the default 
group or overwrites the input channels with the result data. You specify the 
default group in the shortcut menu of the Data Portal structure view.

The toolbar has a button that opens the Calculator. You can use the 
Calculator to create and calculate channels. You also can use the Calculator 
to calculate and display single values and to assign variables.
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B. Running Calculations
DIAdem ANALYSIS has a wide range of mathematical functions. They 
include the standard functions that you call, parameterize, and execute, as 
well as the Calculator, which you use to link channels or single values with 
various functions.

DIAdem uses the data in the Data Portal for analyses, and returns the results 
to the Data Portal.

Example: Differentiation
To execute a standard function DIAdem needs additional information: the 
channels that DIAdem uses for the mathematical operations. Differentiation 
is one of the standard functions.

Differentiate speed over time to determine the acceleration.

Click Basic mathematics functions in the group bar.

The respective function bar has basic functions such as averaging, 
integration, differentiation, and peak search.

Click the Differentiation button in the function bar. Figure 6-2 shows the 
dialog box for differentiation, where you specify the channels you want to 
differentiate. 

Figure 6-2.  Dialog Box for the Standard Function Differentiation

Select the channels Time and Speed and click Execute to calculate the 
differentiation.

The workspace in DIAdem ANALYSIS contains information about the 
completed calculations. It shows you whether the calculation was completed 
successfully, which input channels were used, and which channels contain 
the results.

DIAdem saves the calculation result in the default group of the Data Portal. 
In the default group DIAdem creates two result channels for the 
differentiation. The x-values of the differentiated curve, which is the time 
axis, are in the first channel. These values result from the mean value of two 
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neighboring x-values from the input time channel. The second result 
channel contains the associated y-values, which are the calculated 
difference quotients. The values in this channel represent the physical 
acceleration.

Some mathematical calculations save their results in channels in the Data 
Portal and also assign the results to appropriate DIAdem variables. These 
functions include the calculation of the statistical characteristic values, 
approximation, and regression. In the dialog boxes for these three functions, 
you can specify that DIAdem also copies the result values to the Windows 
clipboard. You can then include the results in your report as text.

Example: Smoothing Curves
In the differentiation example above, the only parameters required were the 
input channels to be analyzed. Other functions require additional input 
parameters. One example is graph smoothing by calculating a floating mean 
value.

The following example shows the smoothing of the calculated channel 
Y_Diff. Smoothing can be useful to emphasize significant structures in a 
graph or to suppress distortion.

Click the Curve fitting functions button in the group bar.

The function bar has various curve fitting functions: splines, approximation, 
smoothing, and others.

Click the Smoothing button in the function bar. Figure 6-3 shows the 
smoothing dialog box where you specify the previously calculated 
acceleration Y_Diff as the channel to be smoothed.

You must specify the channel to be calculated and the smoothing width. The 
smoothing width specifies the number of neighboring data points to the left 
and to the right of the curve point currently to be calculated. DIAdem uses 
the data points to calculate the mean values.

Figure 6-3.  Dialog Box for the Standard Function Smoothing
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To specify the smoothing width enter the number in the field or use the 
increment arrows to count up or down stepwise. Click Execute to start the 
calculation.

Enter all the necessary information for a standard mathematical function in 
the dialog box. As in the other panels, less important settings that you do not 
have to reset very often are included in subdialog boxes. Click the respective 
buttons in the main dialog box to access the subdialog boxes. If you do not 
open a subdialog box or do not make changes, the standard function uses the 
default parameters.

Mathematical functions work with one or more channels. If a function, for 
example averaging, works with several channels, there are three points next 
to the channel selection field. Select all the channels you want in the Data 
Portal and drag and drop the channels into the channel selection field.

Figure 6-4 shows the workspace with the record of the calculations that have 
been run.

Figure 6-4.  Workspace with the Calculation Protocol

Using Free Formulas
The dialog boxes for the standard mathematical functions guide you through 
the calculations so you do not have to enter a formula. Enter and calculate 
your own formulas in the DIAdem Calculator. In such formulas you can 
combine and calculate channels and generate new channels. You can 
calculate single values, save values in variables, and request variable 
contents.
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The following example uses the Calculator to convert the velocity from m/s 
to km/h.

Click the Calculator in the toolbar.

Use the keyboard or the Calculator keys to enter your formula in the input 
box. DIAdem displays the status or the calculated result in the result bar.

A formula consists of the assignment target, the assignment operator, and 
the calculation instruction:

Assignment target := Calculation instruction

Enter the following line to convert the velocity from m/s to km/s:

Ch('KmSpeed'):= 'Speed'/1000

Note When you define a formula, use a point as the decimal character and set character 
strings in quotation marks.

Click Calculate to evaluate the formula. 

Note If the result of a calculation is non-defined, such as division by zero, DIAdem 
assigns NoValue as the result.

Enter the following line to convert the velocity from km/s to km/h:

Ch('KmSpeed'):= 'KmSpeed'*3600

Assign the respective unit to the calculated channel KmSpeed. To change the 
variable contents with the Calculator, enter:

CD('KmSpeed'):= 'km/h'

Using formulas is an easy way to generate any type of value.

Refer to Lesson 8, The DIAdem Calculator for more information about the 
Calculator, which you also can use in the DIAdem ANALYSIS and DIAdem 
SCRIPT panels.
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Exercise 6-1
Objective: Using Basic Mathematics Functions

In the following exercise you differentiate the House_1.tdm data file, 
which contains consumption values for a household, acquired over a long 
period of time. You display the differentiation results in the bottom axis 
system of the House_1.tdr report, which you started in the last lesson.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the House_1.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

4. Select DIAdem ANALYSIS.

5. Open the Basic mathematics functions function bar and select 
Differentiation.

6. Select Date as the x-channel and Gas as the y-channel.

Click Execute.

7. Click the first result channel X_Diff in the Data Portal. Enter 
Time_Diff as the name in the properties and select Time as the 
display format.
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8. Click the second result channel Y_Diff in the Data Portal. Enter 
Gas_Consumption as the name. 

9. Click the Calculator in the toolbar.

10. Enter the following formula in the entry field:
Ch('Gas_Consumption') := 
Ch('Gas_Consumption') * 60 * 60 * 24

The result of the differentiation is in the unit seconds. The specified 
formula calculates the values in days (60 sec. * 60 min. * 24 h.).

Calculate the daily gas consumption.

Close the Calculator.

11. Select DIAdem REPORT.
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12. Click Load layout.

Open the C:\Exercises\DIAdem Basics\ folder and load the 
prepared layout House_3.tdr.

13. Open the Graphic worksheet.

14. Select the result channels Time_Diff and Gas_Consumption in the 
Data Portal and drag and drop the data channels into the bottom axis 
system.

15. Double-click the x-axis numbers to open the dialog box for numeric 
display and check the format as shown in the following figure:

Click OK.
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The report looks like this:

End of Exercise 6-1 
The House_4.tdr layout and the House_2.tdm data file, which contain 
the solution for this exercise, are in the C:\Solutions\DIAdem Basics\ 
folder.
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Exercise 6-2
Objective: Using Complex Mathematical Functions

In the following exercise you use the Peak search function to determine the 
maximum gas consumption, and highlight the maximum values as labeled 
asterisks in the bottom axis system of the report.

1. Select DIAdem ANALYSIS.

2. Open the Basic mathematic functions function bar and select Peak 
search.

3. Set the dialog box parameters as shown in the following figure:

Click Execute.

4. Select DIAdem REPORT.

5. Select the result channels X_Peak and Y_Peak in the Data Portal and 
drag and drop the data channels into the bottom axis system.

6. Double-click the bottom axis system to open the dialog box for curve 
and axis definition.

7. Select the Line and symbol display mode for the X_Peak/Y_Peak 
curve.

8. Open the Curve param subdialog box. Select blank as the line style 
and * as the symbol style. 

9. Click OK to return to the curve and axis definition dialog box.

10. Click Copy to define a second entry with the result channels X_Peak 
and Y_Peak:
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11. Click Curve param. 

Delete the asterisk and select numeric labeling for the y-value.

12. Click Symbol and specify the relative position as top and the format as 
d.dd.

Click OK to close all the dialog boxes.

13. Double-click the y-axis to open the axis scaling, and specify manual 
scaling as shown in the following figure:

Click OK.
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14. Click Save layout as. 

Navigate to the report file in the C:\Exercises\DIAdem Basics\ 
folder and save the report file as House_New.tdr.

15. Select DIAdem NAVIGATOR.

16. Select the House_1 channel group in the Data Portal and drag and drop 
the selected channel group to the tree view of the MyTraining data 
storage. Enter the filename House_New.tdm and click Save.

The report looks like this:

End of Exercise 6-2 
The House_5.tdr layout and the House_3.tdm data file, which contain 
the solution for this exercise, are in the C:\Solutions\DIAdem Basics\ 
folder.
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Exercise 6-3
Objective: Mathematical Analysis - Statistical Characteristic Values

Cooling aggregates were tested in a large-scale experiment. The results are 
evaluated with the functions for classification and for statistics calculation, 
to draw conclusions on the durability of the devices.

In the next exercise you load the Cold.tdm data set. Carry out a durability 
Classification and calculate the minimum value, the maximum value, the 
average durability, and the 0.75 quantile (upper quartile). Display the results 
in the Cold.tdr layout.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal.

3. Navigate to the Cold.tdm data file in the C:\Exercises\DIAdem 
Basics\ folder and drag and drop the file into the Data Portal.

4. Select DIAdem REPORT.

5. Click Load layout.

Navigate to the Cold.tdr layout in the C:\Exercises\DIAdem 
Basics\ folder and open the prepared layout.

6. Select the data channels LifeSpan and CoolingAggregate in the 
Data Portal and drag and drop the channels into the axis system. 

7. Double-click the axis system to open the dialog box for the axis 
definition and select the Horizontal bars display mode. 
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Click OK.

8. Select DIAdem ANALYSIS.

9. Open the Statistics functions function bar and select Single 
classification.

Set the dialog box parameters as shown in the following figure:

Click Classes to set the parameters for class determination:
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Click OK.

10. Click Execute to start the calculation.

11. Select DIAdem REPORT.

12. Open the 2D axis system function bar and select a Simple 2D axis 
system to display the classification results in another axis system.

13. Drag open the 2D axis system starting from the top left corner of the 
workspace.

14. Select the data channel Class mean and then the data channel Sample 
count in the Data Portal and drag and drop the channels into the axis 
system on the right. 

15. Double-click the axis system on the right to open the dialog box for the 
axis definition and select the Bars display mode.

Click OK.

16. Select DIAdem ANALYSIS.

17. Open the Statistics functions function bar and select Statistical 
characteristic values.

18. Select the LifeSpan channel for evaluation.

19. Click All off to reset the dialog box parameters.

20. Select the checkboxes for the Minimum, the Maximum, the 
Arithmetic mean and the 0.75 quantile:
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21. Click Results and specify the mode for transferring the results into the 
clipboard as shown in the following figure:

Click OK.

22. Click Execute.

23. Select DIAdem REPORT.

24. Press <Ctrl-V> to insert the statistical results from the clipboard into the 
report.

The statistics results appear as text in the top left of the graphics area.

25. Position the selected texts in front of the axis system on the left.

26. Open the Decorations function bar and select Rectangles.

Draw a frame around the texts that contain the statistical characteristic 
values.
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27. Double-click the frame to open the dialog box for rectangles. Select 
white as the Background color:

Click OK.

28. Select One layer down four times in the shortcut menu of the selected 
rectangle, so the rectangle is behind the four texts but in front of the axis 
system. 

The report looks like this:

End of Exercise 6-3 
The Cold_1.tdr layout and the Cold_1.tdm data file, which contain the 
solution for this exercise, are in the C:\Solutions\DIAdem Basics\ 
folder.
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Exercise 6-4
Objective: Mathematical and Graphical Interactive Analysis

Only use parts of the existing data for mathematical calculations.

In the following exercise you view the View.tdm data set in DIAdem 
VIEW, select a particular value range, and use the Smoothing function to 
mathematically evaluate this range. You display the result in DIAdem 
VIEW.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the View.tdm data file in the C:\Exercises\DIAdem 
Basics\ folder and drag and drop the file into the Data Portal.

4. Select DIAdem VIEW.

5. Delete the current view without saving the layout.

6. Open the Screen partitioning in three areas function bar and select the 
first Three areas button.

7. Select the channels Time and Vertical_Ampl in the Data Portal and 
drag and drop the channels into the top area.

Select the 2D axis system display type.

8. Repeat step 7 for the bottom left area.

9. Enable the Band cursor.

10. Change the width (dx) of the band cursor in the top axis system.

11. Click Zoom, static in the axis system toolbar of the bottom left axis 
system.

DIAdem zooms the range inside the band cursor.

12. Click Set flags in the axis toolbar to mark all the values in the selected 
range.

13. Click Flags: Copy data points in the axis toolbar to copy the data of the 
selected curve range into separate data channels.

14. Click Global flag reset in the toolbar.
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15. Select DIAdem ANALYSIS.

16. Open the Curve fitting functions function bar and select Smoothing.

17. Set the dialog box parameters as shown in the following figure:

Click Execute.

18. Select DIAdem VIEW.

19. Select the channels XCopy_Time and Y_smooth in the Data Portal and 
drag and drop the channels into the bottom right area.

Select the 2D axis system display type.

20. Open the legend in the bottom right axis system. Idle the cursor over the 
window divider on the right of the axis system. The cursor changes. 
Click and drag the edge of the window to the left to enlarge the legend 
and to display the additional information. You minimize the area in the 
same way.

21. Double-click the legend to open the properties selection. 

22. Change the settings as shown in the following figure: 

• Select all the lines of the Properties to be displayed except <name> 
and click < to delete the lines.

• Select <freetext> in the Properties not for display and click >. 
Then enter Y_Max under Title and 
@str(CMax(Y_smooth),'d.dd')@ under Format/expression.

• Select <freetext> again in the Properties not for display and 
click >. Then enter Time under Title and 
@str(ChD(PNo(Y_smooth,CMax(Y_smooth)), 
XCopy_Time),'d.dd')@ under Format/expression.
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Click OK.

23. Adjust the size of the legend.

The workspace looks like this:

End of Exercise 6-4 
The View.tdv layout and the View_1.tdm data file, which contain the 
solution for this exercise, are in the C:\Solutions\DIAdem Basics\ 
folder.
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Additional Exercise
If you have time, complete the following exercise.

1. Smooth the Vertical_Ampl signal in DIAdem ANALYSIS.

2. Display the result Y_smooth over Time in the top axis system of the 
current view in DIAdem VIEW.

3. Smooth the signal again with different smoothing widths.

4. Compare all the results with the original signal in DIAdem VIEW.
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Exercise 6-5
Objective: Mathematical Analysis - Splines

You can use splines to approximate measurement data.

In the following exercise you load the SplineA.tdm data file, select a 
suitable spline procedure to approximate the data, and display the results 
with the SplineA.tdr layout.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the SplineA.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

4. Select DIAdem ANALYSIS.

5. Open the Curve fitting functions function bar and select Non-
parametrical splines.

6. Set the dialog box parameters as shown in the following figure: 

Click Execute.

7. Open the Curve fitting functions function bar and select Parametrical 
splines.
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8. Set the parameters in the dialog box for calculating parametrical, 
periodic splines as shown in the following figure:

Click Execute.

9. Open the Curve fitting functions function bar and select Parametrical 
splines.

10. Set the parameters in the dialog box for calculating parametrical, 
approximating splines as shown in the following figure:

Click Execute.

11. Open the Curve fitting functions function bar and select Akima 
subsplines.
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12. Set the parameters in the dialog box for calculating the Akima 
subsplines as shown in the following figure:

Click Execute.

13. Select DIAdem REPORT.

14. Click Load layout without saving the layout.

Navigate to the SplineA.tdr layout in the C:\Exercises\DIAdem 
Basics\ folder and open the layout to display the original data.

15. Display the calculation results as curves in the prepared axis systems.

• Top left: Param_Spline_Y1 over Param_Spline_X1

• Top right: Param_Spline_Y over Param_Spline_X

• Bottom left: Akima_Y over Akima_X

• Bottom right: Spline_Y over Spline_X
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The report looks like this:

End of Exercise 6-5 
The SplineB.tdr layout and the SplineB.tdm data file, which contain 
the solution for this exercise, are in the C:\Solutions\DIAdem Basics\ 
folder.
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Exercise 6-6
Objective: Mathematical Analysis - Fast Fourier Transformation (FFT)

Use Fast Fourier Transformation to determine the frequency characteristics 
and their amplitudes, the phase position, and the frequency response locus 
for measured data.

In the following exercise you run a FFT calculation on the FFTA.tdm data 
set and display the results in the FFTA.tdr REPORT layout. 

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the FFTA.tdm data file in the C:\Exercises\DIAdem 
Basics\ folder and drag and drop the file into the Data Portal.

4. Select DIAdem ANALYSIS.

5. Open the Signal analysis functions function bar and select FFT (one 
time signal).

6. Set the channels to be evaluated as shown in the following figure:

7. Click FFT functions to check the functions to be calculated, as shown 
in the following figure:

Click OK.
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8. Click Time intervals to check the time intervals as shown in the 
following figure:

Click OK.

9. Click Window function to check the window function as shown in the 
following figure:

Click OK.

10. Click Execute to calculate the FFT.

11. Select DIAdem REPORT.

12. Click Load layout without saving the current layout.

Navigate to the prepared layout FFTA.tdr in the 
C:\Exercises\DIAdem Basics\ folder and open the layout.

13. Display the original Noise over Time data in the top axis system.

14. Display the results Ampl_Peak over Frequency in the bottom axis 
system.
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The report looks like this:

End of Exercise 6-6 
The FFTB.tdr layout and the FFTB.tdm data file, which contain the 
solution for this exercise, are in the C:\Solutions\DIAdem Basics\ 
folder.
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Exercise 6-7
Objective: Mathematical Analysis - Digital Filters

You can use digital filters to eliminate disturbing frequency characteristics. 
In this example the disturbance is at 500 Hz.

In the following exercise you filter a noise signal with the IIR method, filter 
type Butterworth, 5th order, and a lowpass of 500 Hz. You calculate a FFT 
for the filtered signal and add the results to the report from the previous 
exercise.

1. Select DIAdem ANALYSIS.

2. Open the Signal analysis functions function bar and select Digital 
filters.

3. Set the dialog box parameters as shown in the following figure:

4. Click IIR param to select the filtering method as shown in the 
following figure:

Click OK.
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5. Click Execute to calculate the digital filter.

6. Open the Signal analysis functions function bar and select FFT (one 
time signal).

7. Set the channels to be evaluated as shown in the following figure:

8. Click FFT functions to check the functions to be calculated as shown 
in the following figure:

Click OK.

9. Click Time intervals to check the time intervals as shown in the 
following figure:

Click OK.
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10. Click Window function to check the window function as shown in the 
following figure:

Click OK.

11. Click Execute to calculate the FFT.

12. Select DIAdem REPORT.

13. Select the result channels Ampl_Peak1 over Frequency1 in the Data 
Portal and drag and drop the channels into the bottom axis system.

14. Double-click the x-axis in the bottom axis system to open the dialog box 
for 2D scaling.

15. Set Manual as the Scaling mode for the x-axis. Enter 2000 as the End 
and 500 as the Tick distance as shown in the following figure:

Click OK.
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The report looks like this:

End of Exercise 6-7 
The DigFilter.tdr layout and the DigFilter.tdm data file, which 
contain the solution for this exercise, are in the C:\Solutions\DIAdem 
Basics\ folder.
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Additional Exercise
If you have time, complete the following exercise.

1. Use different filter settings on the same data channels. 

2. View the individual results in DIAdem VIEW.

The following graphic shows the original signal and the results of a 
selection of applied digital filters. Note the differences in amplitude and 
phase between the filtering methods.
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Exercise 6-8
Objective: Mathematical Analysis - Linear Mapping

Linear mapping allows you to map data that is recorded with varying 
sampling rates in a common x-value range.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the 10HertzData.tdm and 25HertzData.tdm data files 
in the C:\Exercises\DIAdem Basics\ folder and drag and drop the 
files into the Data Portal.

4. Select DIAdem ANALYSIS.

5. Open the Curve fitting functions function bar and select Linear 
mapping.

6. Check the dialog box parameters as shown in the following figure:

Click Execute.

7. Select DIAdem VIEW.

8. Click New layout in the toolbar without saving the current view.

9. Open the Regular screen partitioning function bar and select One 
area.

10. In the Data Portal, select the data channels Time, Temp and Lin_image 
in the 25HertzData01 channel group and the Temp channel in the 
10HertzData01 channel group.

11. Drag and drop the selected channels into the area. Select the 2D axis 
system display type.
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The view looks like this:

End of Exercise 6-8 
The LinMapping.tdv layout and the LinMapping.tdm data file, which 
contain the solution for this exercise, are in the C:\Solutions\DIAdem 
Basics\ folder.
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C. Calculating with Invalid Values
In DIAdem, NoValue identifies an invalid value. NoValue is the greatest 
number that can be processed in DIAdem. You can select Settings»Desktop 
parameters»General to change the NoValue in the general DIAdem 
configuration.

DIAdem does not display NoValues in reports or include NoValues in 
function calculations. This means that if you replace values with NoValue, 
you can omit single data or data ranges from calculations and in the graphic 
display, as shown in Figure 6-5. For example, if you want to carry out a 
statistical analysis for a channel without invalid values distorting the result, 
replace the values with NoValue in the DIAdem VIEW channel table 
before the analysis.

Figure 6-5.  On the Left, Signal with Disturbance Adjusted with NoValues and
on the Right, Classification Results.

NoValue Handling
You can use the mathematical functions for handling NoValues to delete 
NoValues from single channels or from associated channel groups, or you 
can replace the NoValues by linear interpolation of the neighboring values.
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Rules for Calculating with NoValues
If one of the terms in the calculation formula is a NoValue, the result of a 
calculation is NoValue. The result is NoValue if there are no channel values 
or if the specified value range is exceeded.

The above does not apply for multiplication or division by NoValue. The 
following rules apply: 

• The result is NoValue if the other operand is not equal to zero.
10 * NoValue = NoValue
10 / NoValue = NoValue

• The result is zero if the other operand is equal to zero:
0 * NoValue = 0
0 / NoValue = 0

For example, to eliminate values greater than 10 in the Example data 
channel, enter the following formula in the Calculator input field: 

Ch('Example'):= 'Example' + ('Example'>10)* NoValue

The Boolean request ('Example'>10) returns 0 or 1. Multiplication by 
NoValues produces either 0 or NoValues. The result of addition with a data 
channel is either the original channel value or NoValue. This formula has 
replaced all values greater than 10 with NoValues.
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Summary, Tips, and Tricks

• DIAdem ANALYSIS contains extensive libraries of standard 
mathematical functions that are located in various function bars. To use 
a standard function, click the function button in the group bar and select 
the feature you want in the function bar that opens. A dialog box appears 
where you set the parameters for your calculation.

• DIAdem stores the calculation results in new data channels in the default 
group or overwrites the input channels with the result data. You specify 
the default group in the shortcut menu of the Data Portal structure view.

• You can predefine the parameters of the functions that are on the 
function bar - except for the channel data.
Select Default setting in the shortcut menu and change the settings. 
DIAdem saves the new default settings and these settings are available 
for reuse in DIAdem.

• NoValues

– are values that are defined invalid.

– are represented by the highest value that can be displayed.

– can be defined as any value.

– are not displayed in the report or included in the calculation.

• If one of the terms in the calculation formula is a NoValue, the result of 
a calculation is NoValue. 

The exceptions are:

– 0 * NoValue = 0

– 0 / NoValue = 0
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Notes
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Lesson 7
Automating Tasks
Introduction
In this lesson you will learn how to automate recurring sequences and 
standard evaluations as scripts.

You create scripts by running them once, and then edit the scripts in the 
DIAdem SCRIPT editor. 

You Will Learn About: 

A. Automating Processes

B. DIAdem SCRIPT Toolbar

C. Script Structure and Syntax

D. Creating a Script

E. Tools that Help You to Create Scripts

F. Editing Scripts

G. Configuring DIAdem SCRIPT
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A. Automating Processes
You use scripts to automate recurring operations and standard evaluations in 
DIAdem. Each action and function in DIAdem has a command. A script 
consists of a series of commands that DIAdem executes consecutively.

To create a script, you record the actions you perform in the recording mode. 
The recording mode records the commands associated to the actions, in the 
script editor. If you disable the recording mode, you can edit, expand, save, 
and test the commands.

You can use scripts to perform complex tasks from data loading, to 
evaluation and display, at the press of a button. You can customize DIAdem 
to fit user requirements.

The DIAdem SCRIPT workspace is divided into the file overview, the 
editor, and the information area for the debug mode.

Figure 7-1.  A Script in DIAdem SCRIPT

Initially, only the script editor and information area are visible. The file 
overview appears after you resize the editor window. Idle the cursor over the 
left edge of the window and click and drag the edge to resize the window. 
Use the bottom edge of the script editor to resize the information area.

1 Toolbar with recording mode and editing functions
2 Group bar with dialog box definitions
3 File overview with loaded files of a project

4 Script editor with script
5 Information area
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 The File Overview
The file overview is the organizational part of the DIAdem SCRIPT 
workspace. The tree structure provides an overview of the files you are 
working on. Here you define and delete folders, specify the folder 
properties, and load, open, and save files.

If you click a file in the file overview, DIAdem SCRIPT moves this file to 
the foreground of the script editor.

To save the current file overview settings in a file with the filename 
extension .wsp (workspace), select Save workspace in the shortcut menu. 
To load a file overview you saved previously, select Open workspace in the 
shortcut menu.

Script Editor
You can view and alter scripts in the script editor. You can edit scripts to 
include control structures that change the linear sequence of commands, for 
example. You also can integrate request dialog boxes, or enable the user to 
interact with the script while the script is running.

Select the script in the file overview. Syntax coloring helps you to 
distinguish between comments, commands, and variables. You can set the 
syntax coloring in the shortcut menu of the file overview. The editor 
provides features like syntax line numbering, bookmarks, and find and 
replace. The status bar of the script editor displays the current cursor 
position, the insert or overwrite mode, changes to the script, and any 
read/write protection.

ToolTips show the correct syntax and the context help provides explanations 
on each command.

The Debugger and the Information Area
You can use the debugger integrated in the editor to check scripts for errors. 
The information area contains a corresponding error report in the log file. 
You also can display the current contents of specific variables and acquire 
intermediate results at any time.

Note The debugger is not installed with DIAdem  so initially the debugger symbols are 
dimmed in the toolbar. Refer to the Student Guide, B. What You Need to Get Started for 
instructions on installing the Script Debugger from the Microsoft homepage.
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B. DIAdem SCRIPT Toolbar
The toolbar in DIAdem SCRIPT has functions for loading, saving and 
printing scripts, and the following functions:

New file
Use this function to create a new script (*.vbs, *.aut), a file to define user 
variables (*.vas), or an empty file. The new file appears automatically for 
editing in the script editor.

End interaction
Use the InteractionOn function to pause a script at any point and switch 
to a mode that enables you to operate DIAdem, without ending the script. 
End interaction continues the script.

Run script
Use this function to start script files (.vbs, .aut, .auc). DIAdem executes 
VBS scripts directly.

Enable recording mode
Use this function to enable the recording mode in which DIAdem 
automatically records all the relevant commands. DIAdem automatically 
gives this script file a comment header.

Disable recording mode
Use this function to end the recording mode. The recorded script then 
appears in the script editor.

Create user dialog box
Use this function to open the dialog editor where you can create your own 
dialog boxes. You use a dialog box to assign entries to specific variables 
while the script is running.

Activate user variables file
This function loads variable definition files (.vas) to enable the defined 
variables, which are then available to DIAdem. When you enable variables, 
DIAdem adds these variables to the existing collection of variables, which 
means DIAdem reserves the required amount of memory and initializes the 
variables. 

Note Variable definition is exclusive. If you load a second variable definition file, 
DIAdem deletes the user variables defined previously.
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C. Script Structure and Syntax
A script consists of comments, commands, variable assignments, formula 
calculations, control structures, procedures, and blank lines.

Comments
You can include comments anywhere in scripts. Indicate comments either 
with rem, or with single quotation marks '. Comments do not slow down 
scripts. 

Commands
Commands carry out internal functions. Most of these functions require 
settings, which are transferred to a parameter list. You call commands with 
Call:

Call Command(parameterlist)

You can transfer channel and variable parameters in the parameter list.

The command name indicates the object the command relates to, and the 
action the command executes. For example, ChnSmooth smooths a 
channel: Chn stands for the channel, and Smooth for the smoothing 
function. DataLoad is the command for loading data. 

Variable Assignments
Variable assignments assign a numeric value or a string to a program 
variable or to a user variable. The assignments are made with equal signs:

Variable = Formula expression

This formula expression links operands by operations. 

Declare all of the variables used in the script early in the script, and assign 
default values to the variables, to define the status of the variables. This 
prevents unexpected script behavior.

Formula Calculations
Use the FormulaCalc command to call the DIAdem Calculator and run 
formula calculations, which calculate entire data channels in scripts, not just 
single values. Formula expressions must be in quotation marks.

Call FormulaCalc("Formula expression")
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Control Structures
Control structures such as loops and branches involve conditions and 
change the linear progress of the script. Use loops to repeat instructions until 
a specific condition is true. Use branches for the script to perform different 
instructions in response to a condition.

Procedures
You can include repeated instructions, or a group of related instructions, in 
separate procedures. Procedures start and end with the keywords Sub and 
End Sub. To run a procedure, Call the procedure name.

Blank Lines
DIAdem ignores blank lines in scripts. Blank lines make scripts easier to 
read.
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D. Creating a Script
The easiest way to create a script is to enable the recording mode. You also 
can create scripts manually. This requires considerable knowledge of 
DIAdem commands and variables. You can edit or start scripts at any time.

Recording a Script
To create a script in the recording mode, complete the following four steps:

1. Enable the recording mode.

In the dialog box that appears, select your recording settings and enter 
comments for the script.

2. Carry out the functions and operations you want to automate in the 
script.

DIAdem registers the relevant actions and stores the associated 
commands in the script.
The status bar shows that DIAdem is recording.

3. Disable the recording mode.

4. Save the script.

The specified command sequence is only temporary in the editor. You 
must save the created script to be able to reuse the script later.

Channel References in Scripts
Enable the recording mode in DIAdem SCRIPT to define how scripts record 
channel references. You can use channel names or channel numbers to 
access channels.

If you use channel names, DIAdem records the channel names when it 
records the script, otherwise DIAdem records the channel numbers.

Call ChnSmooth("[1]/Speed","/Y_smooth",17,"maxNumber")

or

Call ChnSmooth(2,5,17,"maxNumber")

File References in Scripts
Enable the recording mode in DIAdem SCRIPT to specify how DIAdem 
records file references in scripts. If you select the Record absolute path 
checkbox, DIAdem stores a complete path for each filename you use. This 
ensures that the script always works with the files you want, irrespective of 
which current folders are set as user paths.
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Starting a Script
Start a script in one of the following ways:

• Click Execute script file in the toolbar to start a script without loading 
the script in the script editor. The dialog box that appears displays the 
scripts available in the current script path. You can modify the user path 
here.

• Click Run script in the toolbar to start a script that is displayed in the 
script editor.

Once you start the script, the script runs automatically.

You can assign a frequently-used script to a button in the DIAdem SCRIPT 
function bar. The bottom function bar is available in all the DIAdem panels, 
so you can use the scripts you assign here in all panels.
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E. Tools that Help You to Create Scripts
You can use the recording mode, the keys <Ctrl-A>, and the DIAdem help 
to create scripts.

The Recording Mode
In the recording mode, DIAdem records all commands and some variables. 
This mode facilitates creating scripts. The initial script is the basis for your 
script.

The recording mode records the following functions in the separate panels:

• DIAdem NAVIGATOR

– Loading, saving, and importing data

– Operations in the Data Portal

• DIAdem VIEW

– Block operations such as deleting or inserting, in the channel 
contents

– Setting and deleting flags

• DIAdem ANALYSIS

– All calculations 
In rare cases, the recording mode also records variable assignments.

• DIAdem REPORT

– Functions such as opening, saving, displaying, and printing layouts.
The recording mode does not register interactive actions like 
inserting, moving, or configuring graph objects.

The Key Combination <Ctrl-A>
When you generate a script in the recording mode, DIAdem does not 
generally record variable assignments. If you change axis, curve, or text 
parameters in the recording mode, you see the changes in the window, but 
the related variable assignments are not stored in the script.

To record dialog box parameters and variables in the recording mode, press 
<Ctrl-A> in the open dialog box.

If the recording mode is not enabled, press <Ctrl-A> in an open dialog box 
and DIAdem copies the variables and their contents to the clipboard. You 
can insert these variable assignments in the script editor.
© National Instruments Ireland Resources Limited 7-9 DIAdem Basics Course Manual



Lesson 7 Automating Tasks
The DIAdem Help
The DIAdem help shows you where to find variable names and command 
names.

• In the script editor

If you select a DIAdem term in the script editor, press <F1> to access 
the help page for this variable or command.

When the cursor idles on a selected command or variable in the script 
editor, the ToolTip appears with information on the command 
parameters or on the type and value range of the variable.

• In dialog boxes

Every DIAdem dialog box has a help button that opens the DIAdem help 
page with the commands and variables for the dialog box. You can click 
terms underscored in green to access the variable for a dialog box 
parameter, or the syntax for including the variable in the script.

• Command and variable overview in the DIAdem help

In the help tree, the Functions, Commands, and Variables folder has 
various lists of DIAdem commands and variables.

• DIAdem SCRIPT help

In the help tree, select Getting Started»DIAdem SCRIPT for a general 
description of DIAdem SCRIPT, and select Procedures»Working with 
DIAdem SCRIPT for a step-by-step description of how to create and to 
edit scripts. 
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Exercise 7-1
Objective: Creating a Script

You must repeat specific sequences several times a day, but you do not want 
to repeat each step each time. A series of commands could be loading a data 
set, running a mathematical function with this data, and then creating a 
report.

In the following exercise you create a script that loads the Vibration.tdm 
data file, calculates the envelope curve, and displays the result in the 
Envelopes.tdr layout.

1. Select DIAdem SCRIPT.

2. Click Enable recording mode in the toolbar.

3. Comment the script as shown in the following figure:

If you select Number as Channel reference, the recording mode 
records the channel numbers and not the channel names when it accesses 
channels.

Click OK. 

The temporary file TeachIn(1).vbs appears in the editor. DIAdem 
displays the script recording in the status bar. 

4. Select DIAdem NAVIGATOR.

5. Delete the data in the Data Portal without saving the data.

6. Navigate to the Vibration.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.
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7. Select DIAdem REPORT.

8. Click Load layout without saving the current layout.

Navigate to the prepared layout Envelopes.tdr in the 
C:\Exercises\DIAdem Basics\ folder and load the layout. 

9. Select DIAdem ANALYSIS.

10. Open the Curve fitting functions function bar and select Envelope 
curves.

11. Set the parameters as shown in the following figure: 

Click Execute.

12. Select DIAdem REPORT.

13. Click Redraw in the toolbar to refresh the report.

14. Select DIAdem SCRIPT.

The actions carried out reflect the work sequence.

15. Click Disable recording mode in the toolbar.

In the script editor you see the commands recorded in the recording 
mode.

16. Click Save file as to save the script you recorded in the recording mode.

Open the C:\Exercises\DIAdem Basics\ folder and save the script 
as Training.vbs.

17. Click Run script to test the Training.vbs script in the editor.
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When the script finishes, the following report appears:

The Training.vbs script contains the following instructions:
Call DataDelAll(1)
Call DataFileLoad("Vibration.tdm","","")

Call PicLoad("Envelopes")
Call PicUpdate()

Call ChnEnvelopes(1,2,3,4,5,6,50)
Call PicUpdate()

To ensure clarity, the results are displayed but not the comments.

End of Exercise 7-1 
The Basic_07_01.vbs script, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 7-2
Objective: Including Scripts in the DIAdem User Interface

Use scripts to automate repetitive processes and to carry out these processes 
at the push of a button. Assign scripts to buttons to make it easier to start 
frequently-used scripts.

In the following exercise you assign the created script Training.vbs to 
the third button of the third function bar.

1. Select DIAdem SCRIPT.

2. Open the DIAdem scripts function bar and select Default setting in the 
shortcut menu of the third button.

3. Navigate to the Training.vbs script in the C:\Exercises\DIAdem 
Basics\ folder and select the script.

4. Click Open to assign the script to the third button.

5. Open the last function bar again and idle the cursor on the third button.

The name of the assigned script appears in the ToolTip.

6. Open the DIAdem scripts function bar and select VBS Script: 
Training to start the Training.vbs script.

To start scripts, click the function bar button or use keys. Press <Shift-
F3> to start the script assigned to the third button.

End of Exercise 7-2 
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Exercise 7-3
Objective: Extending a Script

In the following exercise you include the command for saving the 
calculation results in the script.

1. Select DIAdem SCRIPT.

2. Click Enable recording mode in the toolbar to record a command.

3. Click OK in the Configure recording mode dialog box.

4. Select DIAdem NAVIGATOR.

5. Click Save TDM file as.

Open the C:\Exercises\DIAdem Basics\ folder and save the 
current Data Portal data as Envelopes.tdm. If the filename already 
exists, overwrite the file with this name.

6. Select DIAdem SCRIPT.

7. Click Disable recording mode in the toolbar.

The TeachIn(2).vbs script appears in the script editor.

8. Click the line number of the recorded command.

9. Click Copy in the toolbar.

10. Click the tabs at the bottom of the script editor to switch to the 
Training.vbs script. 

11. Paste the copied command to the end of the script.

12. Click Save file as.

Open the C:\Exercises\DIAdem Basics\ folder and save the 
modified script as Training.vbs. You also can press <Ctrl-S> to save 
the script.

13. Click Run script in the toolbar to test the Training.vbs script.

TeachIn(2).vbs is a temporary script, so you do not have to save the 
contents of this file.
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The Training.vbs script contains the following instructions:
Call DataDelAll(1)
Call DataFileLoad("Vibration.tdm","","")

Call PicLoad("Envelopes")
Call PicUpdate()

Call ChnEnvelopes(1,2,3,4,5,6,50)

Call PicUpdate()

Call DataFileSave("Envelopes.tdm","TDM")

End of Exercise 7-3 
The Basic_07_02.vbs script, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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F. Editing Scripts
A script consists of a series of commands that DIAdem executes 
consecutively. The script files are ASCII files that you view and modify or 
extend with any ASCII editor.

You can edit scripts to include loops and branches, which control the 
sequence of commands. You also can edit scripts to enable the user to 
interact with the script while the script is running.

Script Commands and Variables
Tables 7-1 and 7-2 contain a selection of frequently-used script commands 
and variables. Refer to the ToolTips and the context help for more 
information on the commands.

Table 7-1.  Script Commands

Command Purpose

AutoQuit Stops a script

ChnAlloc Allocates and names channels

DirLstWrite Creates a list file

ExtProgram Calls an external program

FileX Checks whether an ASCII file exists

FileNameGet Standard dialog box for entering filenames

FormulaCalc Calculates any user-defined function

InteractionOn Interrupts a script

KeyWait Script waits for next keystroke

MsgBoxDisp Displays a user message in a message box

MsgLineDisp Displays a user message in the status bar

PathNameGet Opens the standard dialog box for path selection

Pause Stops a script

ScriptStart Calls a subscript / routine

SubSequence Scripts can only start as Include scripts

SudDefLoad Loads a dialog box description file

SudDlgShow Displays a user dialog box

TextFileClose Closes a text file
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Control Structures: Loops and Branching
DIAdem works through scripts consecutively and stops when it reaches the 
end of the script. DIAdem has control structures that execute commands 
multiple times until a condition is true.

Use control structures such as condition and loop instructions, to specify 
how DIAdem executes the script. Use conditions and loops to write code 
that allows you to make decisions, and that repeats actions.

TextFileEOF Checks the end of a text file

TextFileOpen Opens a text file

TextFileReadLn Reads a line from a text file

TextFileSeek Jumps to a row in a text file

TextFileWriteLn Writes a line in a text file

UserVarCompile Enables a user variable file

WndShow Opens and closes a DIAdem panel

Table 7-2.  Script Commands

Variable Meaning

ActDrive Driver path of the current file

AutoAbort Press <Esc> to abort the script

AutoEcho Displays the commands during a script

AutoIgnoreError Ignores script error messages

ChnCommentOver Operations overwrite channel comments

ChnNameOver Operations overwrite channel names

DlgState Status in which a dialog box was closed

MsgState Status in which a message box was closed

SoundActive Activates acoustic signal output

Table 7-1.  Script Commands

Command Purpose
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The following control structures are available: 

• Simple branching
if ... then ... 
if ... then ... end if 
if ... then ... else ... end if (and alternative)

• Multiple branching
select case ... end select 
select case ... else ... end select (and alternative) 

• Counter loops
for ... to ... next

• Condition-dependent loops 
do while ... loop  
do ... loop until 

Use clear, readable syntax in your scripts to minimize the probability of 
errors. Follow these guidelines for control structure syntax:

• Write only one command in each line.

• Indent commands inside branching and loops.

• Use consistent spelling and capitalization, for example, capitalize the 
keywords in the control structures.

Control Commands
Use control commands to interrupt, to end, or to repeat your script. The 
KeyWait command interrupts the script until the user presses any key. The 
Pause command stops the script for a specific time. The AutoQuit 
command terminates the script. The AutoRepeat command repeats all the 
instructions above the control command.

Messages and Requests
The MsgBoxDisp command is for displaying tips, warnings, or error 
messages in a message box. Extend the optional parameter to use this 
command for standard requests as well.

Syntax MsgBoxDisp(MsgText, [MsgButtonType])

MsgText Specifies any text.
Because the MsgText variable is limited to 80 
characters, you assign longer message text to a text 
variable and use the variable in the call.
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MsgButtonType Specifies the type of button in the message box. 
Possible settings:

The MsgState variable contains the button that was clicked to close the 
message: "IDOk", "IDCancel", "IDRetry", "IDYes", "IDNo", 
"IDAbort" and "IDIgnore".

Note The @CRLF@ inserts carriage-return and linefeed characters. The syntax 
@Variable@ inside a message text displays the contents of the DIAdem variable called 
Variable.

Creating a Serial Evaluation
You create a script for a serial evaluation to analyze and display several data 
files that have the same structure, in the same way.  To enable serial 
evaluation, select Settings»Desktop parameters»Panel specific in 
DIAdem SCRIPT. Figure 7-2 shows the selected checkbox Enable serial 
evaluation during recording mode.

Figure 7-2.  Enabling Serial Evaluation in the DIAdem SCRIPT Configuration

If you close the DIAdem SCRIPT configuration and click Enable 
recording mode in the toolbar, you can select and load multiple files in the 
file selection dialog boxes. DIAdem automatically stores the filenames you 
select in a script list file. When you save the script, you must save the 
associated script list file with the same name, but with the filename 
extension .lst. 

"MB_Ok" Ok

"MB_OkCancel" OK / Cancel

"MB_RetryCancel" Retry / Cancel

"MB_YesNo" Yes / No

"MB_YesNoCancel" Yes / No / Cancel

"MB_AbortRetryIgnore" Abort/Retry/Ignore

"MB_NoButton" No button
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Note If you select only one file in a file selection dialog box, the recording mode records 
the command in the script, with this filename as a parameter. 

When you start the script for serial evaluation, DIAdem reads out the script 
list file in sequence when the script loads and saves a file.  When you use 
different load or save commands ensure that the sequence of the filenames 
in the list file corresponds.

You only have to make minor modifications to change existing scripts into 
serial scripts. Replace the loading and saving parameters in your script with 
the identifier UseFileList. Create a script list file with the same name. 
The script list file contains the filenames to be used in the serial evaluation.
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Exercise 7-4
Objective: Using Loop Instructions

Repeat the envelope curve calculation. Vary the interval width, which 
specifies the extent to which the envelope curve adheres to the original 
curve.

In the following exercise you create a loop that repeats the envelope curve 
calculation.

1. Select DIAdem SCRIPT.

2. Select the Training.vbs tab to view the script with the same name in 
the script editor.

3. Insert a do...loop until loop for repeating instructions:
...
Do
  Call ChnEnvelopes(1,2,3,4,5,6,50)
  Call PicUpdate()
Loop Until (DxPeak<1)

Call DataFileSave("Envelopes.tdm","TDM")

4. Vary the interval width by adding the following instructions:
...
DxPeak = 50
Do
  Call ChnEnvelopes(1,2,3,4,5,6,DxPeak)
  Call PicUpdate()
  DxPeak = DxPeak/2
Loop Until (DxPeak<1)

Call DataFileSave("Envelopes.tdm","TDM")

5. Use the Pause command to stop the script after the report displays:
...
Call PicUpdate()
Call Pause(5)
DxPeak = DxPeak/2
...

6. Click Save file as.

Open the C:\Exercises\DIAdem Basics\ folder and save the 
extended script as Training.vbs.

7. Click Run script in the toolbar to test the Training.vbs script.
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When the Training.vbs script finishes, the following report appears:

The Training.vbs script contains the following instructions:
Call DataDelAll(1)
Call DataFileLoad("Vibration.tdm","","")

Call PicLoad("Envelopes")
Call PicUpdate()

DxPeak = 50
Do
  Call ChnEnvelopes(1,2,3,4,5,6,DxPeak)
  Call PicUpdate()
  Call Pause(5)

  DxPeak=DxPeak/2
Loop until (DxPeak<1)

Call DataFileSave("Envelopes.tdm","TDM")

End of Exercise 7-4 
The Basic_07_03.vbs script, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 7-5
Objective: Using Standard Requests

The envelope calculation does not have to be repeated in all cases. 
Therefore, you integrate a request to ask the user whether he wants DIAdem 
to run the rest of the calculation or not.

In the following exercise you define a standard dialog box for this request.

1. Select DIAdem SCRIPT.

2. Select the Training.vbs tab to view the script with the same name in 
the script editor.

3. Use the following instructions to display a message:
...
  DxPeak=DxPeak/2
  Call MsgBoxDisp("Execute another calculation?",_  
                  "MB_YesNo")
Loop Until (DxPeak<1)
Call DataFileSave("Envelopes.tdm","TDM")

4. Ask if the user wants to end the loop:
...
  Call MsgBoxDisp("Execute another calculation?",_  
                  "MB_YesNo")
Loop Until (DxPeak<1) or (MsgState="IDNo")
Call DataFileSave("Envelopes.tdm","TDM")

5. Click Save file as.

Open the C:\Exercises\DIAdem Basics\ folder and save the 
extended script as Training.vbs.

6. Click Run script in the toolbar to test the Training.vbs script.
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When each report displays, the following message appears:

The Training.vbs script contains the following instructions:
Call DataDelAll(1)
Call DataFileLoad("Vibration.tdm","","")

Call PicLoad("Envelopes")
Call PicUpdate()

DxPeak = 50
Do
  Call ChnEnvelopes(1,2,3,4,5,6,DxPeak)
  Call PicUpdate()
  Call Pause(5)

  DxPeak=DxPeak/2
  Call MsgBoxDisp("Execute another calculation?",_  
                  "MB_YesNo")
Loop Until (DxPeak<1) or (MsgState="IDNo")
Call DataFileSave("Envelopes.tdm","TDM")

End of Exercise 7-5 
The Basic_07_04.vbs script, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 7-6
Objective: Creating a Serial Evaluation in the Recording Mode

In the following exercise you create a script for serial evaluation. The script 
loads several data files, integrates the second channel, and displays the 
results in the Integration.tdr layout.

1. Select DIAdem SCRIPT.

2. Select Settings»Desktop parameters»Panel specific and select 
Enable serial evaluation during recording mode.

Click OK.

3. Click Enable recording mode in the toolbar.

Comment the script. Ensure that the Channel reference is set as Name.

Click OK.

4. Select DIAdem NAVIGATOR.

5. Delete the data in the Data Portal without saving the data.

6. Click Load data file.

Navigate to the C:\Exercises\DIAdem Basics\ folder and select 
all the data files that start with Meas_05. Click Load.

7. Select DIAdem ANALYSIS.

8. Open the Basic mathematics functions function bar and select 
Integration.
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9. Check the channels to be integrated as shown in the following figure:

Click Execute.

10. Select DIAdem REPORT.

11. Click Load layout without saving the current layout.

Open the C:\Exercises\DIAdem Basics\ folder and load the 
layout Integration.tdr.

In addition to the original data, the report also displays the integrated 
signal.

12. Select DIAdem SCRIPT.

13. Click Disable recording mode in the toolbar.

14. Click Save file as.

Open the C:\Exercises\DIAdem Basics\ folder and save the 
TeachIn(3).vbs script as Integration.vbs.

15. Click the tab at the bottom of the script editor and switch to the 
TeachIn(3).lst list file.

16. Click Save file as.

Open the C:\Exercises\DIAdem Basics\ folder and save the 
TeachIn(3).lst list file as Integration.lst.

Ensure that the only difference between the script name and the list file 
name is the filename extension, vbs or lst.

17. Click the tab at the bottom of the script editor to switch to the 
Integration.vbs script.

18. Click Run script in the toolbar to test the Integration.vbs script.

Tip If the last instruction is the command for waiting for any key stroke, Call 
KeyWait(), you can check the results at your own pace.
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When the script runs through the first time, the report looks like this:

When you finish this exercises, the Integration.lst list file 
contains the following entries:
C:\Exercises\DIAdem Basics\Meas_0519_01.tdm
C:\Exercises\DIAdem Basics\Meas_0520_01.tdm
C:\Exercises\DIAdem Basics\Meas_0520_02.tdm
C:\Exercises\DIAdem Basics\Meas_0521_01.tdm
C:\Exercises\DIAdem Basics\Meas_0521_02.tdm
C:\Exercises\DIAdem Basics\Meas_0522_01.tdm

The Integration.vbs script contains the following instructions:
Call DataDelAll(1)
Call DataFileLoad(UseFileList,"TDM","Load")

Call ChnIntegrate(_
        "[1]/Date\Time","[1]/Output","/Y_Integral")

Call PicLoad("Integration")
Call PicUpdate()
Call KeyWait()

End of Exercise 7-6 
The Basic_07_05.vbs script and the Basic_07_05.lst list file, which 
contain the solution for this exercise, are in the C:\Solutions\DIAdem 
Basics\ folder.
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Exercise 7-7
Objective: Creating a Serial Evaluation with a Loop

In the following exercise you add a loop to the serial evaluation script.

1. Select DIAdem SCRIPT.

2. Click the tab at the bottom of the script editor to switch to the 
Integration.lst list file.

3. Delete the comments from the list file so that only the following 
characters remain:

4. Click Save file as.

Open the C:\Exercises\DIAdem Basics\ folder and save the list 
file as Integration.lst.

5. Click the tab at the bottom of the script editor to switch to the 
Integration.vbs script.

6. At the beginning of the script, enter the following instructions for 
opening and positioning the text file:
Dim FNo, FErr
FNo  = TextFileOpen(AutoActPath & "Integration.lst",_
                    tfRead)
FErr = TextFileSeek(FNo,1)
...

7. Replace the command for loading data
Call DataFileLoad(UseFileList,"TDM","Load")

with the following instructions:
DataFileName = trim(TextFileReadLn(FNo))
Call DataFileLoad(DataFileName)
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8. To access the list file and read the filenames, define the following loop 
around the existing commands:
...
Do While Not TextFileEOF(FNo)
  Call DataDelAll(1)

  DataFileName = trim(TextFileReadLn(FNo))
  Call DataFileLoad(DataFileName)

  Call ChnIntegrate(_
       "[1]/Date\Time","[1]/Output","/Y_Integral")

  Call PicLoad("Integration")
  Call PicUpdate()
  Call KeyWait()
Loop

9. At the end of the script, enter the instruction for closing the text file:
...
Loop
FNo = TextFileClose(-1)

10. Click Save file as.

Open the C:\Exercises\DIAdem Basics\ folder and save the script 
as Integration_Loop.vbs.

11. Click Run script in the toolbar to test the Integration_Loop.vbs 
script.

The Integration_Loop.vbs script contains the following 
instructions:
FNo  = TextFileOpen(AutoActPath & "Integration.lst",_
                    tfRead)

FErr = TextFileSeek(FNo,1)
Do While Not TextFileEOF(FNo)
  Call DataDelAll(1)
  DataFileName = trim(TextFileReadLn(FNo))
  Call DataFileLoad(DataFileName)
  Call ChnIntegrate(_
        "[1]/Date\Time","[1]/Output","/Y_Integral")
  Call PicLoad("Integration")
  Call PicUpdate()
  Call KeyWait()
Loop
FNo  = TextFileClose(-1)
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Note The following example also opens a file and reads the contents line by line to the 
end. If an error occurs, the example displays the error number and error text:

FNo  = TextFileOpen(AutoActPath & "Integration.lst",_
                    tfRead)
If FNo = 0 Then
  Call MsgboxDisp("Error number: " & TextFileError(FNo)& _
                  VbCrLf & _
                  "message: " & TextFileErrorTxT(FNo))
Else
  FErr = TextFileSeek(FNo,1)
  Do While Not TextFileEoF(FNo)
    Call DataDelAll(1)
    DataFileName = trim(TextFileReadLn(FNo))
    Call DataFileLoad(DataFileName)

    Call ChnIntegrate(_
        "[1]/Date\Time","[1]/Output","/Y_Integral")

    Call PicLoad("Integration")
    Call PicUpdate()
    Call KeyWait()
  Loop
End If
FNo  = TextFileClose(-1)

End of Exercise 7-7 
The Basic_07_06.vbs script and the Basic_07_05.lst list file, which 
contain the solution for this exercise, are in the C:\Solutions\DIAdem 
Basics\ folder.
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G. Configuring DIAdem SCRIPT
The Desktop parameters are the program settings you can specify in 
DIAdem.

Setting Panel-Specific Parameters
In DIAdem SCRIPT, select Settings»Desktop parameters»Panel specific. 
The configuration dialog box has the following settings:

Library path Displays the current library folder with scripts.

User path Displays the current user folder with scripts. 

Activate series evaluation
Enables the function that you can use to select 
several filenames in specific file selection dialog 
boxes. The script to be recorded can then evaluate 
several files.

File coding Specifies the code for saving the script.

You can save all the program settings in a desktop file. The desktop file has 
the filename extension .ddd. To save your settings in a desktop file, first 
select Window»Close all. Then click Save desktop.
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Summary, Tips, and Tricks

• To create a script, you record the actions you perform in the recording 
mode. The recording mode records the commands associated to the 
actions, in the script editor. If you disable the recording mode, you can 
edit, expand, save, and test the commands.

• The specified command sequence is only temporary in the editor. You 
must save the created script to be able to reuse the script later.

• You can extend and control scripts using loops, condition-related 
branching, procedures, and user-defined dialog boxes.

• In the script editor, syntax coloring helps you to distinguish between 
comments, commands, and variables. You can set the syntax coloring in 
the shortcut menu of the file overview.

• To record dialog box parameters and variables in the recording mode, 
press <Ctrl-A> in the open dialog box.

• If you select a DIAdem term in the script editor, press <F1> to access 
the help page for this variable or command. In the Help tree, the 
Functions, Commands, and Variables folder has an alphabetical list 
of all the DIAdem commands and variables.
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Notes
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Lesson 8
The DIAdem Calculator
Introduction
In this lesson you will learn how to use the Calculator to analyze data with 
your own formulas. 

In formulas you can specify operations with data channels and generate new 
data channels. You also can calculate and display single values and assign 
the values to variables. The Calculator can run numeric, Boolean, and text 
operations. 

You Will Learn About: 

A. Using the DIAdem Calculator

B. Working with the Calculator

C. Operands, Operations, and Auxiliary Variables

D. Additional Notes
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A. Using the DIAdem Calculator
The DIAdem VIEW, DIAdem ANALYSIS and DIAdem SCRIPT panels 
have an integrated calculator. Click the Calculator button in the toolbar to 
open the Calculator. Figure 8-1 shows the Calculator interface.

Figure 8-1.  Extended Calculator Mode

Entry Field
Use the keyboard or the Calculator keys to enter your formula in the entry 
field. The formula must not exceed a maximum of 1000 characters.

Result Bar
DIAdem displays the calculation results and confirmation or error messages 
in the result bar.

Buttons
The buttons Calculate, Command stack, Basic, Extended, Help and 
Close are to the right of the entry field.

Click Calculate to evaluate the formula. When the calculation is complete 
the entry field background is blue.

1 Entry field
2 Result bar
3 Keyboard field
4 Operations

5 Buttons such as Calculate and Command stack
6 Button for Basic and Extended modes
7 Operands
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Click Command stack to open the list of the last calculations performed. 
The last formula calculated is at the top of the list. Double-click the formula 
to copy it to the entry field.

Click Extended or Basic to change the range of Calculator functions. The  
Basic mode provides calculator functions, and the Extended mode includes 
the operations table and the variables table.

Keys
The keys below the result bar are for the basic calculator functions. They are 
grouped in blocks.

Operations Table
The operations table is on the bottom left in the Extended view. The 
operations are listed in alphabetical order. The ToolTip displays the name 
and the argument of the operation for each table cell. Use the tabs to switch 
between numeric, Boolean, and text operations. 

Double-click the name of an operation to copy it into the entry field.

Variable Table
The variables table is on the bottom right in the Extended view. This table 
contains variables frequently used in formula expressions. The variables 
include various single and vector variables and an overview of the current 
channels in the Data Portal.

Double-click a variable name or a channel name to copy it into the entry 
field.
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B. Working with the Calculator
The formulas you enter in the Calculator can perform all types of 
mathematical tasks. The formulas often have different syntax and return 
varying results. The formulas can request single values and variables, assign 
values to variables, and calculate data channels.

Requesting Single Values
Requesting single values means that the result is a single value. You can 
request the contents of a variable or calculate a formula. 

Syntax Variable name?

Formula expression?

For a variable request, the Calculator displays the contents of the variable 
in the result bar.

If you enter a formula expression that has a single value result, the 
Calculator evaluates the formula and displays the result in the result bar. A 
formula expression runs operations on operands.

Note that the Calculator can call and display only single values directly. You 
must assign a result channel for a channel operation.

Examples Pi?

The value of the constant Pi appears in the result line.

sin(0.14598)?

The Calculator calculates the sine of the value 0.14598 and displays the 
result in the result bar.

Invalid Ch('Input')+5.345?

The formula expression contains a channel, Ch('Input'). The result of the 
calculation is not a single value, it is a complete channel that DIAdem 
cannot display in the result line. This request leads to an error message.

Assigning Values to Variables
Assigning a value to a variable means that a variable receives a single value, 
or the result value of a formula calculation. 

Syntax Variable := Value
Variable := Formula expression

The variable that you specify on the left-hand side of the assignment must 
be either a scalar variable or an element of a multi-dimensional variable.

A formula expression runs operations on operands.
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Note In all formula calculations, ensure that the result type is compatible with the 
variable on the left.

Examples R1 := sin(PI/2)

The real variable R1 receives the value of the sine function at Pi/2.

T1 := 'Value of Pi: ' + str(Pi,'d.dd')

The T1 text variable contains text that consists of a specific text and a 
formula expression. The formula converts the numeric quantity Pi into text. 
The format instruction 'd.dd' displays numbers with two decimal places.

Invalid L1 := 23/5

The result of the formula expression is Real (floating-point number). You 
cannot assign 23/5 to the L1 variable without first converting this value to 
an integer (without decimal places). This assignment leads to an error 
message.

R1 := Ch('Input')/10

The formula expression contains a reference to the Input channel. The 
result of this formula is a channel. You can only assign one value to a 
variable. This assignment leads to an error message.

Calculating Channels
Calculating channels means that a formula runs an operation on data 
channels, or data channels and variables, or data channels and constants. 
The result of this formula is also a channel, which DIAdem stores in the 
default channel group in the Data Portal.

Syntax Channel := Formula expression

A formula expression runs operations on operands.

A channel calculation always applies to the entire channel. Every element 
of the channel is calculated according to the formula expression. The result 
channel is the same length as the shortest of the channels involved in the 
calculation. 

If the formula expression does not include a channel, the result of the 
calculation is a single value. You can only assign one single value to one 
variable.

Result Channel for Channel Calculations
The result of a channel calculation is a channel, which you enter on the left 
side of the formula with the expression Ch(). The expression can specify 
the result channel, or the Calculator searches for a target channel.
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You can specify the result channel in various ways:

• Ch('Channelname') := Formula expression

This formula references the result channel by name.

If a channel with this name already exists in the Data Portal, the 
Calculator overwrites the previous channel contents with the calculation 
results.

If no channel with this name exists in the Data Portal, the Calculator 
creates a new channel in the default group and fills the channel with the 
results of the channel calculation.

• Ch(Channelnumber) := Formula expression

This formula references the result channel by the channel number. 

If no channel with this channel number exists in the Data Portal, or if the 
Data Portal contains less channels than the number of the channel, the 
Calculator creates a new channel in the default group and generates a 
channel name.

• Ch(#) := Formula expression

This formula does not specify a result channel. In this case, the 
Calculator specifies the result channel. The Calculator generates a result 
channel in the default group and generates a channel name.

Use channel names instead of channel numbers in formula expressions to 
increase readability and flexibility. Only use channel numbers if several 
channels have the same name and you want to access a particular channel 
and not the first channel. You also can enter Group name/Channel name 
to refer to a particular channel.

If you use the channel name in the formula expression, we recommend you 
use quotation marks. This way you avoid misinterpretations which arise if a 
channel name contains special characters such as + / - *, or if the channel 
name has the name of an internal function such as sin.

Examples Ch('Sine') := Sin('Values')

This formula expression evaluates the Values channel with the sine 
function. The Calculator saves the results in the Sine channel. If there is no 
channel with the name Sine, the Calculator automatically creates a new 
channel in the default channel group. Otherwise the Calculator overwrites 
the contents of the existing channel with the new values.

Ch(3) := Ch(2)/Ch(1)

The Calculator divides each value of the second channel by the respective 
value of the first channel and saves each result in the third channel of the 
Data Portal.
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Ch(#) := 'Distance'/'Time'

The Calculator divides the values of the Distance channel by the values of 
the Time channel. If # is set, the Calculator automatically specifies the 
result channel in the default channel group, generates a name for the result 
channel, and saves the average speed determined.

Invalid Ch('Result') := Sin(Pi/2)

The result of the calculation is a single value that you only can assign to a 
variable but not to a channel. If you want to generate a channel with constant 
values, use the channel generating function. This calculation leads to an 
error message.

Ch(Sin) := Sin('Values')

This instruction calculates the sine for each value of the Values channel 
and saves the results in the Sin channel. However this conflicts with the 
internal sin function that calculates the sine. For the Calculator to accept 
the channel name Sin you must enclose the name in single quotation marks. 
This calculation leads to an error message.
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C. Operands, Operations, and Auxiliary Variables
A formula expression runs operations on operands and saves the result in 
auxiliary variables, for example.

Using Operands
Operands can be program variables, auxiliary variables, and user variables, 
which represent constants, single values, vectors, matrices, or channels.

The operands have different operand forms and operand types.

Operand forms include constants whose contents cannot be changed, scalar 
variables that accept exactly one value, vector variables and matrix variables 
that represent one or two dimensional fields, and channels that display 
numeric vectors with additional information such as the channel name or 
unit.

Note In the Calculator you only can run operations with single values, with Numeric 
or Time type channels, and with individual elements of vectors and matrices. 

Table 8-1 shows which operands are available for the various operand 
forms.

The constants that are frequently used in calculations, π and e, are 
predefined in DIAdem and can be used by name.

• Circle constant π 3.1415926536

• Euler number e 2.7182818285

Table 8-1.  Several Operand Forms

Operand Type Operand Example

Constant Program variable
User variable

Pi
Freely definable

Scalar variables Program variable
Auxiliary variable
User variable

SmoothWidth
R1, B1, L18
Freely definable

Vector variable Program variable
Auxiliary variable
User variable

ChnName(2)
RV1(3), LV3(2), TV(3)
Freely definable

Matrix variable Program variable
User variable

ChD(2,25)
Freely definable

Channel Program variable Ch(3), Ch('Name')
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The operand type specifies the type and the range of the values the operand 
can have:

• Integer type: Byte, Integer, Word, LongInteger

• Real type: Real

• Text type: Free text, Enumeration, Dynamic enumeration 
list

• Boolean type: Boolean

Program variables and user variables can accept any of the types, whereas 
auxiliary variables only can accept LongInteger, Real, Boolean, Free 
text, and Dynamic enumeration list types.

In formula calculations the operand type is important both for calculating 
the formula expression and for the result assignment. The Calculator cannot 
calculate formula expressions containing operands with incompatible types. 
The same applies if a formula result is assigned to a variable type that is not 
compatible with the result type.

The Calculator has the following functions for converting the operands into 
compatible types:

• Trunc converts numeric types into integer types.

• Str converts numeric values into text.

• Val converts text into a numeric value.

Using Operations
The Calculator enables you to connect numeric, Boolean, bit, and text 
operands. The Tables 8-2 to 8-6 list the available operations. 

Arg means you can specify a Numeric or a Time channel and a number. 
Parameters in brackets [ ] are optional.
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Table 8-2.  Numeric Operations

Function Operators

Constants Pi, e

Basic calculation types +, -, *, /

Exponentiation ^

Root
Square

Sqrt(Arg)
Sqr(Arg)

Trigonometric functions Sin(Arg), Cos(Arg), Tan(Arg)
Arcsin(Arg), Arccos(Arg), 
Arctan(Arg)
ATanK(Opposite leg, Adjacent leg)  or 
Atk(Arg)
Sinh(Arg), Cosh(Arg), Tanh(Arg)
Arctanh(Arg) or Atanh(Arg)

Random values Rnd(Arg) [0 <= rnd(Arg) <= Arg]

Standard normal distribution Snd(X)

Conversion radian, degrees Rad(DegArg), Deg(RadArg)

ex, natural logarithm Exp(Arg), Ln(Arg)

Power of ten Eex(Arg)

Logarithm Lg(Arg) or Log(Arg)

Absolute value Abs(Arg)

Signum function Sign(Arg)

Factorial Fac(IntegerArg)

Truncating
Rounding off

Trunc(Arg)
Round(Arg)

Decimal places Frac(Arg)

Remainder (Modulus) Mod(Arg)

Characteristic values of the 
channel

CCh(Channel, Type)

Extreme values MinV(Value1, Value2)
MaxV(Value1, Value2)
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Text conversion Str(Number [,Format])
Char(Number)
RTT(Number [,#Format])
RTP(RealTime, PartialFormat)

Search function Find(Condition [,StartLine])
FindReverse(Condition [, StartLine])
PNo(Channel, Value)

Table 8-3.  Boolean Operations

Function Operators

Comparison operations <, <=, =, >=, >

Boolean operations And, Or, Not

Variable file activated? VSA("FileName")

User variable activated? VIT("UserVariable")

Table 8-4.  Bit Operations

Function Operators

Sets a bit
Deletes a bit
Reads a bit

SetB(Arg, BitNo)
ClrB(Arg, BitNo)
GetB(Arg, BitNo)

Left shift
Right shift

Shl (Arg, BitNum)
Shr (Arg, BitNum)

Boolean operations AndB(Arg1, Arg2)
OrB(Arg1, Arg2)
XorB(Arg1, Arg2)
NotB(Arg, ByteNum)

Table 8-2.  Numeric Operations

Function Operators
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Table 8-5.  Text Operations

Function Operators

Text addition +

Conversion to numeric type Val(Text)
Ord(ASCII characters)
TTR(Date/time text [,Format])

Channel search CNo(ChannelName [, Start]]

Upper case
Lower case

UpC(Text)
LoC(Text)

Index to text vector Idx(Text, "VarName")

Determines keyword Enum(EnumerationlVariable, Index)
MaxOrd(EnumerationVariable)

Copy
Delete

Cop(Text, Number)
Del(Text, Number)

Character position Pos (SearchString, Text)

Text length Len(Text)

Formatting Str(Text, Format)
PU(TextVariable, Format)

Deleting blanks LTrim(Text)
RTrim(Text)
Trim(Text)

Working with channel number 
character strings

ChnStrAdd(ChannelNoStr, ChannelNo)
ChnStrCnt(ChannelNo channelNoStr)
ChnStrRead(ChnNoStr, Index)

Decoding a file name NameSplit(Text, Type)

Writing a line to a file TextFileWriteLn(FileHandle)

Reading a line from a file FR(Filename, Linenumber)
TextFileReadLn(FileHandle)
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Using Auxiliary Variables
DIAdem provides auxiliary variables that you can use for intermediate 
storage of formula results.

Table 8-7 lists names, dimensions, and the type of the auxiliary variables.

Table 8-6.  File and Folder Operations

Function Operators

Opens and closes a text file TextFileOpen(Filename,Mode)
TextFileClose(FileHandle)

Error when accessing text file TextFileError(FileHandle)
TextFileErrorTxt(FileHandle)

Checks end of text file TextFileEOF(FileHandle)

Jumps to row in text file TextFileSeek(FileHandle, LineNumber)

Checks file attribute FileAttrCheck(FileName, Attribute)

Determines file size DataFileSize(FileName)
FileSize(FileName)

File exists? FilEx(FileName)

Checks file access FileDateGet(FileName, Time)

Checks folder attribute FolderAttrCheck(Folder, Attribute)

Determines folder size FolderSize(Folder)

Folder exists? FolderExist(Folder)

Checks folder access FolderDateGet(Folder, Time)

Table 8-7.  Auxiliary Variables

Type
Variables
name Value range Example

Long Integer L1, L2,..., L30 Single value L3 := 12345

LV1, LV2, LV3 Vector[1...15] LV2(2):= -235

Real R1, R2,..., R30 Single value R2 := 0.12345

RV1, RV2, RV3 Vector[1...15] RV3(1) := 12.35

Boolean B1, B2,..., B10 Single value B5:= Yes
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Note Each (auxiliary) variable has a defined, constant type and therefore only can 
accept values of this type.

To access single elements of a multi-dimensional variable, specify the 
indexes. You also can use Integer type variables as indexes. 

Select Edit»Auxiliary variables, or open the expanded Calculator panel to 
view and to modify the auxiliary variables in DIAdem SCRIPT.

Text T1, T2, ..., T10 Single value T4 := "Mo_12"

TV Vector[1...10] TV(7):= "XY"

Dyn. enum. 
list

G1, G2, ..., G10 Single value G1 := "Gear"

GV Vector[1...10] GV(1):= "Engine"

Table 8-7.  Auxiliary Variables

Type
Variables
name Value range Example
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D. Additional Notes
The following sections include typical Calculator applications.

Working with Channel Names
You can access channels with channel numbers that have specific channels 
or with channel names.

Working with Channel Numbers

Example Ch(5):= Ch(1) + Ch(2)

In the above formula all channel positions are specified, which means that 
DIAdem stores the sum of the first and second channels in the list view of 
the Data Portal in the fifth channel. The channel names are irrelevant.

If the result channel 5 does not exist when DIAdem evaluates the formula, 
the Calculator creates the channel and generates a channel name.

Working with Channel Names

Example Ch('Power'):= 'Revs' * 'Torque'

In the above formula the channels to be used are specified by name. 
Therefore, their channel number is irrelevant.

If a channel named Power already exists when the channel is calculated, the 
Calculator overwrites the channel contents with the calculation results.

If no channel with the specified name exists in the Data Portal, the 
Calculator automatically generates a channel called Power and fills it with 
the results of the multiplication of the Revs channel by the Torque channel.

Defining Conditions
You formulate conditions with Boolean operators. Conditions only can have 
the values true (result: Yes, 1) or false (result: No, 0). You can link 
conditions with each other and with numeric operations. For example, 
combining different operations is useful when you analyze channels.
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In formula expressions you can use the comparison operators listed in 
Table 8-8 and the operations listed in Table 8-9.

In the following formula the Calculator compares the data in the Angle2 
channel with the data in the Sine channel linewise and stores the results in 
the Result channel. If the current value from Angle2 is greater than the 
value in the same line of the Sine channel, the value is 1 at the same place 
in the Result channel, because the condition is true. Otherwise, the result 
channel has the value 0 at the same place.

Examples Ch('Result'):= ('Angle2' > 'Sine')

Table 8-8.  Comparative Operators

Comparison Meaning

< Less than Checks whether the first operand is less

<= Less than or 
equal to

Checks whether the first operand is less than or 
equal to the second operand

= Equal to Checks whether operands are equal

<> Not equal to Checks whether operands are not equal

>= Greater than or 
equal to

Checks whether the first operand is greater than or 
equal to the second operand

> Greater than Checks whether the first operand is greater

Table 8-9.  Logical Operators

Concatenation Meaning

and and The expression is fulfilled (true) if both operands 
have the value true

or or
(inclusive)

The expression is not fulfilled (false) if both 
operands have the value false

not not The value of the operands is inverted
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Calculating with Invalid Values
In DIAdem, invalid values are called NoValues. DIAdem does not display 
NoValues in a report and does not use NoValues for calculations.

The following rules apply when NoValues are used in calculations:

• If one of the terms in a calculation is a NoValue the result is also a 
NoValue:
10 * NoValue = NoValue
10 + NoValue = NoValue

• This does not apply for multiplication by and division of 0. If one of the 
factors is 0 the result is also 0:
0 * NoValue = 0
0 / NoValue = 0

The aim of the following calculation is to exclude channel values outside the 
limit values 5 and -1 from subsequent calculations.

Example Ch(6):= Ch(5) + ((Ch(5)>5) or (Ch(5)<-1)) * NoValue

If the value from channel 5 is between -1 and 5, the condition 
(Ch(5) > 5 or Ch(5) < -1) is not true, and the result of the 
multiplication is 0. The summation result is the value of channel 5 at this 
position, which means it is identical to the inspected datum.

If the value from channel 5 is outside the limit values, the condition is true 
and the result of the condition check is 1, the result of the multiplication is 
NoValue, and the result of the summation is therefore also NoValue.

The above formula only transfers the values in channel 5 that are inside the 
limits, to the result channel 6. The other channel values are NoValues. 
DIAdem ignores these NoValues in subsequent calculations and functions 
with this result channel. DIAdem does not display NoValues in reports 
either.

Using Variable Indexes
To access single elements of multidimensional variables such as vectors and 
matrices, or to access channels, you must specify the element with an index. 
For example, specify RV1(3) to access the third element of the real vector 
variable RV1.

You do not have to enter specific indexes, you can use variables and 
functions instead. Indexes must be integer numbers.

In the following example, the trunc function converts the contents of the 
real variable R2 into an integer value, which you can then use as an index. 
You cannot use R2 as an index without converting it.

Example R2 := 3.456

LV1(trunc(R2)) := 7
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Notes on Some of the Functions
Several key functions are listed below.

Calculating Characteristic Values
Use the descriptive statistics to determine characteristic statistical values 
such as sums, extreme values, mean values, quantiles, dispersion, and 
moments. The CCH function determines a specific characteristic value of a 
channel, such as the mean, the minimum value, the maximum value, the 
range, or the sum. 

Syntax CCH(Channel, Type)

Find Function
Use the find function to check a data channel for the first occurrence of a 
condition. The channel condition is a Boolean condition applied to 
channels. A starting line, where DIAdem starts to check for the condition, is 
optional. The result of this function is the number of the line in which the 
condition is true for the first time. If the condition is not true for any of the 
data channel values, the result is 0.

Syntax find(Condition [,Startrow])

PNo Function
The PNo function searches for the line in a data channel that has the value 
that is closest to the value searched for. Unlike the find function, this 
function does not need a tolerance setting.

Syntax PNo(Channel, Value)

Time Conversion
The rtt (real to time) function converts a numeric value into a time format. 
The format instruction defines the conversion. The numeric value is the 
number of seconds that have elapsed since 01/01/0000.

Syntax rtt(Number [,Format])

Use the ttr function (time to real) to convert a text in time format into a real 
value. DIAdem uses its internal time format. The result is the number of 
seconds that elapsed from 01/01/0000 until the specific date.

If the time text does not correspond to the time format defined in the general 
settings, define the appropriate format for the text conversion.

Syntax ttr(Time text [,Format])
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Exercise 8-1
Objective: Working with the Calculator

To save memory space when you record measurement values, the 
measurement acquires the characteristic vehicle data at different sampling 
rates. To combine and calculate the data, you must convert the data to a 
common time basis.

In the following three exercises you use the functions for DAT files to load 
the first three channels of the Car.dat file. You then use the function for 
reducing loading of DAT files to load the last two channels of the Car.dat 
file. You then calculate the power in kw and use the find function to 
determine the time when the speed exceeds the limit value 100. You display 
the results in the Car.tdr report.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Select File»DAT files»Paste from file.

Navigate to the Car.dat data file in the C:\Exercises\DIAdem 
Basics\ folder and select the file.

Select the channels Time, Speed, and Revs:

Click Execute.

4. Select File»DAT files»Paste from file again.

Navigate to the Car.dat data file in the C:\Exercises\DIAdem 
Basics\ folder and select the file.

Select the Torque channel and select Reduce lines:
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5. Click Line reduction and set the dialog parameters:

Reduce the data in such a way that DIAdem only loads 1200 values from 
the first to the last channel value.

– First value: 1 

– Last value: 6000

– Number of intervals: 1200

Select Time2 as the x-channel.

Click OK. 

6. Click Execute to load the data.

7. In the Data Portal properties, compare whether the channels Time and 
Time2 have the same minimum and maximum values and are both 1200 
values long. If the contents are identical, you can calculate the data 
channels.

8. Select DIAdem ANALYSIS.

9. Click the Calculator in the toolbar.

Enter the following formulas into the entry field and click Calculate for 
each one, to determine the power of the channels in kW:

Ch('Power'):= 'Revs'*2*Pi/60 * 'Torque'/1000

Cd('Power'):= 'kW'
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10. Determine the period for accelerating from 0 to 100 km/h with the 
formula:

L1:= find('Speed'>=100)

The find function checks for the first instance of the specified 
condition in the Speed data channel. The result is the number of the line 
with the first value greater than 100. If none of the values is greater than 
100, the condition is not true and the result is false.

11. Determine the time with the formula
R1:= ChD(L1,'Time')

The matrix variable ChD accesses the line L1 in the Time channel.

Note You can combine the two calculations in one formula:

R1:=ChD(find('Speed'>=100),'Time')

12. Close the Calculator.

13. Select DIAdem REPORT.

14. Click Load layout.

Navigate to the Car.tdr layout in the C:\Exercises\DIAdem 
Basics\ folder and open the prepared layout.

15. Double-click the top axis system to open the dialog box for the curve 
definition.

The Time, Speed curve is already defined in the dialog box.
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16. Click New entry and select the Constant display mode.

Enter the calculated time value R1 as the x-constant and the speed value 
100 as the y-constant.

Click OK in both dialog boxes.

17. Open the Decorations function bar and select Texts.

18. Click the text cursor in the worksheet and enter the text:

From 0 to 100 in @str(R1, ’d.d’)@ s
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The report looks like this:

End of Exercise 8-1 
The Car_1.tdr layout and the Car_1.dat data file, which contain the 
solution for this exercise, are in the C:\Solutions\DIAdem Basics\ 
folder.
© National Instruments Ireland Resources Limited 8-23 DIAdem Basics Course Manual



Lesson 8 The DIAdem Calculator
Exercise 8-2
Objective: Isolating Events

In the following exercise you use Boolean functions and NoValues in the 
formula calculation to isolate velocity values that exceed 100 km/h in a test 
drive measurement.

1. Select DIAdem SCRIPT.

2. Click Execute script file in the toolbar. 

Navigate to the Car_fp.vbs script in the C:\Exercises\DIAdem 
Basics\ folder and start the prepared script.

3. A report appears.

Press the space bar to continue the script. The Calculator appears.

4. Enter the following formula to determine where the values of the Speed 
channel are greater than 100:
Ch('Result') := 'Speed' >= 100

Click Calculate. This is a logical operation, so the result channel 
Result only receives the values 0 (condition not true) and 1 (condition 
true).

Close the Calculator.

5. Press the space bar again, click Yes in the dialog box that opens, and 
enter the following formula:
Ch('Result') := ('Speed' >= 100) * 'Speed'

Click Calculate. The formula replaces each 1 in the Result channel 
with the corresponding value in the original Speed channel. 

Close the Calculator.

6. Press the space bar again, click Yes in the dialog box that opens, and 
enter the following formula:
Ch('Result') := 
('Speed' >= 100) * 'Speed' + ('Speed' <100) * NV

Click Calculate. The formula hides all the values of the original Speed 
channel that are less than 100. You use the characteristics of NoValue 
calculation.

If one of the terms in the formula is NoValue, the result of the 
mathematical operation is automatically NoValue. This does not apply 
for multiplication by 0.
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If the Speed channel values are greater than 100, the result channel 
accepts the values (see Figure 8-2), otherwise the values are NoValues 
(see Figure 8-3).

Figure 8-2.  Result of the Check for Values Greater than 100

Figure 8-3.  Result of the Check for Values Less than 100

Note You can combine the last two formulas into the following formula:

Ch('Result'):= 'Speed' + ('Speed'<100)* NoValue

That means you can eliminate data in a channel with the following type of 
formula:

Channel := Channel + Counter condition * NoValue

7. Close the Calculator.

8. Press the space bar and click No in the dialog box to end the script. 
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When the script ends, the report looks like this:

End of Exercise 8-2 
The Car_fp.tdr layout, which contains the solution for this exercise, is in 
the C:\Solutions\DIAdem Basics\ folder.
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Summary, Tips, and Tricks

• The Calculator can perform numeric, Boolean and text operations. Use 
the Calculator to calculate channel formulas. The Calculator can also 
calculate and display single values and assign single values to variables:

– Request Variable name? or
Formula expression?

– Variable assignment Variable := Formula expression
Variable := Value

– Channel calculation Channel := Formula expression

• Use the find function to check the data area for a freely definable 
condition.

• NoValues

– are values that are defined invalid.

– are represented by the highest value that can be displayed.

– can be defined as any value.

– are not usually displayed in reports or included in calculations.

• The result of a calculation with NoValue is NoValue.

The exceptions are:

– 0 * NoValue = 0

– 0 / NoValue = 0
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Notes
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Additional Exercises
Introduction
In the following exercises you will reinforce the skills you have learnt. 

In the first example you can check what you have learnt. In the second 
example you use a special function for creating a report and for 
mathematical analysis.
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A. Example I
The first example consists of three exercises. The exercises revise the skills 
you have learnt for working with DIAdem REPORT.

You will carry out the following actions:

• Load a data set

• Display data in a report

• Integrate a diagram of the measurement object in the report and create a 
test description

• Analyze the data with an approximation

• Display the mathematical results in the report
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Exercise 9-1
Objective: Creating a Report

In the following exercise you load the data file Fridge.tdm and create a 
report layout with three axis systems with grid lines, to display three 
measurement signals separately. You create another axis system with a 
legend, to display all three measurement signals together.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the Fridge.tdm data file in the C:\Exercises\DIAdem 
Basics\ folder and drag and drop the file into the Data Portal.

4. Select DIAdem REPORT.

5. Delete the current layout without saving the layout.

6. Open the 2D axis system function bar and select a Simple 2D axis 
system. 

7. Drag open the axis system at the top left of the worksheet.

8. Double-click the axis system to open the dialog box for curve and axis 
definition.

9. Click Axis definition.  Enable Frame and define horizontal and vertical 
grid lines, as shown in the following figure: 
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10. Select Show minitick grid and click Miniticks to set up the minitick 
grid for the x-axis and the y-axis as shown for the x-axis in the following 
figure:

Click OK to close all the dialog boxes.

11. Select Copy and then select Paste three times in the shortcut menu of 
the axis system and insert three of the same axis systems in your report.

12. Position three axis systems underneath each other in the worksheet. Use 
the alignment functions in the toolbar to adjust the size and the intervals.

Position the fourth axis system to the right of the three other axis 
systems, as shown in the report at the end of this exercise. 

Note Select Edit»Undo or press <Ctrl-Z> to undo the actions carried out last.

13. Select the data channels Time and Freezer and drag and drop these 
data channels into the upper left axis system.
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14. Select the data channels Time and Center and drag and drop these data 
channels into the middle axis system on the left.

15. Select the data channels Time and VegCompartment and drag and 
drop these data channels into the bottom left axis system.

16. Double-click the top axis system to open the dialog box for the axis 
definition and click Curve param to set the curve parameters as shown 
in the following figure:

Click OK to close all the dialog boxes.

17. Repeat the last step for the middle and the bottom axis systems.

18. Select all the data channels in the Data Portal and drag and drop the data 
channels into the fourth, large axis system.

19. Double-click the fourth axis system to open the dialog box for curve and 
axis definition. 
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20. Select the Legend checkbox.

21. Click Legend and select white as the background color:

Click OK to close all the dialog boxes.

22. Click the legend and position the legend at the bottom of the axis system.
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23. Double-click the y-axis text to open the dialog box for axis labeling and 
change the text as shown in the following figure:

Click OK.

The report looks like this:

End of Exercise 9-1 
The Fridge_1.tdr layout, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 9-2
Objective:  Creating a Text Field

In the following exercise you create a text field where you enter the 
company logo and text that describes the test.

1. Select DIAdem REPORT.

2. Open the Decorations function bar and select Rectangles.

3. Click the frame cursor in the top right of the report and drag open a 
rectangle for a text field.

4. Double-click the rectangle to open the rectangle dialog box and check 
the settings shown in the following figure:

5. Click Position to specify the size and position of the rectangle with the 
following coordinates:

Click OK to close all the dialog boxes.

6. Repeat steps 2 to 5 to break down the text field into smaller partitions.

7. Open the Decorations function bar and select Texts to enter a free text. 

8. Click the text cursor in the text field and enter the following text: Press 
<Enter> after each of the first two lines: 
Evaluation: 
@CurrDate@
@CurrTime@ 

Each of the two variable names for the current date and the current time 
must have a leading and a trailing @ character.

9. Click the text cursor in the worksheet to end text entry.
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10. Open the Decorations function bar and select Texts to enter another 
text. 

11. Click the text cursor in the text field and enter the following text: Press 
<Enter> after the first line:
Tester: 
I.Icecube

12. Click the text cursor in the worksheet to end text entry.

13. Select both texts with click-<Ctrl>.

14. Select Properties in the shortcut menu of the selected texts.

15. Select Blue as the Font color and click OK. 

16. Position the texts one above the other as shown in the report at the end 
of this exercise.

17. Open the Graphics file function bar and select Load graphics.

18. Select the National Instruments logo.

19. Position the logo at the top of the text field.

20. Click Redraw in the toolbar.

The report looks like this:

End of Exercise 9-2 
The Fridge_2.tdr layout, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 9-3
Objective: Mathematical Analysis - Approximation

You can use the approximation function to describe the measurement data. 
Use an approximation model function to present the measurement data as 
exactly as possible.

In the following exercise you calculate the approximation for the signals 
from the last exercise and display the results in the report.

1. Select DIAdem ANALYSIS.

2. Open the Curve fitting functions function bar and select 
Approximation.

Set the dialog box parameters as shown in the following figure:

3. Click Set up to select the terms of the following set up function:
a1 + a2 * x + a3 * x² + a4 * x³

Click OK.
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4. Click Execute to run the approximation.

5. Repeat the approximation for the channels Center and 
VegCompartment. Time is the x-channel for both of the y-channels.

6. Select DIAdem REPORT.

7. Select the respective x and y-result channels in the Data Portal for the 
three approximations and drag and drop these channel pairs to the 
associated axis system on the left of the worksheet.

8. Click Save layout as. 

Navigate to the C:\Exercises\DIAdem Basics\ folder and save the 
report file as MyFridge.tdr.

The report looks like this:

End of Exercise 9-3 
The Fridge_3.tdr layout and the Fridge_1.tdm data file, which 
contain the solution for this exercise, are in the C:\Solutions\DIAdem 
Basics\ folder.
© National Instruments Ireland Resources Limited 9-11 DIAdem Basics Course Manual



Lesson 9 Additional Exercises
Additional Exercise
If you have time, complete the following exercise.

1. Enter a text that displays the last approximation function and the 
associated coefficients. The coefficients are in the vector variable 
ApprAnsatzCoef.

2. Use the str function to limit the number of places after the decimal 
point for the approximation coefficients:

@str(ApprAnsatzCoef(x),’d.dd’)@
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B. Example II
The second example consists of eight exercises. The exercises demonstrate 
further display features in DIAdem REPORT and functions for working 
with NoValues.

You will carry out the following actions:

• Load a data set

• Display data as differential bars

• Replace NoValues with interpolated values

• Calculate a mean value

• Add data to the data in the Data Portal

• Create multi-scaled axis systems

• Label the data with symbols and text
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Exercise 9-4
Objective: Changing the Curve Display

In a measurement, weather data is recorded and saved in a file. In the 
following exercise you load the data file Weather_1.tdm and display the 
temperature differences as differential bars in a new layout.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the Weather_1.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

4. Select DIAdem REPORT.

5. Delete the current layout without saving the layout.

6. Select Settings»Layout parameters and set number-oriented channel 
reference as shown in the following figure:

Click OK.
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7. Open the 2D axis system function bar and select a Simple 2D-axis 
system. 

8. Drag open the axis system to cover the entire worksheet.

9. Select the channels Date, T_Min, and T_Max in the Data Portal and 
drag and drop the channels into the axis system.

10. Double-click the axis system to open the dialog box for curve and axis 
definition and delete the last curve definition.

11. Change the display mode to Differential and select T_max as the 
y1-channel. 

12. Click Axis definition and set the global 2D axis system parameters as 
shown in the following figure. 

Set a frame and horizontal and vertical grid lines for the axis system.
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13. Click Scaling and change the Tick style as shown in the following 
figure:

• Bottom for the x-axis

• Left for the y-axis

Click OK.

14. Click Numbers to specify the time format #DD/ T yy for the x-axis.

This time format suppresses leading zeros for the day and displays the 
month and the year in a second line.
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Click OK.

15. Click Labeling and delete the x-axis label text.

Click Y-axis and change the y-axis labels as shown in the following 
figure:

Click OK to close all the dialog boxes.

16. Click Save layout as.

Navigate to the C:\Exercises\DIAdem Basics\ folder and save the 
layout as MyWeather.tdr.
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The report looks like this:

End of Exercise 9-4 
The Weather_1.tdr layout, which contains the solution for this exercise, 
is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 9-5
Objective: Processing NoValues

The weather data sensor occasionally stopped logging. These lapses were 
recorded as NoValues. You interpolate between the existing data points to 
recreate the approximate data points.

In the following exercise you use the standard function NoValues and 
display the result in the report.

1. Select DIAdem ANALYSIS.

2. Open the Basic mathematics functions function bar and select 
NoValues.

Set the dialog box parameters as shown in the following figure:

Click the three points next to y-channels to select the y-channels as 
shown in the following figure:

Click OK.

3. Click Execute to run the interpolation.

4. Change the names of the generated channels in the Data Portal to 
T_min_lin and T_max_lin.
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The Data Portal looks like this:

5. Select DIAdem VIEW.

6. Click New layout in the toolbar without saving the current view.

7. Open the Predefined screen partitioning function bar and select One 
channel table with all channels. 

The channel table lists the data of all the data channels in the Data Portal.

End of Exercise 9-5 
The Weather_2.tdm data file, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 9-6
Objective: Calculating Channels

In the following exercise you use the Calculator to calculate the average 
temperature and display the result with the minimum and maximum 
temperatures in the report from the last exercise.

1. Select DIAdem VIEW.

2. Click the Calculator in the toolbar.

3. Enter the following formula: 
Ch('AverageTemp'):= ('T_min_lin' + 'T_max_lin')/2

Click Calculate and Close the Calculator.

4. Select DIAdem REPORT.

5. Select the channels Date and AverageTemp in the Data Portal and drag 
and drop the channels into the axis system. 

6. Double-click the axis system to open the dialog box for curve and axis 
definition and select Blue as the Line color for the second curve.
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7. Click Curve param and select 0.7 as the Line width:

Click OK to close both the dialog boxes.
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The report looks like this:

End of Exercise 9-6 
The Weather_2.tdr layout and the Weather_3.tdm data file, which 
contain the solution for this exercise, are in the C:\Solutions\DIAdem 
Basics\ folder.
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Exercise 9-7
Objective: Adding New Data to the Existing Data

You load data from a second weather station and show the data in the same 
report. In the following exercise you use the Selective loading function to 
add channels from the Weather_4.tdm data file.

1. Select DIAdem NAVIGATOR.

2. Navigate to the Weather_4.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and double-click the file.

The following dialog box appears:

3. Click the + sign to open the data file, and select the channels Rain, 
T_6h, and Index.
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Click Load.

4. Click Save TDM file as.

Open the C:\Exercises\DIAdem Basics\ folder and save the data 
in the Data Portal as Weather_all.tdm.

The Data Portal looks like this:

End of Exercise 9-7 
The Weather_5.tdm data file, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 9-8
Objective: Multiple Axis Scaling

To show the correlation between several values with different physical units 
and value ranges, you can display the values in one axis system with several 
different y-axes.

In the following exercise you display the average temperature and the 
precipitation in one axis system with several y-axes.

1. Select DIAdem REPORT.

2. Reduce the existing axis system to make room for another axis system 
below it.

3. Open the 2D axis system function bar and select a Simple 2D axis 
system.

4. Drag open the axis system in the lower part of the worksheet.

5. Select the channels Date, AverageTemp, and Rain in the Data Portal 
and drag and drop the channels into the axis system. 

6. Double-click the new axis system to open the dialog box for axis 
definition and click Subaxes.

7. Click New axis to add another y-axis to the axis system:

Select Axis end as the y-axis Reference and 0 for the Offset as %. 

Click OK.

8. Assign the subaxis systems to the curves as shown in the following 
figure and select the display mode Bars for the channel pair 
Date,Rain.
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9. Click Axis definition to define a frame and horizontal and vertical grid 
lines for this axis system as shown in the following figure:
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10. Click Scaling and change the Tick style as shown in the following 
figure:

• Bottom for the x-axis

• Left for the x1/y1-axis

• Right for the x1/y2-axis

Click OK.

11. Click Numbers to specify the time format for the x-axis.

Suppress leading zeros in days and months. Display the month and the 
year in the second line.

Click OK to close all the dialog boxes.
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12. Double-click the left y-axis label to open the dialog box for axis labeling 
and change the text as shown in the following figure:

13. Select the X-1/Y-2 subaxis and alter the Y-axis text and the Distance 
from y-axis as shown in the following figure:

Click OK.
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14. Double-click the numbers on the right y-axis to open the dialog box for 
numeric display and select Right as the Position as shown in the 
following figure:

Click OK.

The report looks like this:

End of Exercise 9-8 
The Weather_3.tdr layout, which contains the solution for this exercise, 
is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 9-9
Objective: Highlighting Values

In the following exercise you label the temperatures measured at 6 o'clock 
with symbols.

1. Select DIAdem ANALYSIS.

2. Open the Basic mathematic functions function bar and select 
NoValues.

3. Set the dialog box parameters as shown in the following figure:

Click Execute.

4. Select DIAdem REPORT.

5. Select the channels Date1 and T_6h1 in the Data Portal and drag and 
drop the channels into the top axis system. 

6. Double-click the top axis system to open the dialog box for axis 
definition and select the Line and symbol display mode for the new 
curve Date1, T_6h1.
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7. Click Curve param and select the blank Line style.

Enter the following string as the Symbol Style:
Y() °C %(/Y125)
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DIAdem writes the respective y-value and the text °C at the 
measurement point. The marker %(/Y125) moves the symbol label in 
the y-direction, which means that the entry appears 125 % above the 
x-axis.

8. Click Symbol to enter the parameters as shown in the following figure:

Click OK in both dialog boxes.

9. Select DIAdem NAVIGATOR.

10. In the Data Portal, open the shortcut menu for the channel group 
Weather_1 and select New»Channel.

11. Enter Weather as the Name and select Text as the Display format. Set 
the Maximum channel length to 14.

Click OK.

12. Select DIAdem VIEW.

13. Open the Predefined screen partitioning function bar and select One 
channel table with all channels. 

The channel table lists the data of all the data channels in the Data Portal.
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14. Enter the following text lines in the Weather channel:
dry
drizzle
light rain
rain
cloudless
slightly overcast
lightly overcast
cloudy
overcast
heavy cloud
very cloudy
snowfall
fog
sunny

15. Select DIAdem REPORT.

16. Double-click the top axis system to open the dialog box for curve and 
axis definition.

17. Click Copy  to define a second entry with the channels Date1 and 
T_6h1:
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18. Click Curve param.

Enter the following string as the Symbol Style:
K(/kWeather /iIndex1) %(/Y130)

The K identifier refers to a text channel that DIAdem reads for curve 
labels. Enter the name of the text channel after the /k parameter and 
enter the name of the index channel after the /i parameter. The index 
channel specifies which text line DIAdem writes at which curve point.

The identifier %(/Y130) moves the symbol label in the y-direction, 
which means that the entry appears 130 % above the x-axis.

19. Click Symbol to enter the following parameters:

• Angle 90

• Position Right

• Font Arial

• Font size 2.5

Click OK to close all the dialog boxes.
© National Instruments Ireland Resources Limited 9-35 DIAdem Basics Course Manual



Lesson 9 Additional Exercises
The report looks like this:

End of Exercise 9-9 
The Weather_4.tdr layout and the Weather_6.tdm data file, which 
contain the solution for this exercise, are in the C:\Solutions\DIAdem 
Basics\ folder.
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Exercise 9-10
Objective: Integrating Text

In the following exercise you create a text field and a text object to describe 
the measurement.

1. Select DIAdem REPORT.

2. Open the Decorations function bar and select Rectangles.

3. Use the frame cursor to click the bottom of the report and drag open a 
frame for a text field at the bottom edge.

4. Double-click the rectangle to open the rectangle dialog box and check 
the parameters as shown in the following figure:

5. Click Position to specify the size and position of the rectangle with the 
following coordinates:

Click OK to close all the dialog boxes.

6. Open the Decorations function bar and select Text object.

7. Position the text object to the left in the text field and double-click the 
white rectangle to open the text object.
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8. Enter the text as shown in the following figure:

9. Select Background»Frame.

Click OK to close the text object.

10. Open the Decorations function bar again and select Text object.

11. Position the text object on the right in the text field and double-click the 
white rectangle to open the second text object.

12. Select Tables»Insert new table and set the dialog box parameters as 
shown in the following figure:

Click OK.

13. Mark all six table cells and select Tables»Configure cells.

14. Click the Frame field to enable internal lines, as shown in the following 
figure:

Click OK.

15. Click the table cells to enter the text as shown in the following figure: 
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Select DIAdem expression»New to enter the DataSetName variable 
for the filename and the CurrDate variable for the current date. If you 
click Display DIAdem expression, you see that DIAdem automatically 
encloses the variables in @ characters.

Click OK to close the text object.

16. Place the second text object on the right of the text field.

The report looks like this:

End of Exercise 9-10 
The Weather_5.tdr layout, which contains the solution for this exercise, 
is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 9-11
Objective: Integrating Graphics

In the following exercise you integrate a picture that illustrates the 
measurement results.

1. Select DIAdem REPORT.

2. Open the Graphics file function bar and select Load graphics.

Navigate to the Weather.wmf background graphic in the 
C:\Exercises\DIAdem Basics\ folder and load the graphic.

3. Position the graphic in the worksheet and adjust the size. 

4. Double-click the graphic to open the dialog box for the graphics file and 
change the parameters as shown in the following figure:

Click OK.

5. Click Redraw in the toolbar.

6. Click Save layout as. 

Navigate to the C:\Exercises\DIAdem Basics\ folder and save the 
report file as MyWeather.tdr.
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The report looks like this:

End of Exercise 9-11 
The Weather_6.tdr layout, which contains the solution for this exercise, 
is in the C:\Solutions\DIAdem Basics\ folder.
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C. Example III
The third example consists of two exercises. Both exercises demonstrate the 
advantages of storing data separately from layouts. 

You will carry out the following actions:

• Analyzing a data set with several layouts

• Display several data sets with the same layout
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Exercise 9-12
Objective: Using Several Layouts to Analyze a Data Set

In the following exercise you display measurements in different layouts. 
The first layout shows all the measurement data and the second layout 
displays an extract of the measured data.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the MixAndMatch1.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

4. Select DIAdem REPORT.

5. Click Load layout.

Navigate to the prepared layout MixAndMatch1.tdr in the 
C:\Exercises\DIAdem Basics\ folder and load the layout.

The report displays all the recorded data channels as shown in the 
following figure:
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6. Click Load layout.

Navigate to the prepared layout MixAndMatch2.tdr in the 
C:\Exercises\DIAdem Basics\ folder and load the layout.

The report displays the four measured pressure values in two separate 
axis systems. The selected x-extracts display the details more clearly.

7. Click Load layout.

Navigate to the prepared layout MixAndMatch3.tdr in the 
C:\Exercises\DIAdem Basics\ folder and load the layout.
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This report also displays the four strain gauge values in two separate 
axis systems. The selected x-extracts display the details more clearly.

End of Exercise 9-12 
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Exercise 9-13
Objective: Comparing Several Data Sets in One Layout

In the following exercise you compare the results of a series of 
measurements in one layout. This produces uniform reports that you can 
compare.

1. Take a look at the results of the strain gauge measurement from the last 
exercise. The characteristics in the bottom axis system change for each 
data set.

2. Select DIAdem NAVIGATOR.

3. Delete the data in the Data Portal without saving the data.

4. Navigate to the MixAndMatch2.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

5. Select DIAdem REPORT.

6. Click Redraw in the toolbar to load the data in the report.

The report looks like this:
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7. Select DIAdem NAVIGATOR.

8. Delete the data in the Data Portal without saving the data.

9. Navigate to the MixAndMatch3.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

10. Select DIAdem REPORT.

11. Click Redraw in the toolbar to load the data in the report.

The report looks like this:

In the previous layouts, the data channels in the Data Portal have a 
channel number reference. This setting was appropriate because the data 
channels were always at the same position in the Data Portal. If you do 
not know what structure your data set has, but you know that your 
channels always have the same channel names, use the channel name to 
reference the data channels. That is the default setting in DIAdem 
REPORT.
© National Instruments Ireland Resources Limited 9-47 DIAdem Basics Course Manual



Lesson 9 Additional Exercises
12. Select DIAdem NAVIGATOR.

13. Delete the data in the Data Portal without saving the data.

14. Navigate to the MixandMatch4.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

15. Select DIAdem REPORT.

16. Click Redraw in the toolbar to load the data in the report.

The report looks like this:

This report is different to the previous reports. The channels in the data 
set are in a different order. In the Data Portal, the first strain gauge 
channel, StrainGauge1, is now at position 7 instead of position 6. 
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To display the correct data in your report, you can either change the 
channel numbers in each axis system, or use the channel name to 
reference the data channels in the layout.

17. Select Settings»Layout parameters and select Name-oriented 
Channel reference.
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Click OK.

18. Double-click the top axis system to open the dialog box for curve and 
axis definition.

Select Strain Gauge 2 as the new y-channel for the Time, Event 
CountA curve. 
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Click OK.

19. Double-click the bottom axis system to open the dialog box for curve 
and axis definition.

Select Strain Gauge 3 as the new y-channel for the curve Time, 
Strain Gauge 2. 

Select Strain Gauge 4 as the new y-channel for the Time, Event 
CountB curve. 
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Click OK.

20. Click Save layout as. 

Open the C:\Exercises\DIAdem Basics\ folder and save the 
layout as MixAndMatch.tdr.

21. Now test the layout with the data sets MixAndMatch1.tdm,  
MixAndMatch2.tdm, and MixAndMatch3.tdm. Click Redraw in the 
DIAdem REPORT toolbar to display the loaded data.

End of Exercise 9-13 
The MixAndMatch4.tdr layout, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Notes
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Lesson 10
Loading External Data
Introduction
In this lesson you will learn how to load external data formats in DIAdem. 

You Will Learn About: 

A. DIAdem Data Organization

B. Loading External Data
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A. DIAdem Data Organization
TDM is the standard DIAdem 9 data format for reading external data and for 
saving data. The TDM data format structures the external data as a root, 
channel groups, and channels, and organizes the data accordingly in the 
Data Portal.

Figure 10-1 shows the structure of the TDM data format:

Figure 10-1.  TDM Data Format Structure

The root describes the data set.

The channel groups organize the channels and describe the group 
properties. You can assign any number of channels to a channel group. The 
number of channel groups you use is limited only by the amount of memory 
on your computer.

The channels contain the actual data and and describe the channel data. The 
channel properties include the channel name, channel unit, channel length, 
and channel origin, and certain characteristic values such as the minimum 
value and monotony.

You can add any number of custom properties to the root, the channel group, 
and the channel. DIAdem saves the custom properties with the data set. 

In the TDM format, DIAdem 9 saves the descriptions and the numeric data 
in different files that have the same filenames. DIAdem saves the description 
in a text file with the filename extension .tdm, and the numeric data in a 
binary file with the filename extension .tdx.

   Root

      Channelgroup_1

             Channel_1

                ....

             Channel_N

      Channelgroup_1

             ...../Channel_1

               ....

             ...../Channel_N

      .....

      Channelgroup_N

                 Channel_1

                   ....
DIAdem Basics Course Manual 10-2 ni.com



Lesson 10 Loading External Data
B. Loading External Data
DIAdem supports many file formats. You select the file type in the file 
selection dialog box shown in Figure 10-2. DIAdem uses the loading 
method that corresponds to the file type. According to the file type, a wizard 
appears where you set the format parameters that enable DIAdem to load the 
data in TDM format into the Data Portal.

Figure 10-2.  List of Formats in Dialog Box for Data Loading

DIAdem 9 supports the data formats mentioned in the section on Supported 
Data Storage in Lesson 3, Managing Data and the following formats:

• dBase

• DIF (Data Interchange Format)

• Wave

• ERG (data acquisition from BMW)

• HIS (data logger PR3000 from Philips)

• LAX (data acquisition devices from Medas)

• TEAC

To add file types to the list, you can create a DataPlugin or a GPI file filter 
for your special data format. A DataPlugin is based on a VBScript that reads 
data from files and loads the data into the Data Portal. At the DIAdem 
DataPlugin Web site you can download many prepared DataPlugins or 
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provide your DataPlugin for other users. To register your data format in 
DIAdem, select New DataPlugin in the shortcut menu of the data storage 
manager.

You also can register the GPI file filters from previous DIAdem versions to 
use the file filters. Refer to the ..\DIAdem\AddInfo folder and the 
National Instruments Web site for GPI file filters. To register GPI file filters 
you select Settings»Desktop parameters»GPI-DLL registration. 

Loading Data with the ASCII and Excel Wizards
When you load ASCII data and Excel data, the wizards analyze the data you 
want to import. Enter the import parameters in the wizard dialog boxes. The 
file data can be structured in any way.

The wizards have a preview so you can see how your settings will affect the 
import. You can undo the settings.

Both the ASCII Wizard and the Excel Wizard can read text and numeric 
data. DIAdem can store the text in a dynamic GPI variable or save the text 
to a file and create an associated index channel. You assign descriptive text 
such as channel names and units to the data set properties or channel 
properties.

You can save your settings in a configuration file (*.stp). To import 
another ASCII file with the same structure, specify this configuration file in 
the wizard.

Note You only can load an Excel file that is not already open in Excel. The Excel Wizard 
can read data from Excel 97 or later versions. 

Importing Binary Data
You use the DAT data format described in Lesson 3, Working with DAT 
Files to load binary data. To convert the data into the DAT format, you must 
create a header file that controls access to the external file. The user must be 
familiar with the DAT data organization. As soon as the header file exists, 
DIAdem can load the external file like a DAT file.

Select File»DAT files»Import via header to open the dialog box shown in 
Figure 10-3, and load, generate, save, edit, and delete the channel properties 
for importing binary data.
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Figure 10-3.  Dialog Box for Loading, Generating, and Saving Data Headers.

Load external data as follows:

1. Load an existing header file that describes a data structure similar to the 
data to be loaded. If necessary, you can delete single channel properties.

2. Open the Properties subdialog box to edit the properties of the data 
storage to be loaded.

3. Generate the channel properties associated with each channel of the 
external data that is to be read. Then Edit the generated channel 
properties. 

4. Save the created data set and channel properties. 

5. Click Execute to load the external data into the default group in the Data 
Portal.

When the properties are saved, DIAdem can read the data with the 
normal loading function.

Importing Data with the Report Wizard
You also can use the Report Wizard as another way to import data from all 
kinds of data sources.

As described in Lesson 2, Working with the Report Wizard, the Report 
Wizard page shown in Figure 10-4 opens by default when you launch 
DIAdem. While you are working in DIAdem, you can press <Ctrl-W> to 
open the Report Wizard.
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Figure 10-4.  Loading Data with the Report Wizard

In the first Report Wizard step you select your data. Open the data source in 
the top left of the dialog box and select one or more data sets in the file 
overview on the right. Click Finish to load the data into the Data Portal.

Define frequently-used data storages in the data storage manager of 
DIAdem NAVIGATOR to simplify access to these data. You can register the 
following data storages: Files, VI Logger, Citadel, SQL and AOP databases, 
and ATF and XML files.

Note When you load ASCII or Excel files, the Import Wizard appears. When you load 
data from SQL databases, you can load database tables into the Data Portal as channel 
groups.
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Exercise 10-1
Objective: Loading ASCII Block Data

In the following exercise you use the ASCII Import Wizard to create a data 
set description and load weather data saved in an ASCII file, and display the 
data in the REPORT layout from the last lesson.

The weather data is in blocks in an ASCII file:

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the Weather_7.asc data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

4. DIAdem opens the ASCII Import Wizard where you make the settings 
shown in the following figure:

ASCII File
Weather data from Aachen

Date;T_min;T_max;T_min_lin;T_max_lin;AverageTemp;Rain;T_6h;Index
-;°C;°C;°C;°C;°C;mm;°C;-

{February}
01.02.2003 -3 0 -5 1 -1.5 0.1 -3 0
02.02.2003 -4 -1 -6 0 -2.5 0 -4 0
03.02.2003 -2 6 -4 7 2 0.3 4 0
04.02.2003 1 6 -1 7 3.5 12 3 0
05.02.2003 1 7 -1 8 4 5 5 0
06.02.2003 5 8 3 9 6.5 0 6 0
07.02.2003 6 9 4 10 7.5 0 6 0
08.02.2003 1 13 1 14 7 0 2 0
09.02.2003 3 11 1 12 7 3 5 0
10.02.2003 4 7 2 8 5.5 2 4 0
11.02.2003 5 8 3 9 6.5 6 7 {Rain} 0
...
31.03.2003 6 13 3 14 9 0 6 0
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5. Click Next and set the parameters for the next step, as shown in the 
following figure:

6. Click Next to specify the destinations and the data set properties.

Click the individual entries in the Channel type column consecutively 
and specify the destination in the top section of the dialog box.

• Select Header comment 1 for the first row.

• Select Header comment 2 for the second row. 

• Select Name for the third row.

• Select Unit for the fourth row.
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7. Select the column that contains the time format. Select date/time and 
enter the format dd.mm.yyyy. 

Click Finish. DIAdem loads the data into the Data Portal.

8. Select DIAdem REPORT.

9. Click Redraw in the toolbar to display the loaded weather data in the 
current report. 

If you have not loaded the report layout from the last exercise, navigate 
to the Weather_6.tdr layout in the C:\Solutions\DIAdem 
Basics\ folder and load the layout.
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The report looks like this:

End of Exercise 10-1 
The Weather_7.tdm data file, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 10-2
Objective: Loading ASCII Channel Data

In the following exercise you use the Import via header function to create 
a data set description, load an ASCII file with four data channels, and 
display the file in a report.

The ASCII data are saved in columns. In the following figure, the first value 
of each channel is in bold:

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Select File»DAT files»Import via header.

Sample data set for
channel storage
1
2
3
4
5
6
45.48
51.9
53.4
44.8
51.7
48.02
470
1063
1600
2057
47.15
53.73
56.92
45.92
54.58
52.17
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4. Click Generate to create the channel properties as shown in the 
following figure:

5. Click Continue and set the parameters as shown in the following figure:

Click OK to create the four channel headers that DIAdem displays in the 
overview of the main dialog box.

6. Click Edit to change the channel properties of the third and fourth 
channels:

• Select the third channel and enter 4 as the No. of values.

• Select the fourth channel and enter 20 as the Position of this 
channel's first data point.
DIAdem Basics Course Manual 10-12 ni.com



Lesson 10 Loading External Data
Click Close. 

7. Click Properties to enter the data set properties.

Enter Gasoline as the Name in the first comment row, and enter 
ASCII Import as the Comment.

Click OK.

8. Click Save As.

Navigate to the C:\Exercises\DIAdem Basics\ folder and save the 
header file as Gasoline.dat. 

9. Click Execute to load the data from the Gasoline.asc ASCII file into 
the Data Portal according to the created header file.

10. Name the loaded channels in the Data Portal as shown in the following 
figure:

11. Assign the following units to the channels in the properties window:

• Amount: l

• Kilometers: km

• Price: Euro
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12. Select DIAdem REPORT.

13. Delete the current layout without saving the layout.

14. Open the 2D table function bar and select 2D table with horizontal 
and vertical separators.

15. Drag open the axis system in the middle of the worksheet.

16. Select the channels Kilometers, Amount, and Price in the Data 
Portal and drag and drop the data channels into the table.

17. Double-click the table to open the table definition dialog box.

18. Click New entry. Select Expression as the Data type and enter the 
following expression: 
@str(ChD(D2TabRow,Price)/ChD(D2TabRow,Amount),"d.dd")@

Click OK.

19. Click Down to move the expression to the last row and select 
Automatic maximum as the Table length.

20. Click Headers.
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21. Select Use individual table heading for the fourth column and enter the 
expressions as shown in the following figure:

22. Select the first column. 

Clear the Use individual table heading checkbox and enter the 
expressions as shown in the following figure:

Click OK to close all the dialog boxes.

23. Drag the separator underneath the heading downwards to enlarge the 
table heading.
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The report looks like this:

End of Exercise 10-2 
The Gasoline.tdr layout and the Gasoline.tdm data file, which 
contain the solution for this exercise, are in the C:\Solutions\DIAdem 
Basics\ folder.
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Exercise 10-3
Objective: Using the Report Wizard to Load Data

In the following exercise you define the SQL database SQL_Example.mdb 
as the new data source in the data storage manager. You then use the Report 
Wizard to load data from this SQL database and display the data in a report.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Click Change data storage in the toolbar.

4. Double-click New data storage under SQL. Enter Training as the 
new data storage name.

Press <Return>.
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5. Load the data storage in the properties dialog box.

Open the C:\Exercises\DIAdem Basics\ folder and load the 
SQL_Example.mdb file.

Select Save password to open the data storage next time without 
entering the password.

Click OK.

DIAdem opens the new data storage in the NAVIGATOR panel.

Click + to display the data.

6. Press <Ctrl-W> to start the Report Wizard.

7. Select the SQL: Training data source and select the 
Tab_Weather_Info table in the tree.
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8. Click Next and specify the data you want to display as shown in the 
following figure:

9. Click Next and select Y-axes to specify the layout:
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Click Finish to display the data in DIAdem REPORT.

The report looks like this:

End of Exercise 10-3 
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Exercise 10-4
Objective: Loading Excel Data

In the following exercise you use the Excel Import Wizard to analyze an 
Excel file and load the data into the Data Portal.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Click Change data storage in the toolbar.

4. Navigate to Files»My DIAdem 9.1.

5. Navigate to the Excel_Example.xls data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

6. DIAdem opens the Excel Import Wizard where you make the settings 
shown in the following figure:

7. Click Next to specify the destination and the data format.

Click the individual entries in the Channel type column consecutively 
and specify the destination in the top section of the dialog box.

• Select Name for the first row.

• Select Ignore for the second row.
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8. Select the last column that contains the time format. Select Date/Time. 

Mark the two empty columns to the left of the time data and select 
Ignore. 

Click Finish.

9. Navigate to the Excel_Example.xls data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal again.

10. DIAdem opens the Excel Import Wizard where you select Transpose in 
the first dialog box.
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Click Next.

11. Click Reset and then click OK to delete all the previous dialog box 
settings.

Mark all the columns and select the data format Ignore. 

Mark the second column and select the data format Numeric.

Mark the last three rows of the second column and select Ignore as the 
destination. 
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Click Finish. DIAdem creates a second channel group for the new 
channel.

12. Select both channel groups in the Data Portal and drag and drop the 
selected channel groups to the tree view of the MyTraining data 
storage. Enter the filename My3D_data.tdm and click Save. 

13. Select DIAdem REPORT.

14. Delete the current layout without saving the layout.

15. Open the 3D axis system function bar and select a Simple 3D axis 
system.

16. Drag open the 3D axis system in the middle of the worksheet.

17. Double-click the 3D axis system to open the dialog box for curve and 
axis definition.

18. Click New entry and specify waterfall display for the channels:

• Select [1]/TimeStamp as the x-channel.
• Select [2]/Channel 2 as the y-channel.
• Select [1]/Band 1 to [1]/Band 20 as the z-matrix.

• Select Waterfall as the type of curve. 

• Select Glob. palette 1 as the Color. 

Click OK.
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19. Click Axis definition.  Enter 210 as the Rotation around z-axis. Click 
OK to close all the dialog boxes.

The report looks like this:

End of Exercise 10-4 
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Exercise 10-5
Objective: Loading the Data from a VI Logger Database

In a musical experiment, three frequencies are selected to reproduce a chord. 
The NI VI Logger software automatically saves the data in a Citadel 
database.

In the following exercise you register this database in DIAdem as a new data 
storage and load the data in the Data Portal. In DIAdem VIEW you specify 
the transition ranges for the three notes to delete the notes. You save the 
remaining signal ranges in separate channels and calculate the main 
frequencies.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Click Change data storage in the toolbar.

4. Double-click VI Logger»New data storage and enter Demo Box 
Sweep.
DIAdem Basics Course Manual 10-26 ni.com



Lesson 10 Loading External Data
5. Press <Return>. Specify the properties of the new data storage as 
follows: 

Select Folder and open the C:\Exercises\DIAdem Basics\Vi 
Logger Demo Box Sweep\ folder. 

Click OK. 

6. DIAdem opens the new data storage in the NAVIGATOR panel.
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7. Click + consecutively until DIAdem displays the channels.

8. Select the bottom test and drag and drop the test to the Data Portal.

9. Select DIAdem VIEW.

10. Delete the current view without saving the layout.

11. Open the Regular screen partitioning function bar and select Three 
areas.

12. Select four channels in the Data Portal and drag and drop the channels 
into the top area. 
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Select the 2D axis system display type.

13. Select the channels Time, Square Wave and Sine Wave in the Data 
Portal and drag and drop the three channels to the middle area.

Select the 2D axis system display type.

The oscillation periods of the signals are short, so DIAdem displays a 
continuous colored surface. In this view, you cannot see that the 
oscillation time varies during the measurement, because the oscillations 
are all 5 seconds shorter.

14. Click Band cursor in the toolbar.

15. Click Zoom, dynamic in the middle axis system to enable scrolling.

The middle axis system is to function as the zoom window for the top 
axis system. Set the band cursor in the top axis system so narrow that 
you can recognize the oscillations in the middle axis system.

16. Click the top axis system and use the band cursor to search for a range 
between 5 and 6 where the oscillation periods change for the first time.
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17. Press <Shift> and click Set flags in the toolbar for the middle axis 
system. DIAdem selects all curves in the selected axis system area. 

18. Click Flags: Delete data points in the toolbar of the middle axis system 
to delete the selected curve section.

The display in the top axis system now has a gap.

19. Move the right edge of the band cursor in the top axis system to the axis 
origin.

20. Click Global flag reset in the toolbar.

21. Press <Shift> and click Set flags in the toolbar for the middle axis 
system to select the first signal section. 
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22. Click Flags: Copy data points in the toolbar of the middle axis system 
to copy the selected curve section.

You see four new channels in the Data Portal:

23. Select DIAdem ANALYSIS.

24. Open the Signal analysis functions function bar and select FFT (one 
time signal).

Select XCopy_time as the time channel.
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25. Click the three points to the right of Signal channels and select the two 
signal channels YCopy_SquareWave and YCopy_SineWave.

Click OK. 

26. Click Execute to calculate the FFT. The FFT creates three result 
channels in the Data Portal.

27. Select DIAdem VIEW.

28. Select the three result channels of the FFT calculation in the Data Portal 
and drag and drop the selected channels to the bottom area.

Select the 2D axis system display type.
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29. Click Global flag reset in the toolbar.

30. Repeat steps 16 to 29 to describe the next transition range for the 
oscillation periods between 11 and 13.

The view looks like this:

End of Exercise 10-5 
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Summary, Tips, and Tricks

• TDM is the standard DIAdem 9 data format for reading external data 
and for saving data. The TDM data format structures the external data as 
a root, channel groups, and channels, and organizes the data accordingly 
in the Data Portal.

• DIAdem supports many external formats. According to the file type, a 
wizard appears where you set the external format parameters that enable 
DIAdem to load the data in TDM format into the Data Portal. 

• You use the DAT data format to load binary data. To convert the data into 
the DAT format, you must create a header file that controls access to the 
external file.

• You also can use the Report Wizard as another way to import data from 
all kinds of data sources.
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Notes
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Lesson 11
3D Data Display
Introduction
In this lesson you will learn how DIAdem organizes and displays 3D data. 

You Will Learn About: 

A. Organizing 3D Data

B. Displaying 3D Data
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A. Organizing 3D Data
DIAdem works with single channels. For 3D display, DIAdem reads the 
data as a matrix or as a triple. Figure 11-1 shows how DIAdem organizes 
data in triples and in matrices. 

Figure 11-1.  DIAdem Reads 3D Data in Triples or Matrices

A value triple consists of three data channels: one data channel each for the 
x, y, and z-values. All data channels should be the same length, otherwise 
the 3D display is limited to the length of the shortest data channel.

A matrix consists of an x-channel, a y-channel, and several z-channels. 
There must be as many z-channels as there are values in the y-channel. The 
z-channels must be the same length as the x-channel. The z-channels must 
be in consecutive order in the Data Portal. If the z-channels are not the same 
length as the x-channel, DIAdem uses a matrix that is shortened accordingly 
for 3D display.

You can use the basic 3D functions in DIAdem ANALYSIS to convert data 
channels into a matrix or a value triple. 

Triple Structure Matrix Structure
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DIAdem combines the data channels of the matrix in Table 11-1 into the 
three data channels of the triple in Table 11-2:

Table 11-1.  Matrix Structure

X Y Z1 Z2 Z3

1 5 8 12 16

2 6 9 13 17

3 7 10 14 18

4 11 15 19

Table 11-2.  Triple Structure

X Y Z

1 5 8

2 5 9

3 5 10

4 5 11

1 6 12

2 6 13

3 6 14

4 6 15

1 7 16

2 7 17

3 7 18

4 7 19
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DIAdem expands the data channels of the triple in Table 11-3 into the data 
channels of the matrix in Table 11-4:

 

Table 11-3.  Triple Structure

X Y Z

1 5 8

2 6 9

3 6 10

4 7 11

Table 11-4.  Matrix Structure

X Y Z1 Z2 Z3

1 5 8 NoValue NoValue

2 6 NoValue 9 NoValue

3 7 NoValue 10 NoValue

4 NoValue NoValue 11
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B. Displaying 3D Data
You display 3D data graphically in 3D axis systems and numerically in 3D 
tables.

The 3D axis system function bar has various definitions for 3D axis 
systems, for example, with and without grid lines. Click the template you 
want to display in the worksheet. You can position the 3D axis system 
anywhere and adjust the size. Double-click the axis system to modify the 
display and the data assignment.

Note The display modes in the 3D axis system depend on the data structure. DIAdem 
requires the data as a matrix for the display modes Surface, Waterfall, Bars, and 2D 
matrix. For the display modes Spikes and Symbol, DIAdem can use the data as 
matrices and as triples.

The 3D table function bar has various definitions for 3D tables. Use 3D 
tables for numeric display of the matrix structure of 3D data. To display 3D 
data as triples, list the three data channels in a 2D table. Each line has a 
triple.
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Exercise 11-1
Objective: Displaying Data as Triples

In the following exercise you use a script to create data triples that you 
display in various modes in a 3D axis system. You display triple data in the 
modes 3D curve, Spikes and Symbol.

1. Select DIAdem SCRIPT.

2. Click Open file. 

Navigate to the Helix.vbs script in the C:\Exercises\DIAdem 
Basics\ folder and load the script :

This script generates data triples for helixes. Helixes are spiral-shaped 
curves. First the script creates the Phi channel with the angle values and 
calculates from these values the x-values and the y-values of the two 
helixes, and then calculates the associated z-values.

The data of the first helix are in the data channels X1, Y1, and Z, and the 
data of the second helix are in the data channels X2, Y2, and Z. The 
second helix is phase-shifted 180 degrees from the first helix.

3. Click Run script in the toolbar.

4. Select DIAdem REPORT.

5. Delete the current layout without saving the layout.

6. Open the 3D axis system function bar and select a Simple 3D axis 
system.

7. Drag open the axis system to cover the entire worksheet.

8. Double-click the 3D axis system to open the dialog box for curve and 
axis definition.
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9. Click New entry and make the following settings for the first helix: 

• Channels: x1, y1, z

• Display mode: 3D curve

Click OK.

10. Click New entry and make the following settings for the second helix:

• Channels: x2, y2, z

• Display mode: 3D curve 

Click OK.

Click OK.
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The report looks like this:

11. Select DIAdem SCRIPT.

12. To regenerate the data for the helixes, change the value of the NumLoops 
constant in the Helix.vbs script as shown in the following figure:
NumLoops = 0.5
....

13. At the end of the script, enter the instruction for refreshing the report:
...
Call PicUpdate()

14. Click Run script in the toolbar.
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When the script runs through the first time, the report looks like this:

15. Double-click the 3D axis system to open the dialog box for curve and 
axis definition and change the display mode for both helixes from 3D 
curve to Spikes.

Note Make sure that the Structure is always set as Triple.

Click OK. 
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The report looks like this:

16. Select DIAdem SCRIPT.

17. To regenerate the data for the helixes, change the value of the 
NumPoints constant in the Helix.vbs script as shown in the 
following figure:
NumPoints = 30
...

18. Click Run script in the toolbar.

DIAdem creates new channel data and then displays the data in the 
report.

19. Double-click the 3D axis system to open the dialog box for curve and 
axis definition and change the display mode for the first helix from 
Spikes to Symbol.

Note Make sure that the Structure is always set as Triple.
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20. Click Curve param and enter the symbol as shown in the following 
figure:

21. Click Symbol and enter d.dd as the format:

Click OK in both dialog boxes.
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22. Repeat steps 19 to 21 for the second helix.

The report looks like this:

End of Exercise 11-1 
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Exercise 11-2
Objective: Displaying Data as a Matrix

In the following exercise you import an Excel file with the measured power 
and voltage curves of a semiconductor at six different temperatures. You 
display the temperature-related power and voltage curves in a 3D axis 
system. You use Surface, Waterfall, Bars, 2D matrix, Spikes and 
Symbol as the display modes for matrices.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Click Change data storage in the toolbar.

4. Navigate to Files»My DIAdem 9.1 and double-click.

5. Navigate to the Semiconductor.xls data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

DIAdem opens the Excel Import Wizard. 

6. Check the default settings in the Excel Wizard dialog box as shown in 
the following figure: 

7. Click Next to specify the destination and the data format.
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8. First click Reset and then click OK to delete all settings.

9. Click the individual entries in the Channel type column consecutively 
and specify the destination in the top section of the dialog box.

• Select Name for the first row.

• Select Comment for the second row.

• Select Unit for the third row.

Click Finish.

10. In the Data Portal, open the shortcut menu for the channel group 
Semiconductor, and select New»Channel.

11. Enter Temperature as the Name.

Click OK.

12. Move the Temperature channel to the second position in the Data 
Portal.
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13. Select DIAdem VIEW.

14. Open the Predefined screen partitioning function bar and select One 
channel table with all channels.

15. Enter C as the unit for the Temperature channel in the channel table 
and enter the channel values -50, -25, 0, 25, 50, and 75.

16. Select DIAdem REPORT.

17. Delete the current layout without saving the layout.

18. Open the 3D axis system function bar and select a Simple 3D axis 
system.

19. Drag open the axis system to cover the entire worksheet. 

20. Double-click the 3D axis system to open the dialog box for curve and 
axis definition.

21. Click New entry and make the following settings for surface display: 

• Channels: Vcc, Temperature, Current -50°C

• Display mode: Surface

Click OK.
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Click OK.

The report looks like this:

22. Double-click the 3D axis system to open the dialog box for curve and 
axis definition.
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23. Click Axis definition and modify the projection angles as shown in the 
following figure:

Click OK to close all the dialog boxes.

The report looks like this:

24. Double-click the 3D axis system to open the dialog box for curve and 
axis definition and change the display mode from Surface to 
Waterfall.

Click OK.
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The report looks like this:

25. Double-click the 3D axis system to open the dialog box for curve and 
axis definition and change the display mode from Waterfall to Bars.

Click OK.

The report looks like this:
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26. Double-click the 3D axis system to open the dialog box for curve and 
axis definition and change the display mode from Bars to 2D matrix.

Click OK.

The report looks like this:

In this display mode the width of the bar is proportional to its height.

27. Double-click the 3D axis system to open the dialog box for curve and 
axis definition and change the display mode from 2D matrix to 
Spikes. 

Note Make sure that the Structure is set as Matrix.

Click OK.
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The report looks like this:

28. Double-click the 3D axis system to open the dialog box for curve and 
axis definition and change the display mode from Spikes to Symbol.

Note Make sure that the Structure is set as Matrix.

29. Click Curve param and select the symbol type as shown in the 
following figure:

Click OK to close all the dialog boxes.
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The report looks like this:

In this display mode, DIAdem displays the z-value at each curve point.

30. Click Save layout as. 

Open the C:\Exercises\DIAdem Basics\ folder and save the 
layout as MyTripleChart.tdr.

31. Select DIAdem NAVIGATOR.

32. Select the Semiconductor channel group in the Data Portal and drag 
and drop the selected channel group to the MyTraining data storage 
tree. Enter the filename 3D_Data_1.tdm and click Save.

End of Exercise 11-2 
The D3Data.tdm data set, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Additional Exercise
If you have time, complete the following exercise.

1. Select DIAdem SCRIPT. Navigate to the Helix_Solution.vbs 
script in the C:\Exercises\DIAdem Basics\ folder and load the 
script. The script completes the steps in Exercise 11-1 and shows the 
various alternatives for displaying 3D triple data. Have a closer look at 
the script to see how it was programmed.

2. Navigate to the Semiconductor_solution.vbs script in the 
C:\Exercises\DIAdem Basics\ folder and load the script. The 
script completes the steps in Exercise 11-2 and shows the various 
alternatives for displaying 3D matrix data. Have a closer look at the 
script to see how it was programmed.
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Exercise 11-3
Objective: Displaying Measured Data Three-Dimensionally

In the following exercise you load the data file D3Display_1.tdm with the 
vehicle data rpm, torque, and temperature. In a 3D axis system you display 
the temperatures in relation to the rpm and the torque.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal.

3. Navigate to the D3Display_1.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

4. Select DIAdem REPORT.

5. Delete the existing layout.

6. Select Settings»Layout parameters and select Number-oriented as 
the Channel reference.

Click OK.

7. Open the 3D axis system function bar and select a Simple 3D axis 
system.
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8. Drag open the axis system to cover the entire worksheet.

9. Double-click the 3D axis system to open the dialog box for curve and 
axis definition.

10. Click New entry and define a spike display as shown in the following 
figure: 

Click OK to close all the dialog boxes.

The report looks like this:

End of Exercise 11-3 
The D3Display_1.tdr layout, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 11-4
Objective: Modifying the Angle

In the following exercise you modify the rotation angle and the inclination 
for a different view of an axis system.

1. Select DIAdem REPORT.

2. Select the axis system in the report from the last exercise. Reduce the 
size of the axis system. 

3. Select Copy in the shortcut menu for the axis system.

4. Then select Paste in the shortcut menu.

5. Position the copied axis system to the right of the first axis system.

6. Double-click the copied axis system to open the dialog box for curve 
and axis definition. Change the display mode of the original data to 
Symbol and select triple as the structure: 

7. Click Curve param and enter * as the symbol.
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Click OK.

8. Click Axis definition and modify the projection angles as shown in the 
following figure:

9. Click Numbers and select Determine rel. position automatically for 
all three axes.

Click OK to close all the dialog boxes.
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The report looks like this:

End of Exercise 11-4 
The D3Display_2.tdr layout, which contains the solution for this 
exercise, is in the C:\Solutions\DIAdem Basics\ folder.
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Exercise 11-5
Objective: Mathematical Analysis - 3D Envelope Curves

In the following exercise you calculate an envelope curve that describes the 
boundary range of the measured data. The temperature data in the Data 
Portal are not equidistant. However, equidistant data is required for surface 
display.

1. Select DIAdem ANALYSIS.

2. Open the 3D Surface functions function bar and select Envelope 
curves.

3. Check the dialog box parameters as shown in the following figure:

Click Execute to calculate the envelope curve.

4. Select DIAdem REPORT.

5. Double-click the left axis system to open the dialog box for curve and 
axis definition.

6. Click New entry to define the envelope curve as shown in the following 
figure:

Click OK.
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7. Click OK.

8. Repeat steps 5 and 6 for the axis system on the right. 

The report looks like this:

End of Exercise 11-5 
The D3Display_3.tdr layout and the D3Display_2.tdm data file, 
which contain the solution for this exercise, are in the 
C:\Solutions\DIAdem Basics\ folder.
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Exercise 11-6
Objective: Mathematical Analysis - 3D Interpolation

In the following exercise you interpolate a value triple and the result is a 
regular matrix. You then display the matrix as a surface in a new axis system.

1. Select DIAdem ANALYSIS.

2. Open the 3D surface functions function bar and select Interpolation of 
a matrix.

3. Set the dialog box parameters as shown in the following figure:

4. Click Method to select the interpolation method as shown in the 
following figure:

Click OK.

5. Click Output points to specify a grid with 20*25 evaluation points:

• Select X-values and Calculate evaluation points. Enter 20.

• Select Y-values and Calculate evaluation points. Enter 25.
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Click OK.

6. Click Analysis to set the evaluation mode as shown in the following 
figure:

Click OK.

7. Click Execute to calculate the interpolation.

8. Select DIAdem REPORT.

9. Open the 3D axis system function bar and select a Simple 3D axis 
system.

10. Drag open and position the axis system at the bottom of the worksheet.

11. Double-click the new 3D axis system to open the dialog box for curve 
and axis definition.

12. Click New entry and define a surface display as shown in the following 
figure:
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Click OK to close all the dialog boxes.

13. Position the axis system in the worksheet as shown at the end of the 
exercise. 

The report looks like this:

End of Exercise 11-6 
The D3Display_4.tdr layout and the D3Display_3.tdm data file, 
which contain the solution for this exercise, are in the 
C:\Solutions\DIAdem Basics\ folder.
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Exercise 11-7
Objective: Mathematical Analysis - 3D Contours

In the following exercise you create a channel with temperature values. You 
then calculate the contours for these temperatures, to display the 
temperature distribution as a characteristic curve field.

1. In the Data Portal, open the shortcut menu for the channel group 
D3Display_1, and select New»Channel. 

2. Enter Isolines as the name.

Click OK.

3. Select DIAdem VIEW.

4. Open the Predefined screen partitioning function bar and select One 
channel table with all channels.

The channel table displays the contents of all the channels in the Data 
Portal. 

5. In the channel table, enter the channel values 10, 20, 30, 40, 50, 
60, 70 for the new Isolines channel:

6. Select DIAdem ANALYSIS.

7. Open the 3D surface functions function bar and select Contour 
calculation.
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8. Set the dialog box parameters as shown in the following figure:

9. Click Bound.curve and check the settings.

Click OK.

10. Click Execute to calculate the contour.

11. Select DIAdem REPORT.

12. Double-click the upper right 3D axis system to open the dialog box for 
curve and axis definition.

13. Click New entry and define the isolines as shown in the following 
figure:
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Click OK to close all the dialog boxes.

The report looks like this:

End of Exercise 11-7 
The D3Display_5.tdr layout and the D3Display_4.tdm data file, 
which contain the solution for this exercise, are in the 
C:\Solutions\DIAdem Basics\ folder.
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Summary, Tips, and Tricks

• For 3D display, DIAdem reads the data as a matrix or as a triple. A value 
triple consists of three data channels: one data channel each for the x, y, 
and z-values. A matrix consists of an x-channel, a y-channel, and several 
z-channels.

• The display mode in the 3D axis system depends on the data structure. 
DIAdem requires the data as a matrix for the display modes Surface, 
Waterfall, Bars and 2D matrix, and DIAdem can use the data as 
matrices and triples in the display modes Spikes and Symbol.

• Use 3D tables for numeric display of the matrix structure of 3D data. To 
display 3D data as triples, list the three data channels in a 2D table. Each 
line has a triple.
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Notes
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Appendix A
Evaluating Crash Data
Introduction
In this lesson you will learn how to evaluate data from crash tests.

DIAdem contains many basic mathematical functions for standardized 
crash test evaluation, such as integration, differentiation, statistics functions, 
and digital filtering. DIAdem also provides the Calculator for free 
calculation of resultant acceleration values. The DIAdem Crash Analysis 
Toolset includes a number of special crash analysis functions. 

To document and present the results, use the extensive graphic display 
functions in DIAdem REPORT.

You Will Learn About:

A. Working with the Crash Analysis Functions
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A. Working with the Crash Analysis Functions
The functions in the Crash Analysis Toolset adhere to the calculation 
regulations in the SAE, ISO, and NHTSA specifications.

Resultant
This function calculates the resultant acceleration from the acceleration 
values in the x, y and z-directions.

Filtering
This function filters a signal with specific limit frequencies and tolerance 
bands for the lowpasses: CFC_60, CFC_180, CFC_600, CFC_1000, 
FIR_100, CFC_Free. DIAdem continues the signal to be filtered at the start 
and at the end mirror-inverted to the first and last channel value, to eliminate 
the transient response of the filter.

HIC
The HIC (Head Injury Criterion) value is a normed maximum integral value 
of the head acceleration. The function calculates either the value HIC, 
HIC36 or HIC15, and the start and end times of the interval in which 
DIAdem determines the HIC. DIAdem requires a time channel and the 
associated acceleration values for the calculation. DIAdem uses the 
resultant from the head acceleration in the x, y and z-directions as the 
acceleration.

HPC
The HPC value (Head Performance Criterion) is a normed maximum 
integral value of the head acceleration. The function calculates either the 
value HPC, HPC36 or HPC15, and the start and end times of the interval in 
which DIAdem determines the HPC. DIAdem requires a time channel and 
the associated acceleration values for the calculation. DIAdem uses the 
resultant from the head acceleration in the x, y and z-directions as the 
acceleration.

HCD
The HCD (Head Contact Duration) value is a normed maximum integral 
value of the head acceleration. The HCD formula is the same as the HIC 
formula except that DIAdem only uses the contact intervals to determine the 
HCD value. For the calculation DIAdem requires a time channel with linear 
partitioning and an acceleration channel.

X ms
This function calculates the maximum acceleration value that was exceeded 
for at least x milliseconds during the crash test. X is a free parameter. 
X=3ms is usually used (3ms value). DIAdem saves the start time of the 
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X ms value as the result. DIAdem requires a time channel and the associated 
acceleration values for the calculation. 

X g
This function calculates the total time that the acceleration signal exceeded 
the specified value X[g] (g is gravity acceleration). DIAdem can specify this 
value either as a whole or in parts. For the calculation DIAdem requires a 
time channel with linear partitioning and an acceleration channel.

VC
This function calculates an injury criterion for the chest area (Viscous 
Criterion). For the calculation DIAdem requires the measured chest 
deformation signal of the chest and the associated time channel. The 
deformation constant for the dummy type is included in the calculation.

TTI
This function calculates an injury criterion for the chest area with side 
impact (Thorax Trauma Index). For the calculation DIAdem requires the 
acceleration values of the upper and lower ribs and the acceleration values 
of the spine.

TI
This function calculates an injury criterion for the lower leg area (Tibia 
Index). For the calculation DIAdem requires one channel each with the 
bending moments around the x and y-axes, and the axial force of pressure 
in the z-direction. The input channels must be filtered with CFC600.

Time At Level
This function calculates the maximum period of time during which a signal 
exceeds a specific lower threshold. For the calculation, DIAdem requires the 
signal to be examined, the associated time signal, and the positive and 
negative limit curves.

NIC
This function calculates an injury criterion for the neck area (Neck Injury 
Criterion). For the calculation DIAdem requires a time channel and a 
channel with the forces. The input channels must be filtered with CFC600.

NIC Rear Impact
This function calculates an injury criterion for the neck in rear impact (Neck 
Injury Criterion). For the calculation DIAdem requires the channels with the 
acceleration values of the first spinal vertebra and of the first chest vertebra, 
and the time channel.
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NIJ
The NIJ value (Normalized Neck Injury Criterion) includes the four neck 
criteria, NTE (lTension Extension), NTF (Tension Flexion), NCE 
(Compression Extension), and NCF (Compression Flexion). For the 
calculation DIAdem requires the axial forces in z-direction at the head/neck 
point, the bending moment in y-direction at the top of the neck, and the 
associated time channel.

FFC
This function calculates the force on the thigh (Femur Force Criterion). For 
the calculation DIAdem requires the axial pressure force and the associated 
time channel. The input channels must be filtered with CFC600.

PulseLimit
This function checks whether an acceleration is within a specific corridor. 
DIAdem requires the acceleration values, the associated time channel, and 
the channels that specify the upper and lower limit curves.

Acomp
Calculates the average acceleration during the compression phase (Average 
Accelaration During Compression Phase). For the calculation DIAdem 
requires the unfiltered acceleration values and the associated time channel.

MinMax
This function calculates the times of the first minimum and the first 
maximum in the specified data channel.

Time Area Copy
This function copies a specific time range and the associated channel values 
into new channels.

Crash Analysis Results
DIAdem stores the results of the various crash functions in new channels in 
the Data Portal or in variables. You can display the variables in message 
boxes, use the variables in formulas, or document the variables in tables and 
text in your report.

For the complete evaluation of a crash test, you can create scripts that run 
the calculations automatically and generate a standardized report. You also 
can use scripts to automate dummy calibrations and limit value checks.
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Select Examples»Viewing, Presenting, Automating»User 
Templates»DIAdem ANALYSIS in the contents tree of the DIAdem help 
for two examples of crash test data evaluation that also create reports:

• CRASH Analysis

This example evaluates the horizontal, vertical, and lateral head 
acceleration measured on a dummy. The report shows the graphic of the 
head acceleration and lists the values for the HIC, HIC15, and HIC36 
value, and the 3ms acceleration.

• Crash Evaluation Based on the MME Standard

This example evaluates measurement data from a vehicle safety test 
based on the ISO MME standard (Multimedia Data Exchange Format) 
and creates a report. The example loads an MME data set, evaluates the 
frontal or side impact tests, displays the result preview as a graphic and 
a list of the characteristic values, and creates reports for PowerPoint and 
Excel.
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Exercise A-1 
Objective: Eliminating an Offset in Crash Values

A crash test records signals with offset. You eliminate this offset to ensure 
that the data is processed correctly.

In the following exercise you copy the first 50 measured values of the x, y, 
and z-acceleration into new channels. You calculate the mean values of 
these data channels to determine and subtract the respective offset.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the Crash_1.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal.

4. In the Data Portal, open the shortcut menu for the channel group 
Crash_1 and select New»Channel.

Set the parameters as shown in the following figure to specify three new 
channels:

Click OK.

5. Select DIAdem VIEW.

6. Open the Predefined screen partitioning function bar and select One 
channel table with all channels. 

The channel table lists the data of all the data channels in the Data Portal.

7. Click A_head_hor in the first table cell of the second channel and 
select all the data in the channels A_head_hor, A_head_ver, and 
A_head_lat, up to table cell 50 of the A_head_lat channel. 

8. Select Copy in the shortcut menu. 
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9. Click the first table cell in the new Channel_01 channel and select 
Paste in the shortcut menu. 

10. Select DIAdem ANALYSIS.

11. Open the Statistics functions function bar and select Statistical 
characteristic values to calculate the arithmetic mean.

12. Click the three points next to Channels to select the channels shown in 
the following figure.

Click OK.

13. Click All off and set the dialog box parameters as shown in the following 
figure:

Click Execute.

14. Click the Calculator in the toolbar.
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15. Enter the following formula in the entry field:
Ch('A_head_hor_noff'):='A_head_hor'-ChD(1,'Arithm_mean')

Click Calculate.

16. Calculate the following formulas in the same way:
Ch('A_head_ver_noff'):='A_head_ver'-ChD(2,'Arithm_mean')

Ch('A_head_lat_noff'):='A_head_lat'-ChD(3,'Arithm_mean')

Close the Calculator.

17. Select DIAdem REPORT.

18. Click Load layout without saving the layout.

19. Navigate to the Crash_1.tdr layout in the C:\Exercises\DIAdem 
Basics\ folder and load the prepared layout.
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The report looks like this:

End of Exercise A-1 
The Crash_1.vbs script, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise A-2 
Objective: Evaluating Dummy-Head Acceleration

In the following exercise you use a CFC 1000 filter to filter head 
acceleration measured for a dummy head the in x, y, and z-directions 
(horizontal, vertical, lateral). You then determine the resultant and calculate 
the HIC, the 3 ms value, and the maximum value.

1. Select DIAdem ANALYSIS.

2. Open the Crash analysis functions function bar and select Filtering to 
filter the A_head_hor_noff channel with the CFC 1000 lowpass filter 
as shown in the following figure:

Click Execute.

3. Repeat step 2 with the channels A_head_ver_noff and 
A_head_lat_noff.

4. Click the Calculator in the toolbar.

5. Enter the following variable assignment in the entry field:
CN(12):= 'A_head_hor_f1000'

Click Calculate.
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6. Repeat step 5 for channels 13 and 14:
CN(13):= 'A_head_ver_f1000'

CN(14):= 'A_head_lat_f1000'

Close the Calculator.

7. Open the Crash analysis functions function bar and select Resultant.

Set the channels as shown in the following figure:

Click Execute.

8. Open the Crash analysis functions function bar and select Head 
Injury Criterion to calculate the HIC value. Set the parameters as 
shown below:

Click Execute.

9. Open the Crash analysis functions function bar and select x-ms 
calculation to calculate the 3 ms value. Set the parameters as shown 
below:

Click Execute.
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10. Open the Basic mathematic functions function bar and select Peak 
search to determine the maximum value and the associated time value.

Click Execute.

11. Select DIAdem REPORT.

12. Click Load layout without saving the current layout.

Navigate to the prepared layout Crash_2.tdr in the 
C:\Exercises\DIAdem Basics\ folder and load the layout.

13. Select the result channels X_Peak and Y_Peak in the Data Portal and 
drag and drop the channels into the bottom axis system.  

14. Double-click the axis system to open the dialog box for curve and axis 
definition.

Select the Line and symbol display mode for the channel pair 
X_Peak and Y_Peak.
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15. Click Curve param and select the blank Line style. Specify the 
Marker and the Symbol as shown in the following figure:
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16. Click Symbol and set the parameters as shown in the following figure:

Click OK to close all the dialog boxes.

17. Double-click the prepared text in the text field to open the dialog box for 
text parameters and check the settings:
3 ms Value: @Str(XmsAcceleration,'d.d')@ at 
@str(XmsTimeBegin,'d.d')@ ms

Date: @DataSetDate@

Operator: @DataSetAuthor@

Test No.: @DataSetTitle@
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The report looks like this:

End of Exercise A-2 
The Crash_2.vbs script, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise A-3 
Objective: Displaying the Data Scaled

In the following exercise you display the resultant calculated in the previous 
exercise scaled. Scaled display is useful for comparing different results.

1. Select DIAdem REPORT.

2. Select Settings»Layout parameters and set scaled display as shown in 
the following figure:

Click OK. DIAdem makes the axis system smaller.

3. Double-click the axis system to open the dialog box for curve and axis 
definition.
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4. Click Axis definition and select Units per unit length for 
Scaling defined by:
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5. Click Scaling and set fixed scaling for the x-axis as shown in the 
following figure:

6. Select Y-axis and set the dialog box parameters as shown in the 
following figure:

Click OK to close all the dialog boxes.

7. Position the axis system in the worksheet and resize the axis system as 
shown in the following figure:
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The report looks like this:

End of Exercise A-3 
The Crash_3.tdr layout, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise A-4 
Objective: Creating an AVS Diagram

AVS diagrams show the acceleration, velocity, and displacement over time.

In the following exercise you use a CFC 60 filter to filter the vehicle delay 
values. You use multiple integration to specify the velocity and the 
displacement from the filtered values. You then display the acceleration, the 
velocity, and the displacement in one axis system with separate y-axes.

1. Select DIAdem NAVIGATOR.

2. Delete the data in the Data Portal without saving the data.

3. Navigate to the Crash_4.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal. 

4. Select DIAdem ANALYSIS.

5. Open the Crash analysis functions function bar and select Filtering.

Set the parameters for filtering data with a CFC 60 filter as shown in the 
following figure:

Click Execute.

6. Click the Calculator in the toolbar.

7. Enter the following formula in the entry field to convert the signal, 
which was measured in g, to the unit m/s²:
Ch('A_tun_hor_si'):='FilteredSignal' * 9.81
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Click Calculate and Close the Calculator.

8. Open the Basic mathematic functions function bar and select 
Integration to specify the velocity from the delay. Check the parameters 
as shown below:

Click Execute.

9. Click the Calculator in the toolbar.

10. Enter the following formula in the entry field to assign the channel name 
Velocity to the result channel:
CN('Y_Integral'):='Velocity'

Click Calculate.
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11. Enter the following formula in the entry field to subtract the values of 
the Velocity channel from the impact velocity values. The first 
comment line of the data set properties contains the velocity at the time 
of impact.
Ch('Abs_velocity'):=val(DataSetComment(1))-'Velocity'

Click Calculate and Close the Calculator.

12. Open the Basic mathematic functions function bar and select 
Integration. Check the parameters as shown in the following figure:

Click Execute.

13. Click the Calculator in the toolbar.

14. Enter the following formula in the entry field to assign the channel name 
Displacement to the result channel:
CN('Y_Integral'):='Displacement'
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Click Calculate.

15. Enter the following formula in the entry field to convert the signal, 
which was measured in meters, to the unit millimeters:
Ch('Displacement_mm'):='Displacement' * 1000

Click Calculate and Close the Calculator.

16. Select DIAdem REPORT.

17. Click Load layout without saving the current layout.

Navigate to the Crash_4.tdr layout in the C:\Exercises\DIAdem 
Basics\ folder and load the prepared layout.

18. Double-click the axis system to open the dialog box for curve and axis 
definition.

19. Click Subaxes and then click New axis twice to define two additional 
y-axes as shown in the following figure:
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Click OK.

20. Assign the subaxes to the three curves as shown in the following figure:

21. Click Axis definition. 

22. Click Scaling to enter the fixed scaling for the first y-subaxis as shown 
in the following figure:
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Click OK.

23. Click Labeling and select Y-axis to check the labeling for the additional 
y-axes.

• Subaxis 2 X-1/Y-2: Velocity [m/s]

• Subaxis 3 X-1/Y-3: Displacement [mm]

Click OK to close all the dialog boxes.

24. Click Save layout as.

Open the C:\Exercises\DIAdem Basics\ folder and save the 
layout as AVS.tdr.
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The report looks like this:

End of Exercise A-4 
The Crash_4.vbs script, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise A-5 
Objective: Inspecting the Signal for Exceeded Limits

In the following exercise you check the calculated velocity. You manually 
enter the limits and display the velocity and the boundary curve in an axis 
system. This determines whether the signal is in the specified corridor.

1. In the Data Portal, open the shortcut menu for the channel group 
Crash_4 and select New»Channel.

Set the parameters as shown in the following figure to specify two new 
channels:

Click OK.

2. Select DIAdem VIEW.

3. Open the Predefined screen partitioning function bar and select One 
channel table with all channels.

4. In the channel table for the new channels Channel_01 and 
Channel_02, enter the channel names CorrX and CorrY and the 
channel values shown in the following figure:

5. Select DIAdem REPORT.

6. Click Load layout.

Navigate to the Crash_5.tdr layout in the C:\Exercises\DIAdem 
Basics\ folder and load the layout.
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7. Select the channels CorrX and CorrY in the Data Portal and drag and 
drop these two data channels into the axis system.

8. Double-click the axis system to open the dialog box for curve and axis 
definition and select the second curve:

9. Click Curve param to select the line style as shown in the following 
figure:
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Click OK to close all the dialog boxes.

10. Select DIAdem NAVIGATOR.

11. Select the channels CorrX and CorrY in the Data Portal to save these 
data for other evaluations.

12. Drag and drop the selected channels to the MyTraining data storage 
tree. Enter the filename MyCorridor.tdm.

Check whether the checkbox Only elements selected in the Data 
Portal is selected, and click Save. 

13. Select DIAdem REPORT.
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The report looks like this:

End of Exercise A-5 
The Crash_5a.tdr layout, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise A-6 
Objective: Automating the Corridor Check

In the following exercise you automate the process of checking the velocity 
signal for certain limit ranges. You display the boundary curve, the signal, 
and the results in a report.

To mathematically compare the velocity with the corridor curve, the two 
signals must have a common x-channel. Interpolate the missing values in the 
corridor curve.

1. Select DIAdem SCRIPT.

2. Click Enable recording mode in the toolbar.

3. Comment the script.

Click OK.

4. Select DIAdem NAVIGATOR.

5. Delete the data in the Data Portal without saving the data.

6. Navigate to the data files Crash_6.tdm and Corridor.tdm in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the files 
into the Data Portal. 

7. Select DIAdem ANALYSIS.
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8. Open the Curve fitting functions function bar and select Linear 
mapping. Set the parameters as shown in the following figure:

Click Execute.

9. Select DIAdem REPORT.

10. Click Load layout.

Navigate to the Crash_6.tdr layout in the C:\Exercises\DIAdem 
Basics\ folder and load the layout.

11. Select DIAdem SCRIPT.

12. Click Disable recording mode in the toolbar.

The TeachIn(1).vbs script appears in the script editor.

13. Enter the following instructions after the mapping function call:
...
Call ChnMapLinCalc(3,4,1,5,1,"const. value",NoValue,_
                   "analogue")
Call FormulaCalc("Ch('Difference'):= 'Lin_Image'-"&_
                "'Velocity'")
If CMin("Difference") < 0 Then
  T1= "Velocity is not OK!"
Else
  T1= "Velocity is OK!"
End If
...

The Crash_6.tdr report uses the T1 variable to display the results 
contained in the command lines, in the report.

14. Click Save file as. 

Open the C:\Exercises\DIAdem Basics\ folder and save the script 
as CrashTraining.vbs.

15. Click Run script in the toolbar to test the CrashTraining.vbs script.
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The report looks like this:

The associated CrashTraining.vbs script contains the following 
instructions:
Call DataDelAll(1)
Call DataFileLoad("Crash_6.tdm","","") 
Call DataFileLoad("Corridor.tdm","","") 
Call ChnMapLinCalc(3,4,1,5,1,"const. value",NoValue,_
                   "analogue")
Call FormulaCalc("Ch('Difference'):= 'Lin_Image'-"&_
                 "'Velocity'")
If CMin("Difference") < 0 Then
  T1= "Velocity is not OK!"
Else
  T1= "Velocity is OK!"
End If
Call PicLoad("Crash_6.tdr")
Call PicUpdate()

Note For clarity, the scripts do not have comment lines.

End of Exercise A-6 
The Crash_6.vbs script, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise A-7 
Objective: Using the Corridor Check for any Data Sets

In the following exercise you add a file selection dialog box to the script 
from the last exercise, to enable you to select and check any number of data 
files.

1. Select DIAdem SCRIPT.

2. Edit the CrashTraining.vbs script.

3. Add the following instructions at the beginning of the script:
Call FileNameGet("Navigator","FileRead")
If (DlgState = "IDOk") Then
...

4. Add the following instruction at the end of the script:
...
End If

5. Replace the Crash_6 parameter of the DataFileLoad command by 
the FileDlgName variable:
...
Call DataFileLoad(FileDlgName,"","") 
Call DataFileLoad("Corridor.tdm","","")

6. Click Save file as. 

Open the C:\Exercises\DIAdem Basics\ folder and save the 
modified script as CrashTraining.vbs.

7. Click Run script in the toolbar to test the CrashTraining.vbs script.

Navigate to the data files Crash_6a.tdm and Crash_6b.tdm in the 
C:\Exercises\DIAdem Basics\ folder and use these data files to 
check the script.
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If you load the Crash_6b.tdm data file the report looks like this:

The associated CrashTraining.vbs script contains the following 
instructions:
Call FileNameGet("Navigator","FileRead")
If (DlgState = "IDOk") Then
  Call DataDelAll(1)
  Call DataFileLoad(FileDlgName,"","")
  Call DataFileLoad("Corridor.tdm","","")
  Call ChnMapLinCalc(3,4,1,5,1,"const. value",NoValue,_
                     "analogue")
    Call FormulaCalc("Ch('Difference'):= 'Lin_Image'-_
                   'Velocity'")
  If CMin("Difference") < 0 Then
    T1= "Velocity is not OK!"
  Else
    T1= "Velocity is OK!"
  End If

  Call PicLoad("Crash_6.tdr")
  Call PicUpdate()
End If

End of Exercise A-7 
The Crash_7.vbs script, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise A-8 
Objective: Finding a Trigger and Isolating a Signal Range

In a crash test, the vehicle impact time recording does not trigger. 

In the following exercise you use the find function to specify the time of 
the vehicle impact. You isolate a signal section that is 200 ms wide, starting 
from this trigger.

1. Select DIAdem SCRIPT.

2. Click Enable recording mode in the toolbar.

3. Comment the script and click OK.

4. Select DIAdem NAVIGATOR.

5. Delete the data in the Data Portal without saving the data.

6. Navigate to the Crash_8.tdm data file in the 
C:\Exercises\DIAdem Basics\ folder and drag and drop the file 
into the Data Portal. 

7. Select DIAdem VIEW.

8. Click the Calculator in the toolbar.

9. Enter the following formula in the entry field to check the horizontal 
head acceleration A_head_x for a value that is greater than 10 g:
L1:=find(abs('A_head_x') > 10)

Click Calculate.
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10. Enter the following formula in the entry field to determine the associated 
time:
R1:=ChD(L1,'Time_1')

Click Calculate.

11. Enter the following formula in the entry field to determine the actual 
impact time. The impact is 5 ms before the 10 g threshold is exceeded:
L2:=find('Time_1' > R1-0.005)

Click Calculate.

12. Enter the following formula in the entry field to determine the end time 
of the range to be isolated:
L3:=find('Time_1' > R1-0.005+0.200)
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Click Calculate and Close the Calculator.

13. In the Data Portal, open the shortcut menu for the channel group 
Crash_8 and select New»Channel.

Set the parameters as shown in the following figure to create four new 
channels:

Click OK.

14. Open the Predefined screen partitioning function bar and select One 
channel table with all channels.

15. Click table cell 222 (L2) of the first channel Time_1 and select all the 
data in the channels Time_1, A_head_x, A_head_y, and A_head_z, 
up to table cell 1778 (L3) of the A_head_z channel. 

16. Select Copy in the shortcut menu. 

17. Click the first table cell in the new Channel_01 channel and select 
Paste in the shortcut menu. 

18. Select DIAdem SCRIPT.

19. Click Disable recording mode in the toolbar.
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20. Edit the recorded script and replace the last two instructions for copying 
data with the following instruction for copying blocks:
...
Call DataBlCopy("1-4",L2,L3-L2+1,"5-8",1)

21. Add the following lines after the last instruction:
...
CN(5) = "Time"
CN(6) = "A_head_hor"
CN(7) = "A_head_ver"
CN(8) = "A_head_lat"

22. Click Save file as. 

Open the C:\Exercises\DIAdem Basics\ folder and save the script 
as Trigger.vbs.

23. Click Run script in the toolbar to test the Trigger.vbs script.

Navigate to the Crash_8.tdr layout in the C:\Exercises\DIAdem 
Basics\ folder to check the script.

The associated script Trigger.vbs contains the following 
instructions:
Call DataDelAll(1)
Call DataFileLoad("Crash_8.tdm","","")

L1 = find("abs('A_head_x') > 10")
R1 = ChD(L1, "Time_1")
L2 = find("'Time_1' > (R1-0.005)")
L3 = find("'Time_1' > ((R1-0.005)+0.200")

Call ChnAlloc("Channel_01",1024,4,DataTypeFloat64,_
              "Numeric",1,5)
Call DataBlCopy("1-4",L2,L3-L2+1,"5-8",1)

CN(5) = "Time"
CN(6) = "A_head_hor"
CN(7) = "A_head_ver"
CN(8) = "A_head_lat"

End of Exercise A-8 
The Crash_8.vbs script, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise A-9 
Objective: Calculating a Dummy-Head Evaluation for a Section of the Signal

In the following exercise you add a dummy-head evaluation of the isolated 
signal to the script from the last exercise.

1. Select DIAdem SCRIPT.

2. Click Open file.

Navigate to the prepared script Crash_2.vbs in the 
C:\Exercises\DIAdem Basics\ folder and load the script.

3. Create the following procedure from the Crash2.vbs script and 
change the channel references as shown in the following figure:
Sub Do_Head
  Call ChnCFCFiltCalc(5,6,12,"CFC_1000",0,"EndPoints",10)
  CN(12) = "A_head_hor_f1000"

  Call ChnCFCFiltCalc(5,7,13,"CFC_1000",0,"EndPoints",10)
  CN(13) = "A_head_ver_f1000"

  Call ChnCFCFiltCalc(5,8,14,"CFC_1000",0,"EndPoints",10)
  CN(14) = "A_head_lat_f1000"

  Call ChnXYZAbsValue(12,13,14,15)
  Call ChnHICCalc(5,15,0,0,1,0,0)
  Call ChnXMSCalc(5,15,3,0,"in one peak")
  Call ChnPeakFind(5,15,16,17,1,"Max.Peaks",_
                  "Amplitude")

  Call PicLoad("Crash_9.tdr")
  Call PicUpdate()
End Sub

4. Select these instructions.

5. Click Copy in the toolbar.

6. Select File»Close to close the modified script, without saving the script.

7. Click the tab at the bottom of the script editor to switch to the 
Trigger.vbs script. 

8. Click Paste in the toolbar to add the copied instructions at the beginning 
of the Trigger.vbs script.
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9. Group the instructions into the following procedure Get_Section:
Sub Get_Section
  Call DataDelAll(1)
  Call DataFileLoad("Crash_8.tdm","","")

  L1 = find("abs('A_head_x') > 10")
  R1 = ChD(L1,"Time_1")
  L2 = find("'Time_1' > (R1-0.005)")
  L3 = find("'Time_1' > ((R1-0.005)+0.200")

  Call ChnAlloc("Channel_01",1024,4,DataTypeFloat64,_
              "Numeric",1,5)
  Call DataBlCopy("1-4",L2,(L3-L2)+1,"5-8",1)

  CN(5) = "Time"
  CN(6) = "A_head_hor"
  CN(7) = "A_head_ver"
  CN(8) = "A_head_lat"
End Sub

10. Add the following instructions for starting the procedure, at the end of 
the script:
...
Call Get_Section()
Call Do_Head()

11. Click Save file as. 

Open the C:\Exercises\DIAdem Basics\ folder and save the script 
as Crash.vbs.

12. Click Run script in the toolbar to test the Crash.vbs script.

The associated script Crash.vbs contains the following instructions:
Sub Do_Head()
  Call ChnCFCFiltCalc(5,6,12,"CFC_1000",0,"EndPoints",10)
  CN(12) = "A_head_hor_f1000"

  Call ChnCFCFiltCalc(5,7,13,"CFC_1000",0,"EndPoints",10)
  CN(13) = "A_head_ver_f1000"

  Call ChnCFCFiltCalc(5,8,14,"CFC_1000",0,"EndPoints",10)
  CN(14) = "A_head_lat_f1000"

  Call ChnXYZAbsValue(12,13,14,15)
  Call ChnHICCalc(5,15,0,0,1,0,0)
  Call ChnXMSCalc(5,15,3,0,"in one peak")
  Call ChnPeakFind(5,15,16,17,1,"Max.Peaks","Amplitude")
  Call PicLoad("Crash_9.tdr")
  Call PicUpdate()
End Sub
’..................................................
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Sub Get_Section()
  Call DataDelAll(1)
  Call DataFileLoad("Crash_8.tdm","","")
  L1 = find("abs('A_head_x') > 10")
  R1 = ChD(L1,"Time_1")
  L2 = find("'Time_1' > (R1-0.005)")
  L3 = find("'Time_1' > ((R1-0.005)+0.200")
  
  Call ChnAlloc("Channel_01",1024,4,DataTypeFloat64,_
                "Numeric",1,5)
  Call DataBlCopy("1-4",L2,(L3-L2)+1,"5-8",1)
  
  CN(5) = "Time"
  CN(6) = "A_head_hor"
  CN(7) = "A_head_ver"
  CN(8) = "A_head_lat"
End Sub
’..................................................
Call Get_Section()
Call Do_Head()

End of Exercise A-9 
The Crash_9.vbs script, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Exercise A-10 
Objective: Localizing All the Events in the Signal.

In the following exercise you modify the script from the last exercise to run 
the script repeatedly. You extend the mathematical functions that you use to 
specify the curve characteristics and to isolate a certain event, so that you 
can find and evaluate all the relevant sections.

1. Select DIAdem SCRIPT.

2. Delete the following instructions from the Do_Head procedure.
...
  Call PicLoad("Crash_9.tdr")
  Call PicUpdate()
...

3. Modify the Get_Section procedure as shown in the following script, 
to enable you to start the find function at a variable position:
Sub Get_Section
  L1 = find("abs('A_head_x') > 10", L5)
  R1 = ChD(L1, "Time_1")
  L2 = find("'Time_1' > (R1-0.005)", L5)
  L3 = find("'Time_1' > ((R1-0.005)+0.200", L5)

  Call DataBlCopy("1-4",L2,L3-L2+1,"5-8",1)
  Call FormulaCalc("Ch(5) := Ch(5)-ChD(1,5)")

  CN(5) = "Time"
  ...
End Sub

4. Specify the following Def_Picture procedure after the Do_Head 
procedure to display the partial results in a report. The procedure stops 
the script until the user presses any key.
Sub Def_Picture
  Call GraphObjOpen("2DAxis2")
    D2ConstX(4) = Chd(L2,"Time_1")
    D2ConstX(5) = Chd(L3,"Time_1")
  Call GraphObjClose("2DAxis2")
  Call PicUpdate()
 End Sub
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5. After the Def_Picture procedure, add the following instructions, 
which load the data from a turnover test and load the associated layout:
...
Call PicLoad("Crash_10.tdr")

Call DataDelAll(1)
Call DataFileLoad("Crash_10.tdm")

Call Get_Section()
...

6. Specify the following loop, which localizes all the events in the signal:
...
L5 = 1
Do
  Call Get_Section()
  Call Do_Head()
  Call Def_Picture()
  L5 = L3
Loop Until (find("abs('A_head_x') > 10", L5)) = 0

7. Click Save file as. 

Open the C:\Exercises\DIAdem Basics\ folder and save the script 
as Crash.vbs.

8. Click Run script in the toolbar to test the Crash.vbs script.

Click the space bar to continue the script.

The associated script Crash.vbs contains the following instructions:
Sub Get_Section()
  L1 = find("abs('A_head_x') > 10", L5)
  R1 = ChD(L1, "Time_1")
  L2 = find("'Time_1' > (R1-0.005)", L5)
  L3 = find("'Time_1' > ((R1-0.005)+0.200", L5)

  Call DataBlCopy("1-4",L2,(L3-L2)+1,"5-8",1)

  Call FormulaCalc("Ch(5) := Ch(5)-ChD(1,5)")

  CN(5) = "Time"
  CN(6) = "A_head_hor"
  CN(7) = "A_head_ver"
  CN(8) = "A_head_lat"
End Sub
’..................................................
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Sub Do_Head()
  Call ChnCFCFiltCalc(5,6,12,"CFC_1000",0,"EndPoints",10)
  CN(12) = "A_head_hor_f1000"

  Call ChnCFCFiltCalc(5,7,13,"CFC_1000",0,"EndPoints",10)
  CN(13) = "A_head_ver_f1000"

  Call ChnCFCFiltCalc(5,8,14,"CFC_1000",0,"EndPoints",10)
  CN(14) = "A_head_lat_f1000"

  Call ChnXYZAbsValue(12,13,14,15)
  Call ChnHICCalc(5,15,0,0,1,0,0)
  Call ChnXMSCalc(5,15,3,0,"in one peak")
  Call ChnPeakFind(5,15,16,17,1,"Max.Peaks","Amplitude")
End Sub

’..................................................
Sub Def_Picture
  Call GraphObjOpen("2DAxis2")
    D2ConstX(4) = Chd(L2,"Time_1")
    D2ConstX(5) = Chd(L3,"Time_1")
  Call GraphObjClose("2DAxis2")

  Call PicUpdate()
End Sub

’..................................................
Call PicLoad("Crash_10.tdr")
Call DataDelAll(1)
Call DataFileLoad("Crash_10.tdm")

L5 = 1
Do
  Call Get_Section()
  Call Do_Head()
  Call Def_Picture()
  L5 = L3
Loop Until (find("abs('A_head_x') > 10", L5)) = 0
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When the script runs through the first time, the report looks like this:

End of Exercise A-10 
The Crash_10.vbs script, which contains the solution for this exercise, is 
in the C:\Solutions\DIAdem Basics\ folder.
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Summary, Tips, and Tricks

• DIAdem contains many basic mathematical functions for standardized 
crash test evaluation, such as integration, differentiation, statistics 
functions, and digital filtering. DIAdem also provides the Calculator for 
free calculation of resulting acceleration values. 

• The DIAdem Crash Analysis Toolset includes a number of special crash 
analysis functions. 

• To document and present the results, use the extensive graphic display 
functions in DIAdem REPORT.

• DIAdem stores the results of the various crash functions in new channels 
in the Data Portal or in variables. You can display the variables in 
message boxes, use the variables in formulas, or document the variables 
in tables and text in your report.

• For the complete evaluation of a crash test, you can create scripts that 
run the calculations automatically and generate a standardized report. 
You also can use scripts to automate dummy calibrations and limit value 
checks.
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Notes
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